aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/libnet-pcap-perl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 13:54:08 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:47:16 +0300
commit3157d6d6cb9f87d6086126b5e7b42c4dc87ebb81 (patch)
tree163865bf0c2a6879781d55678a13a2956927fcd6 /recipes/perl/libnet-pcap-perl
parente1db194438b7badd98163418379f096c8ddb7eb5 (diff)
downloadopenembedded-3157d6d6cb9f87d6086126b5e7b42c4dc87ebb81.tar.gz
libnet-pcap-perl: add Net::Pcap Perl module
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl/libnet-pcap-perl')
-rw-r--r--recipes/perl/libnet-pcap-perl/kill-runtime-pcap-check-fake-functions-check.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/perl/libnet-pcap-perl/kill-runtime-pcap-check-fake-functions-check.patch b/recipes/perl/libnet-pcap-perl/kill-runtime-pcap-check-fake-functions-check.patch
new file mode 100644
index 0000000000..72b3eb7c9f
--- /dev/null
+++ b/recipes/perl/libnet-pcap-perl/kill-runtime-pcap-check-fake-functions-check.patch
@@ -0,0 +1,32 @@
+Index: Net-Pcap-0.16/Makefile.PL
+===================================================================
+--- Net-Pcap-0.16.orig/Makefile.PL 2010-02-02 16:50:32.000000000 +0300
++++ Net-Pcap-0.16/Makefile.PL 2010-02-02 18:14:50.000000000 +0300
+@@ -444,7 +444,7 @@
+ close($cfile);
+ my $quote = $is_Win32 ? '"' : "'";
+ xsystem("$^X Makefile.PL " . join(' ', map { "${quote}$_=$options{$_}${quote}" } keys %options));
+- xsystem("$Config{make} test ${quote}OTHERLDFLAGS=${opt}${quote}");
++# xsystem("$Config{make} test ${quote}OTHERLDFLAGS=${opt}${quote}");
+ } # end try_link0
+
+ sub try_link {
+@@ -530,14 +530,11 @@
+ my @funcs = ();
+ print "detecting available functions... ";
+
+- my @paths = DynaLoader::dl_findfile(qw(-lpcap));
+- my $libref = DynaLoader::dl_load_file($paths[0]);
+-
+- for my $func (@_) {
+- my $symref = DynaLoader::dl_find_symbol($libref, $func);
+- push @funcs, $func if defined $symref
+- }
++ my $objdump = $ENV{'OBJDUMP'};
++ my $st_libdir = $ENV{'STAGING_LIBDIR'};
++ @funcs=`$objdump -t $st_libdir/libpcap.so | grep F | grep ".text" | awk '{print \$6}' | grep "^pcap_"`;
+
++ chomp(@funcs);
+ print "ok\n";
+ return @funcs
+ }