aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/libnet-rawip-perl_0.25.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 17:54:02 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:48:11 +0300
commitd0b135ec2b3fccec83b1d6aa93099ae52aaf5d63 (patch)
tree0d843040a1720783dc1abd86aa69cc8e596347b5 /recipes/perl/libnet-rawip-perl_0.25.bb
parentad300b99dbb3bfbe7fbc22f04416ae97b1f69671 (diff)
downloadopenembedded-d0b135ec2b3fccec83b1d6aa93099ae52aaf5d63.tar.gz
libnet-rawip-perl: add Net::RawIP Perl module
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl/libnet-rawip-perl_0.25.bb')
-rw-r--r--recipes/perl/libnet-rawip-perl_0.25.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/perl/libnet-rawip-perl_0.25.bb b/recipes/perl/libnet-rawip-perl_0.25.bb
new file mode 100644
index 0000000000..ec57c7a9cf
--- /dev/null
+++ b/recipes/perl/libnet-rawip-perl_0.25.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Perl extension to manipulate raw IP packets with interface to libpcap"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libpcap"
+RDEPENDS = " \
+ perl-module-class-struct \
+ perl-module-data-dumper \
+ perl-module-english \
+ perl-module-getopt-long \
+ perl-module-subs \
+ perl-module-test-more \
+ "
+
+SRC_URI = " \
+ http://search.cpan.org/CPAN/authors/id/S/SA/SAPER/Net-RawIP-${PV}.tar.gz;name=net-rawip-perl-${PV} \
+ file://kill-pcap-check.patch;patch=1 \
+ "
+SRC_URI[net-rawip-perl-0.25.md5sum] = "a99f461e20e7894154f64729a4652448"
+SRC_URI[net-rawip-perl-0.25.sha256sum] = "6d104b2f0e453eff7a1b479c528798670b15729ed6ecf41430405ff6d7e1ee58"
+
+S = "${WORKDIR}/Net-RawIP-${PV}"
+
+inherit cpan