aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/libxml-libxml-perl_1.70.bb
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-01-22 00:03:33 +0000
committerPhilip Balister <philip@balister.org>2010-01-22 09:24:50 -0500
commitca64b38e43edd7379ea7a95cda8976f010cd54bf (patch)
treed5d98b583955737399b8b935192ac9284d6e9d4e /recipes/perl/libxml-libxml-perl_1.70.bb
parent71edf0fca9bdbb903170e4b20b911cabdaa6ff7d (diff)
downloadopenembedded-ca64b38e43edd7379ea7a95cda8976f010cd54bf.tar.gz
libxml-libxml-perl: Adds perl module XML::LibXML
Signed-off-by: Philip Balister <philip@balister.org>
Diffstat (limited to 'recipes/perl/libxml-libxml-perl_1.70.bb')
-rw-r--r--recipes/perl/libxml-libxml-perl_1.70.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/perl/libxml-libxml-perl_1.70.bb b/recipes/perl/libxml-libxml-perl_1.70.bb
new file mode 100644
index 0000000000..ac56c9f4ad
--- /dev/null
+++ b/recipes/perl/libxml-libxml-perl_1.70.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "XML-LibXML"
+SECTION = "libs"
+LICENSE = ""
+DEPENDS += "libxml2 \
+ libxml-sax-perl \
+ zlib \
+"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PA/PAJAS/XML-LibXML-${PV}.tar.gz;name=libxml \
+ file://libxml-libxml-perl-disable-libxml2-check.patch;patch=1 \
+"
+SRC_URI[libxml.md5sum] = "33d4294f708e20c298cfe534d1166844"
+SRC_URI[libxml.sha256sum] = "53e6cf06772ba9d85055dc6e4488dbd876d2376e48ef3578fa73246ee98b3ba0"
+
+S = "${WORKDIR}/XML-LibXML-${PV}"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
+
+BBCLASSEXTEND = "native"
+
+CFLAGS += " -D_GNU_SOURCE "