aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.10.1.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-21 07:46:44 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-21 07:49:51 -0700
commit2a548400c6c7fe47c23b8ba513135e81297b68cd (patch)
tree8895516b9270cbd49bc345861bcdb31dd6478129 /recipes/perl/perl-native_5.10.1.bb
parentc3b5b68541320ed0104d8654a0793251ed0187b9 (diff)
downloadopenembedded-2a548400c6c7fe47c23b8ba513135e81297b68cd.tar.gz
perl-native: Mangle scripts to use /usr/bin/env perl
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl/perl-native_5.10.1.bb')
-rw-r--r--recipes/perl/perl-native_5.10.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index b5e8bf421e..61d57f4b2b 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r5"
+PR = "r6"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
@@ -103,7 +103,13 @@ do_install() {
# Fix Errno.pm for target builds
sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm
+
+ # Make sure we use /usr/bin/env perl
+ for PERLSCRIPT in `grep -rIl ${bindir}/perl ${D}${bindir}`; do
+ sed -i -e 's|^#!${bindir}/perl|#!/usr/bin/env perl|' $PERLSCRIPT
+ done
}
+
do_install_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do