aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-10 17:05:04 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-10 17:05:04 +0000
commit4c2fcc5f95e446ebeb4c59c873d517de85409ff9 (patch)
treeb9f1b1c72775d4accca4279b4d6284eceebb4710 /recipes/perl/perl-native_5.8.8.bb
parentd7e645662fcaaa1a99e73110bde21265eec0a461 (diff)
downloadopenembedded-4c2fcc5f95e446ebeb4c59c873d517de85409ff9.tar.gz
perl-native: Fix after layout/native.bbclass changes (merged from Poky)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index bde7638137..cac474edc4 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -66,10 +66,10 @@ do_stage_append() {
# We need a hostperl link for building perl
ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
# Store native config in non-versioned directory
- install -d ${STAGING_DIR_HOST}/perl \
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${STAGING_DIR_HOST}/perl
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl
# target configuration
install lib/Config.pm ${STAGING_LIBDIR_NATIVE}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/