summaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 15:09:38 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 15:09:38 +0000
commit7596f868583c6ef0897a869a89edc5dd4525206d (patch)
treeb00e4aceb555f01da38f64ae5ebbe4b38cdc28dc /recipes/perl/perl_5.8.8.bb
parentefbc7fe76ca09c3e760d1d42c35f97312a068ff6 (diff)
downloadopenembedded-7596f868583c6ef0897a869a89edc5dd4525206d.tar.gz
perl-5.8.8: use LDFLAGS for shared libraries (fixes QA error)
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2118bba68f..521cdf65e5 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r26"
+PR = "r27"
# Major part of version
PVM = "5.8"
@@ -29,6 +29,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://62_debian_cpan_definstalldirs.patch;patch=1 \
file://64_debian_enc2xs_inc.patch;patch=1 \
file://asm-pageh-fix.patch;patch=1 \
+ file://shared-ldflags.patch;patch=1 \
file://config.sh \
file://config.sh-32 \
file://config.sh-32-le \
@@ -43,6 +44,9 @@ HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"
# Where to find .so files - use the -native versions not those from the target build
export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl/${PV}/"
+# LDFLAGS for shared libraries
+export LDDLFLAGS = "${LDFLAGS} -shared"
+
do_configure() {
# Make hostperl in build directory be the native perl
cp -f ${HOSTPERL} hostperl