aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 17:06:27 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:47:57 +0300
commit6ca2812e04a7da80277d74d78b30df2483960a16 (patch)
tree4f8ed56b3e253724f4e6ed0ad44e48f4b8ea06d7 /recipes/perl
parent0539ea049ee9a5be063d7c40d7bbc015ea682002 (diff)
downloadopenembedded-6ca2812e04a7da80277d74d78b30df2483960a16.tar.gz
libmail-spf-perl: add Mail::SPF Perl module
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libmail-spf-perl/fix-sbin-native-install.patch13
-rw-r--r--recipes/perl/libmail-spf-perl_2.007.bb36
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes/perl/libmail-spf-perl/fix-sbin-native-install.patch b/recipes/perl/libmail-spf-perl/fix-sbin-native-install.patch
new file mode 100644
index 0000000000..8654997d30
--- /dev/null
+++ b/recipes/perl/libmail-spf-perl/fix-sbin-native-install.patch
@@ -0,0 +1,13 @@
+Index: Mail-SPF-v2.006/Build.PL
+===================================================================
+--- Mail-SPF-v2.006.orig/Build.PL 2009-08-24 14:56:24.000000000 +0400
++++ Mail-SPF-v2.006/Build.PL 2009-08-24 14:56:59.000000000 +0400
+@@ -69,7 +69,7 @@
+ 'bin/spfquery'
+ ],
+ install_path => {
+- 'sbin' => '/usr/sbin'
++ 'sbin' => $ENV{'sbindir'}
+ },
+ create_makefile_pl
+ => 'passthrough',
diff --git a/recipes/perl/libmail-spf-perl_2.007.bb b/recipes/perl/libmail-spf-perl_2.007.bb
new file mode 100644
index 0000000000..b4fdd05923
--- /dev/null
+++ b/recipes/perl/libmail-spf-perl_2.007.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Mail::SPF - An object-oriented implementation of Sender Policy Framework"
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = " \
+ liberror-perl-native \
+ libnet-dns-perl-native \
+ libnet-dns-resolver-programmable-perl-native \
+ libnetaddr-ip-perl-native \
+ liburi-perl-native \
+ "
+RDEPENDS_${PN} += " \
+ liberror-perl \
+ libnet-dns-perl \
+ libnet-dns-resolver-programmable-perl \
+ libnetaddr-ip-perl \
+ liburi-perl \
+ perl-module-module-build \
+ perl-module-test-more \
+ perl-module-version \
+ "
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+
+SRC_URI = " \
+ http://search.cpan.org/CPAN/authors/id/J/JM/JMEHNLE/mail-spf/Mail-SPF-v${PV}.tar.gz;name=mail-spf-perl-${PV} \
+ file://fix-sbin-native-install.patch;patch=1 \
+ "
+SRC_URI[mail-spf-perl-2.007.md5sum] = "67dccdc91e3264679a0e17d493d3cc30"
+SRC_URI[mail-spf-perl-2.007.sha256sum] = "d8886e6a5b300946434284a6527bbb68ed98d27d3582c8e475e338facb96c50b"
+
+S = "${WORKDIR}/Mail-SPF-v${PV}"
+
+inherit cpan_build
+
+PACKAGE_ARCH = "all"