aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:29:57 +0200
committermd <md@freiheit.com>2009-05-27 21:51:01 +0200
commitf97874313a4eda554d1b833a953b1d5ae154df06 (patch)
treedbe9d415e68a68c712d5c8cd12a4e90e23e631af /recipes/perl
parentcb901464380fb0d06133f1c644d20653ad74c90f (diff)
downloadopenembedded-f97874313a4eda554d1b833a953b1d5ae154df06.tar.gz
perl-native: removed settings clashing with gcc 3 for nylon * Config_heavy.pl and config.sh contained the gcc flag `-Wdeclaration-after-statement' which broke the build with gcc 3, this is disabled for nylon now
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index e3d73845fc..57e9e1c394 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -85,5 +85,11 @@ do_stage_append() {
install $i ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE
done
}
+do_stage_append_nylon() {
+ # get rid of definitions not supported by the gcc version we use for nylon...
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
+ done
+}
PARALLEL_MAKE = ""