aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 15:05:15 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:47:35 +0300
commit5cbb23ba25e5c2379bf77601c59e04177192e264 (patch)
treef99ca0d40c216e0118ad9583c48509045a3a11a0 /recipes/perl
parenta590c1f068a8b5f4befb7e65233aa369d60c5b01 (diff)
downloadopenembedded-5cbb23ba25e5c2379bf77601c59e04177192e264.tar.gz
libauthen-pam-perl: add Authen::PAM Perl module
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libauthen-pam-perl_0.16.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/perl/libauthen-pam-perl_0.16.bb b/recipes/perl/libauthen-pam-perl_0.16.bb
new file mode 100644
index 0000000000..c8fdfa448d
--- /dev/null
+++ b/recipes/perl/libauthen-pam-perl_0.16.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Authen::PAM - Perl interface to PAM library"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libpam"
+RDEPENDS = "perl-module-posix"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-${PV}.tar.gz;name=authen-pam-perl-${PV}"
+SRC_URI[authen-pam-perl-0.16.md5sum] = "7278471dfa694d9ef312bc92d7099af2"
+SRC_URI[authen-pam-perl-0.16.sha256sum] = "0e949bd9a2a9df0f829971030fe9169cbaf6cec78b92faf22f547ff6c6155c9b"
+
+S = "${WORKDIR}/Authen-PAM-${PV}"
+
+do_configure_prepend () {
+ oenote Executing autoreconf --verbose --install --force
+ mkdir -p m4
+ autoreconf -Wcross --verbose --install --force || oefatal "autoreconf execution failed."
+ sed -i 's:\./configure\(.[^-]\):./configure --build=${BUILD_SYS} --host=${HOST_SYS} --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} --datadir=${datadir} --sysconfdir=${sysconfdir} --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} --libdir=${libdir} --includedir=${includedir} --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir}\1:' Makefile.PL
+}
+
+inherit cpan