summaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-02-09 15:34:42 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:45:24 +0300
commit5ae979b0ab285bc06fdd51c133379e91bea7de34 (patch)
tree28d7cb86bffa5c47443c27d5797b57c2a88bf5f5 /recipes/perl
parente7c6b93906b8909e659d7e680a1457472bc99bda (diff)
downloadopenembedded-5ae979b0ab285bc06fdd51c133379e91bea7de34.tar.gz
perl-native_5.8.8: allow architecture difference in host's Errno
Fixes build for packages that are using Errno Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index 632ff161d9..a872618491 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r15"
+PR = "r16"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -69,6 +69,8 @@ do_stage_append() {
install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
install config.sh ${STAGING_LIBDIR}/perl
+ # Fix Errno.pm for target builds
+ sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Errno.pm
# target configuration
install lib/Config.pm ${STAGING_LIBDIR_NATIVE}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/