summaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-07-11 20:51:15 +0000
committerKhem Raj <raj.khem@gmail.com>2010-07-13 20:25:06 -0700
commit5ce3d5e328aceacbc17a099e8db8a7d4bf9452a0 (patch)
tree8cde0225e191c2f5b118431657720148a29ab40c /recipes/perl
parente78de4e1cdb5b49831233d82c2fe7ea17884a870 (diff)
downloadopenembedded-5ce3d5e328aceacbc17a099e8db8a7d4bf9452a0.tar.gz
perl_5.8.8.bb: Don't use hostperl's $Config{cppflags} with cross compiler.
Fixes /usr/local/include Badness. make[2]: Entering directory `/home/grg/oe2/tmp/work/mipsel-oe-linux/perl-5.8.8-r34/perl-5.8.8/ext/Errno' hostperl -I/home/grg/oe2/tmp/work/mipsel-oe-linux/perl-5.8.8-r34/perl-5.8.8/Cross/../fake_config_library -MConfig Errno_pm.PL Errno.pm CROSS COMPILE Badness: /usr/local/include in INCLUDEPATH: /usr/local/include No error definitions found at Errno_pm.PL line 216. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl_5.8.8.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 4f4c468a78..f09360facf 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -104,7 +104,8 @@ do_configure() {
}
do_compile() {
if test "${MACHINE}" != "native"; then
- sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
+ sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' \
+ -e 's|$Config{cppflags}||' ext/Errno/Errno_pm.PL
fi
cd Cross
oe_runmake perl LD="${TARGET_SYS}-gcc"