aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-08-04 03:51:57 +0000
committerChris Larson <chris_larson@mentor.com>2010-08-04 09:07:15 -0700
commit6b53fcad4f2af012e762bbf6450831857ca29373 (patch)
treef1f992143f6504210464398760d5f69bb24cc1bf /recipes/perl
parent7bc322831d1ed3487d36dee4687b7fa3b5cc81e4 (diff)
downloadopenembedded-6b53fcad4f2af012e762bbf6450831857ca29373.tar.gz
perl: use only one method all_perl_packages
.. to avoid ERROR: Error Method already seen: all_perl_packages in' perl_5.8.8.bb' now in 'perl_5.10.1.bb' TODO: error() already prints "ERROR:" so the "Error" in above msg is redundant Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Acked-by: Roman I Khimov <khimov@altell.ru> Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl.inc8
-rw-r--r--recipes/perl/perl_5.10.1.bb7
-rw-r--r--recipes/perl/perl_5.8.8.bb7
3 files changed, 10 insertions, 12 deletions
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
new file mode 100644
index 0000000000..ddde0b8872
--- /dev/null
+++ b/recipes/perl/perl.inc
@@ -0,0 +1,8 @@
+# helper functions for perl
+def all_perl_packages(d):
+ depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
+ blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
+ for pkg in d.getVar("PACKAGES", True).split():
+ if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
+ yield pkg
+
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 75993b519a..a09c59dcbc 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -210,12 +210,7 @@ FILES_${PN}-doc = "${datadir}/perl/${PV}/*/*.txt \
RPROVIDES_perl-lib = "perl-lib"
-def all_perl_packages(d):
- depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
- for pkg in d.getVar("PACKAGES", True).split():
- if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
- yield pkg
+require perl.inc
# Create a perl-modules package recommending all the other perl
# packages (actually the non modules packages and not created too)
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index ed489f4ac5..c8ad895e56 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -210,12 +210,7 @@ FILES_${PN}-doc = "${datadir}/perl/${PV}/*/*.txt \
RPROVIDES_perl-lib = "perl-lib"
-def all_perl_packages(d):
- depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
- for pkg in d.getVar("PACKAGES", True).split():
- if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
- yield pkg
+require perl.inc
# Create a perl-modules package recommending all the other perl
# packages (actually the non modules packages and not created too)