summaryrefslogtreecommitdiffstats
path: root/recipes/phoneme
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-20 11:42:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-20 12:25:27 +0200
commit5b1ad58d47a63237d7b8f32590e63262a8ff3f11 (patch)
tree64694344d1e9e8b723ba717e99c2daece2e45b81 /recipes/phoneme
parentfe366ec1bbc8f60d3c7bcca23dfb557126bb12c1 (diff)
downloadopenembedded-5b1ad58d47a63237d7b8f32590e63262a8ff3f11.tar.gz
phoneme-advanced: add patch for build with (e)glibc-2.12 and fix QA issue with missing GNU_HASH
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/phoneme')
-rw-r--r--recipes/phoneme/files/b160-newer-libc.patch11
-rw-r--r--recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb5
-rw-r--r--recipes/phoneme/phoneme-advanced.inc4
3 files changed, 16 insertions, 4 deletions
diff --git a/recipes/phoneme/files/b160-newer-libc.patch b/recipes/phoneme/files/b160-newer-libc.patch
new file mode 100644
index 0000000000..814de0d1c2
--- /dev/null
+++ b/recipes/phoneme/files/b160-newer-libc.patch
@@ -0,0 +1,11 @@
+diff -uNr cdc.orig/src/linux/native/java/lang/UNIXProcess_md.c cdc/src/linux/native/java/lang/UNIXProcess_md.c
+--- cdc.orig/src/linux/native/java/lang/UNIXProcess_md.c 2010-08-20 11:25:25.000000000 +0200
++++ cdc/src/linux/native/java/lang/UNIXProcess_md.c 2010-08-20 11:32:33.000000000 +0200
+@@ -38,6 +38,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ #ifdef JDK
+ /* path in the environment */
diff --git a/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb b/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
index 34adeae570..5efce915cc 100644
--- a/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
+++ b/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
@@ -1,11 +1,12 @@
-PR = "r1"
+PR = "r2"
require phoneme-advanced.inc
BUILDREV = "b160"
SRCREV = "20424"
-SRC_URI += "file://${BUILDREV}-makefile-fix.patch;striplevel=0"
+SRC_URI += "file://${BUILDREV}-makefile-fix.patch;striplevel=0 \
+ file://${BUILDREV}-newer-libc.patch;striplevel=0"
FILES_${PN} += "\
${COMMON_DIR}/bin/cvm \
diff --git a/recipes/phoneme/phoneme-advanced.inc b/recipes/phoneme/phoneme-advanced.inc
index be3ff92790..b055875129 100644
--- a/recipes/phoneme/phoneme-advanced.inc
+++ b/recipes/phoneme/phoneme-advanced.inc
@@ -85,14 +85,14 @@ do_configure() {
pmo HOST_RANLIB "${BUILD_RANLIB}"
pmo "# C/C++ toolchain binaries"
- pmo TARGET_CC "${CC}"
+ pmo TARGET_CC "${CC} "
pmo TARGET_CC_PATH "${CC}"
pmo CCFLAGS "${CFLAGS}"
pmo TARGET_CCC "${CXX}"
pmo TARGET_PATH "${CXX}"
pmo CCCFLAGS "${CXXFLAGS}"
pmo TARGET_AR "${AR}"
- pmo TARGET_LD "${CC}"
+ pmo TARGET_LD "${CC} ${LDFLAGS}"
pmo TARGET_RANLIB "${RANLIB}"
pmo USE_GCC2 false