aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php/php-5.3.0
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-30 22:41:49 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-30 22:41:49 +0200
commit9236bee4400b2db9cddbdef8c08e3f71e2f322f7 (patch)
tree3ceb854a6411c10eba8cd4f1fd09f18a7895433f /recipes/php/php-5.3.0
parent9628f84b91574ba4c1f968ae49d8cbca3544f01c (diff)
downloadopenembedded-9236bee4400b2db9cddbdef8c08e3f71e2f322f7.tar.gz
php-native: add 5.3.0
Diffstat (limited to 'recipes/php/php-5.3.0')
-rw-r--r--recipes/php/php-5.3.0/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.3.0/pear-makefile.patch11
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/php/php-5.3.0/acinclude-xml2-config.patch b/recipes/php/php-5.3.0/acinclude-xml2-config.patch
new file mode 100644
index 0000000000..bf519d2934
--- /dev/null
+++ b/recipes/php/php-5.3.0/acinclude-xml2-config.patch
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+- for i in $PHP_LIBXML_DIR /usr/local /usr; do
+- if test -x "$i/bin/xml2-config"; then
+- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+- break
+- fi
+- done
++
++ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+ if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.3.0/pear-makefile.patch b/recipes/php/php-5.3.0/pear-makefile.patch
new file mode 100644
index 0000000000..26de98a48f
--- /dev/null
+++ b/recipes/php/php-5.3.0/pear-makefile.patch
@@ -0,0 +1,11 @@
+--- /pear/orig-Makefile.frag 2007-03-16 12:18:33.000000000 +0200
++++ /pear/Makefile.frag 2007-03-16 12:35:48.000000000 +0200
+@@ -6,7 +6,7 @@
+ PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=E_ALL -dmemory_limit=-1 -ddetect_unicode=0
+
+ install-pear-installer: $(SAPI_CLI_PATH)
+- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
++ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"