aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php/php_5.2.6.bb
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-09 14:11:33 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-09 21:13:28 +0000
commit86e1e0f6f61dc0277af696c498c5e129f88fb6ef (patch)
tree9c08260618091f81d955d4414d4d03976784b852 /recipes/php/php_5.2.6.bb
parent6170c93c39a1ac24c19d0b7172a672f157637fe7 (diff)
downloadopenembedded-86e1e0f6f61dc0277af696c498c5e129f88fb6ef.tar.gz
php_5.2.6.bb : add dependency on mysql, remove sqlite pdo as it doesnt build
Seems according to google to be some issue of bison vs lemon but the build failure seems to be fairly common.
Diffstat (limited to 'recipes/php/php_5.2.6.bb')
-rw-r--r--recipes/php/php_5.2.6.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/php/php_5.2.6.bb b/recipes/php/php_5.2.6.bb
index 0d9e1f42a5..8723a1e14f 100644
--- a/recipes/php/php_5.2.6.bb
+++ b/recipes/php/php_5.2.6.bb
@@ -1,8 +1,8 @@
require php.inc
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native"
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
-PR = "r6"
+PR = "r7"
SRC_URI += "file://pear-makefile.patch;patch=1 \
file://string.c.patch;patch=1 "
@@ -24,6 +24,7 @@ EXTRA_OECONF = " --without-iconv \
--with-libxml-dir=${STAGING_BINDIR_CROSS} \
--with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+ --without-pdo-sqlite \
"
export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"