aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/php
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php-5.2.6/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.2.6/pear-makefile.patch11
-rw-r--r--recipes/php/php-native.inc15
-rw-r--r--recipes/php/php-native_5.2.6.bb3
-rw-r--r--recipes/php/php.inc19
-rw-r--r--recipes/php/php_5.2.6.bb83
6 files changed, 149 insertions, 0 deletions
diff --git a/recipes/php/php-5.2.6/acinclude-xml2-config.patch b/recipes/php/php-5.2.6/acinclude-xml2-config.patch
new file mode 100644
index 0000000000..bf519d2934
--- /dev/null
+++ b/recipes/php/php-5.2.6/acinclude-xml2-config.patch
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+- for i in $PHP_LIBXML_DIR /usr/local /usr; do
+- if test -x "$i/bin/xml2-config"; then
+- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+- break
+- fi
+- done
++
++ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+ if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.2.6/pear-makefile.patch b/recipes/php/php-5.2.6/pear-makefile.patch
new file mode 100644
index 0000000000..26de98a48f
--- /dev/null
+++ b/recipes/php/php-5.2.6/pear-makefile.patch
@@ -0,0 +1,11 @@
+--- /pear/orig-Makefile.frag 2007-03-16 12:18:33.000000000 +0200
++++ /pear/Makefile.frag 2007-03-16 12:35:48.000000000 +0200
+@@ -6,7 +6,7 @@
+ PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=E_ALL -dmemory_limit=-1 -ddetect_unicode=0
+
+ install-pear-installer: $(SAPI_CLI_PATH)
+- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
++ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php-native.inc b/recipes/php/php-native.inc
new file mode 100644
index 0000000000..1698a80379
--- /dev/null
+++ b/recipes/php/php-native.inc
@@ -0,0 +1,15 @@
+require php.inc
+
+DEPENDS = "zlib-native libxml2-native"
+
+inherit autotools native pkgconfig
+export LIBS=" -lxml2 "
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
+
+EXTRA_OECONF = "--with-cgi --enable-sockets --enable-pcntl \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR_NATIVE}/.. \
+ --without-libpng --without-libjpeg \
+ --with-libxml-dir=${STAGING_BINDIR_NATIVE} \
+ "
+
+FILESPATH = "${FILE_DIRNAME}/php-${PV}:${FILE_DIRNAME}/php:${FILE_DIRNAME}/files"
diff --git a/recipes/php/php-native_5.2.6.bb b/recipes/php/php-native_5.2.6.bb
new file mode 100644
index 0000000000..ac1c51fa3f
--- /dev/null
+++ b/recipes/php/php-native_5.2.6.bb
@@ -0,0 +1,3 @@
+require php-native.inc
+
+PR = "r3"
diff --git a/recipes/php/php.inc b/recipes/php/php.inc
new file mode 100644
index 0000000000..e9d49a3269
--- /dev/null
+++ b/recipes/php/php.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
+HOMEPAGE = "http://www.php.net"
+SECTION = "console/network"
+LICENSE = "PHP"
+
+SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
+ file://acinclude-xml2-config.patch;patch=1"
+
+S = "${WORKDIR}/php-${PV}"
+
+inherit autotools
+
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+
+acpaths = ""
+
+do_install () {
+ oe_runmake 'INSTALL_ROOT=${D}' install
+}
diff --git a/recipes/php/php_5.2.6.bb b/recipes/php/php_5.2.6.bb
new file mode 100644
index 0000000000..2cf5e285e6
--- /dev/null
+++ b/recipes/php/php_5.2.6.bb
@@ -0,0 +1,83 @@
+require php.inc
+
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native"
+
+PR = "r4"
+
+SRC_URI += "file://pear-makefile.patch;patch=1 "
+
+export THREADS="pthread"
+export LIBS=" -lpthread "
+
+EXTRA_OECONF = " --without-iconv \
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-pcntl \
+ --enable-memory-limit \
+ --enable-wddx \
+ --enable-embedded-mysqli \
+ --enable-magic-quotes \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+ --with-libxml-dir=${STAGING_BINDIR_CROSS} \
+# --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
+# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+ "
+
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
+export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
+export PHP_PEAR_PHP_BIN = "${bindir}/php"
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+# fixme
+do_install_append() {
+ mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ${D}/${sysconfdir}
+ rm -rf ${D}/${STAGING_DIR_NATIVE}
+ rm -rf ${D}/.registry
+ rm -rf ${D}/.channels
+ rm -rf ${D}/.[a-z]*
+}
+
+PACKAGES = "${PN}-dbg \
+ ${PN}-cli \
+ ${PN}-cgi \
+ ${PN}-pear \
+ ${PN}-dev \
+ ${PN}-doc \
+ ${PN} \
+"
+
+
+FILES_${PN}-dbg =+ "${bindir}/.debug"
+
+FILES_${PN}-doc += "${libdir}/php/doc"
+
+FILES_${PN}-cli = "${bindir}/php"
+FILES_${PN}-cgi = "${bindir}/php-cgi"
+
+FILES_${PN}-pear = "${bindir}/pear* ${bindir}/pecl \
+ ${libdir}/php/PEAR \
+ ${libdir}/php/PEAR.php \
+ ${libdir}/php/System.php ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \
+ ${libdir}/php/.channels ${libdir}/php/.channels/.alias \
+ ${libdir}/php/.channels\__uri.reg \
+ ${libdir}/php/.channels\pear.php.net.reg ${libdir}/php/.channels/pecl.php.net.reg \
+ ${libdir}/php/.registry \
+ ${libdir}/php/Archive/Tar.php \
+ ${libdir}/php/Console/Getopt.php ${libdir}/php/OS/Guess.php \
+ ${sysconfdir}/pear.conf"
+
+
+FILES_${PN}-dev = "${includedir}/php ${libdir}/build \
+ ${bindir}/phpize ${bindir}/php-config \
+ ${libdir}/php/.depdb ${libdir}/php/.depdblock ${libdir}/php/.filemap ${libdir}/php/.lock \
+ ${libdir}/php/test "
+
+FILES_${PN} = "${libdir}/php"
+FILES_${PN} += "${bindir}"
+
+RDEPENDS_${PN}-pear = ${PN}
+RDEPENDS_${PN}-cli = ${PN}
+RDEPENDS_${PN}-dev = ${PN}