aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-21 16:53:52 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-21 16:53:52 +0200
commitd9cb7ebc9d52ee74172a93c256408293651a373a (patch)
tree13907a592a13cce4d6a9f28b0695ead4cbbde176 /recipes/php
parent9043ab7d88211c9012519f434b4a145207f6e0a3 (diff)
downloadopenembedded-d9cb7ebc9d52ee74172a93c256408293651a373a.tar.gz
php: fixed build errors
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php-5.2.6/string.c.patch21
-rw-r--r--recipes/php/php.inc2
-rw-r--r--recipes/php/php_5.2.6.bb5
3 files changed, 25 insertions, 3 deletions
diff --git a/recipes/php/php-5.2.6/string.c.patch b/recipes/php/php-5.2.6/string.c.patch
new file mode 100644
index 0000000000..a24b887ac2
--- /dev/null
+++ b/recipes/php/php-5.2.6/string.c.patch
@@ -0,0 +1,21 @@
+Index: php-5.2.6/ext/standard/string.c
+===================================================================
+--- php-5.2.6.orig/ext/standard/string.c
++++ php-5.2.6/ext/standard/string.c
+@@ -592,14 +592,12 @@ PHP_FUNCTION(nl_langinfo)
+ #endif
+ #ifdef DECIMAL_POINT
+ case DECIMAL_POINT:
+-#endif
+-#ifdef RADIXCHAR
++#elif RADIXCHAR
+ case RADIXCHAR:
+ #endif
+ #ifdef THOUSANDS_SEP
+ case THOUSANDS_SEP:
+-#endif
+-#ifdef THOUSEP
++#elif THOUSEP
+ case THOUSEP:
+ #endif
+ #ifdef GROUPING
diff --git a/recipes/php/php.inc b/recipes/php/php.inc
index e9d49a3269..0f9a42077a 100644
--- a/recipes/php/php.inc
+++ b/recipes/php/php.inc
@@ -10,7 +10,7 @@ S = "${WORKDIR}/php-${PV}"
inherit autotools
-CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -D_GNU_SOURCE"
acpaths = ""
diff --git a/recipes/php/php_5.2.6.bb b/recipes/php/php_5.2.6.bb
index c6cb00fa0f..38e86568d8 100644
--- a/recipes/php/php_5.2.6.bb
+++ b/recipes/php/php_5.2.6.bb
@@ -2,9 +2,10 @@ require php.inc
DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native"
-PR = "r5"
+PR = "r6"
-SRC_URI += "file://pear-makefile.patch;patch=1 "
+SRC_URI += "file://pear-makefile.patch;patch=1 \
+ file://string.c.patch;patch=1 "
export THREADS="pthread"
export LIBS=" -lpthread "