aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-04-04 16:12:53 -0700
committerTom Rini <tom_rini@mentor.com>2011-04-04 16:41:08 -0700
commit4abe57b9bca460792dbd7c1a909eeb4f3ea82820 (patch)
tree0394168c4abc4ee433b57a3be1508183660c0675 /recipes/php
parent4b298625bdf9e83233deed506452d773729e6204 (diff)
downloadopenembedded-4abe57b9bca460792dbd7c1a909eeb4f3ea82820.tar.gz
php: Drop 5.2.13
This is unpinned and has a number of security issues. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php-5.2.13/CVE-2010-0397.patch58
-rw-r--r--recipes/php/php-5.2.13/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.2.13/iconv.patch27
-rw-r--r--recipes/php/php-5.2.13/imap-fix-autofoo.patch41
-rw-r--r--recipes/php/php-5.2.13/pear-makefile.patch13
-rw-r--r--recipes/php/php-5.2.13/php-m4-divert.patch83
-rw-r--r--recipes/php/php_5.2.13.bb103
7 files changed, 0 insertions, 343 deletions
diff --git a/recipes/php/php-5.2.13/CVE-2010-0397.patch b/recipes/php/php-5.2.13/CVE-2010-0397.patch
deleted file mode 100644
index 8f70d40a46..0000000000
--- a/recipes/php/php-5.2.13/CVE-2010-0397.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Description: Fix a null pointer dereference when processing invalid
- XML-RPC requests.
-Origin: vendor
-Forwarded: http://bugs.php.net/51288
-Last-Update: 2010-03-12
-
-Index: php/ext/xmlrpc/tests/bug51288.phpt
-===================================================================
---- /dev/null
-+++ php/ext/xmlrpc/tests/bug51288.phpt
-@@ -0,0 +1,14 @@
-+--TEST--
-+Bug #51288 (CVE-2010-0397, NULL pointer deref when no <methodName> in request)
-+--FILE--
-+<?php
-+$method = NULL;
-+$req = '<?xml version="1.0"?><methodCall></methodCall>';
-+var_dump(xmlrpc_decode_request($req, $method));
-+var_dump($method);
-+echo "Done\n";
-+?>
-+--EXPECT--
-+NULL
-+NULL
-+Done
-Index: php/ext/xmlrpc/xmlrpc-epi-php.c
-===================================================================
---- php.orig/ext/xmlrpc/xmlrpc-epi-php.c
-+++ php/ext/xmlrpc/xmlrpc-epi-php.c
-@@ -701,6 +701,7 @@ zval* decode_request_worker (zval* xml_i
- zval* retval = NULL;
- XMLRPC_REQUEST response;
- STRUCT_XMLRPC_REQUEST_INPUT_OPTIONS opts = {{0}};
-+ const char *method_name;
- opts.xml_elem_opts.encoding = encoding_in ? utf8_get_encoding_id_from_string(Z_STRVAL_P(encoding_in)) : ENCODING_DEFAULT;
-
- /* generate XMLRPC_REQUEST from raw xml */
-@@ -711,10 +712,16 @@ zval* decode_request_worker (zval* xml_i
-
- if(XMLRPC_RequestGetRequestType(response) == xmlrpc_request_call) {
- if(method_name_out) {
-- zval_dtor(method_name_out);
-- Z_TYPE_P(method_name_out) = IS_STRING;
-- Z_STRVAL_P(method_name_out) = estrdup(XMLRPC_RequestGetMethodName(response));
-- Z_STRLEN_P(method_name_out) = strlen(Z_STRVAL_P(method_name_out));
-+ method_name = XMLRPC_RequestGetMethodName(response);
-+ if (method_name) {
-+ zval_dtor(method_name_out);
-+ Z_TYPE_P(method_name_out) = IS_STRING;
-+ Z_STRVAL_P(method_name_out) = estrdup(method_name);
-+ Z_STRLEN_P(method_name_out) = strlen(Z_STRVAL_P(method_name_out));
-+ } else if (retval) {
-+ zval_ptr_dtor(&retval);
-+ retval = NULL;
-+ }
- }
- }
-
diff --git a/recipes/php/php-5.2.13/acinclude-xml2-config.patch b/recipes/php/php-5.2.13/acinclude-xml2-config.patch
deleted file mode 100644
index bf519d2934..0000000000
--- a/recipes/php/php-5.2.13/acinclude-xml2-config.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
-+++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
-@@ -2359,12 +2359,9 @@
- AC_DEFUN([PHP_SETUP_LIBXML], [
- AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
- [
-- for i in $PHP_LIBXML_DIR /usr/local /usr; do
-- if test -x "$i/bin/xml2-config"; then
-- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
-- break
-- fi
-- done
-+
-+ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
-+
- ])
-
- if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.2.13/iconv.patch b/recipes/php/php-5.2.13/iconv.patch
deleted file mode 100644
index 66b39cc560..0000000000
--- a/recipes/php/php-5.2.13/iconv.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: php-5.2.13/acinclude.m4
-===================================================================
---- php-5.2.13.orig/acinclude.m4
-+++ php-5.2.13/acinclude.m4
-@@ -2430,7 +2430,8 @@ AC_DEFUN([PHP_SETUP_ICONV], [
- dnl
- dnl Check libc first if no path is provided in --with-iconv
- dnl
-- if test "$PHP_ICONV" = "yes"; then
-+ dnl must check against no, not against yes as PHP_ICONV can also include a path, which implies yes
-+ if test "$PHP_ICONV" != "no"; then
- AC_CHECK_FUNC(iconv, [
- found_iconv=yes
- ],[
-Index: php-5.2.13/ext/iconv/config.m4
-===================================================================
---- php-5.2.13.orig/ext/iconv/config.m4
-+++ php-5.2.13/ext/iconv/config.m4
-@@ -15,7 +15,7 @@ if test "$PHP_ICONV" != "no"; then
-
- if test "$iconv_avail" != "no"; then
- if test -z "$ICONV_DIR"; then
-- for i in /usr/local /usr; do
-+ for i in $PHP_ICONV /usr/local /usr; do
- if test -f "$i/include/iconv.h" || test -f "$i/include/giconv.h"; then
- PHP_ICONV_PREFIX="$i"
- break
diff --git a/recipes/php/php-5.2.13/imap-fix-autofoo.patch b/recipes/php/php-5.2.13/imap-fix-autofoo.patch
deleted file mode 100644
index 3695b7bc42..0000000000
--- a/recipes/php/php-5.2.13/imap-fix-autofoo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: php-5.2.11/ext/imap/config.m4
-===================================================================
---- php-5.2.11.orig/ext/imap/config.m4 2009-12-10 12:27:52.800974533 -0700
-+++ php-5.2.11/ext/imap/config.m4 2009-12-10 12:28:33.720976583 -0700
-@@ -103,7 +103,7 @@
- PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared)
- AC_DEFINE(HAVE_IMAP,1,[ ])
-
-- for i in $PHP_IMAP /usr/local /usr; do
-+ for i in $PHP_IMAP $PHP_IMAP/usr /usr/local /usr; do
- IMAP_INC_CHK()
- el[]IMAP_INC_CHK(/include/c-client)
- el[]IMAP_INC_CHK(/include/imap)
-@@ -192,13 +192,7 @@
- AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
- fi
-
-- if test -r "$IMAP_DIR/c-client/c-client.a"; then
-- ln -s "$IMAP_DIR/c-client/c-client.a" "$IMAP_DIR/c-client/libc-client.a" >/dev/null 2>&1
-- elif test -r "$IMAP_DIR/$PHP_LIBDIR/c-client.a"; then
-- ln -s "$IMAP_DIR/$PHP_LIBDIR/c-client.a" "$IMAP_DIR/$PHP_LIBDIR/libc-client.a" >/dev/null 2>&1
-- fi
--
-- for lib in c-client4 c-client imap; do
-+ for lib in /usr/lib c-client4 c-client imap; do
- IMAP_LIB=$lib
- IMAP_LIB_CHK($PHP_LIBDIR)
- IMAP_LIB_CHK(c-client)
-Index: php-5.2.11/acinclude.m4
-===================================================================
---- php-5.2.11.orig/acinclude.m4 2009-12-10 12:37:13.134722881 -0700
-+++ php-5.2.11/acinclude.m4 2009-12-10 12:37:39.342007053 -0700
-@@ -2338,7 +2338,7 @@
- PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
- fi
-
-- for i in $PHP_OPENSSL_DIR; do
-+ for i in $PHP_OPENSSL_DIR $PHP_OPENSSL_DIR/usr; do
- if test -r $i/include/openssl/evp.h; then
- OPENSSL_INCDIR=$i/include
- fi
diff --git a/recipes/php/php-5.2.13/pear-makefile.patch b/recipes/php/php-5.2.13/pear-makefile.patch
deleted file mode 100644
index 487f507a02..0000000000
--- a/recipes/php/php-5.2.13/pear-makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: php-5.2.11/pear/Makefile.frag
-===================================================================
---- php-5.2.11.orig/pear/Makefile.frag 2009-08-02 13:11:15.000000000 -0600
-+++ php-5.2.11/pear/Makefile.frag 2009-12-09 16:13:38.700972014 -0700
-@@ -11,7 +11,7 @@
- PEAR_SUFFIX = -ds a$(program_suffix)
-
- install-pear-installer: $(SAPI_CLI_PATH)
-- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
-+ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
-
- install-pear:
- @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php-5.2.13/php-m4-divert.patch b/recipes/php/php-5.2.13/php-m4-divert.patch
deleted file mode 100644
index dfc7b643e2..0000000000
--- a/recipes/php/php-5.2.13/php-m4-divert.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-Patch taken from
-
-http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
-
-diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
---- php-5.2.10.org/configure.in 2009-06-17 14:22:41.000000000 +0200
-+++ php-5.2.10/configure.in 2009-08-18 12:16:25.317640253 +0200
-@@ -1,7 +1,7 @@
- ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
- dnl ## Process this file with autoconf to produce a configure script.
-
--divert(1)
-+divert(1001)
-
- dnl ## Diversion 1 is the autoconf + automake setup phase. We also
- dnl ## set the PHP version, deal with platform-specific compile
-@@ -263,7 +263,7 @@
- sinclude(TSRM/tsrm.m4)
-
-
--divert(2)
-+divert(1002)
-
- dnl ## Diversion 2 is where we set PHP-specific options and come up
- dnl ## with reasonable default values for them. We check for pthreads here
-@@ -302,7 +302,7 @@
- PTHREADS_FLAGS
- fi
-
--divert(3)
-+divert(1003)
-
- dnl ## In diversion 3 we check for compile-time options to the PHP
- dnl ## core and how to deal with different system dependencies.
-@@ -661,7 +661,7 @@
- PHP_CRYPT_R_STYLE
- fi
-
--divert(4)
-+divert(1004)
-
- dnl ## In diversion 4 we check user-configurable general settings.
-
-@@ -902,7 +902,7 @@
- AC_MSG_RESULT([using system default])
- fi
-
--divert(5)
-+divert(1005)
-
- dnl ## In diversion 5 we check which extensions should be compiled.
- dnl ## All of these are normally in the extension directories.
-diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
---- php-5.2.10.org/ext/standard/config.m4 2007-07-11 13:56:03.000000000 +0200
-+++ php-5.2.10/ext/standard/config.m4 2009-08-18 12:16:25.317640253 +0200
-@@ -1,6 +1,6 @@
- dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
-
--divert(3)dnl
-+divert(1003)dnl
-
- dnl
- dnl Check if flush should be called explicitly after buffered io
-@@ -205,7 +205,7 @@
- AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
- AC_FUNC_FNMATCH
-
--divert(5)dnl
-+divert(1005)dnl
-
- dnl
- dnl Check for regex library type
-diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
---- php-5.2.10.org/scripts/phpize.m4 2009-06-02 21:54:22.000000000 +0200
-+++ php-5.2.10/scripts/phpize.m4 2009-08-18 12:16:25.317640253 +0200
-@@ -1,6 +1,6 @@
- dnl This file becomes configure.in for self-contained extensions.
-
--divert(1)
-+divert(1001)
-
- AC_PREREQ(2.13)
- AC_INIT(config.m4)
diff --git a/recipes/php/php_5.2.13.bb b/recipes/php/php_5.2.13.bb
deleted file mode 100644
index a8590870e7..0000000000
--- a/recipes/php/php_5.2.13.bb
+++ /dev/null
@@ -1,103 +0,0 @@
-require php.inc
-
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql5 \
- libc-client openssl findutils-native"
-
-PR = "${INC_PR}.4"
-
-SRC_URI = "http://museum.php.net/php5/php-${PV}.tar.bz2;name=src \
- file://acinclude-xml2-config.patch \
- file://php-m4-divert.patch \
- file://pear-makefile.patch \
- file://imap-fix-autofoo.patch \
- file://CVE-2010-0397.patch \
- file://iconv.patch \
- "
-
-SRC_URI[src.md5sum] = "eb4d0766dc4fb9667f05a68b6041e7d1"
-SRC_URI[src.sha256sum] = "2b50a2535e3bb9a98cd4d1633f9452d877276c40b385915261f040d535c7eadb"
-
-export THREADS="pthread"
-export LIBS=" -lpthread "
-
-EXTRA_OECONF = " --enable-mbstring \
- --enable-discard-path \
- --enable-sockets \
- --enable-shared \
- --enable-pcntl \
- --enable-wddx \
- --disable-embedded-mysqli \
- --enable-magic-quotes \
- --enable-fastcgi \
- --with-imap=${STAGING_DIR_HOST} \
- --with-imap-ssl=${STAGING_DIR_HOST} \
- --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
- --with-iconv=${STAGING_LIBDIR}/.. \
- --with-libxml-dir=${STAGING_BINDIR_CROSS} \
- --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
- --with-mysqli="${STAGING_BINDIR_CROSS}/mysql_config" \
- --with-pdo-mysql="${STAGING_BINDIR_CROSS}/mysql_config" \
- --without-pdo-sqlite \
- "
-
-export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
-export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
-export PHP_PEAR_PHP_BIN = "${bindir}/php"
-
-#LDFLAGS += "-lstdc++"
-
-do_configure_append() {
- find ${S} -type f -readable -writable | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
-}
-
-# fixme
-do_install_append() {
- mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ${D}/${sysconfdir}
- rm -rf ${D}/${STAGING_DIR_NATIVE}
- rm -rf ${D}/.registry
- rm -rf ${D}/.channels
- rm -rf ${D}/.[a-z]*
- sed -i 's:${STAGING_DIR_NATIVE}::g' ${D}/${sysconfdir}/pear.conf
-}
-
-PACKAGES = "${PN}-dbg \
- ${PN}-cli \
- ${PN}-cgi \
- ${PN}-pear \
- ${PN}-dev \
- ${PN}-doc \
- ${PN} \
-"
-
-
-FILES_${PN}-dbg =+ "${bindir}/.debug"
-
-FILES_${PN}-doc += "${libdir}/php/doc"
-
-FILES_${PN}-cli = "${bindir}/php"
-FILES_${PN}-cgi = "${bindir}/php-cgi"
-
-FILES_${PN}-pear = "${bindir}/pear* ${bindir}/pecl \
- ${libdir}/php/PEAR \
- ${libdir}/php/PEAR.php \
- ${libdir}/php/System.php ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \
- ${libdir}/php/.channels ${libdir}/php/.channels/.alias \
- ${libdir}/php/.channels\__uri.reg \
- ${libdir}/php/.channels\pear.php.net.reg ${libdir}/php/.channels/pecl.php.net.reg \
- ${libdir}/php/.registry \
- ${libdir}/php/Archive/Tar.php \
- ${libdir}/php/Console/Getopt.php ${libdir}/php/OS/Guess.php \
- ${sysconfdir}/pear.conf"
-
-
-FILES_${PN}-dev = "${includedir}/php ${libdir}/build \
- ${bindir}/phpize ${bindir}/php-config \
- ${libdir}/php/.depdb ${libdir}/php/.depdblock ${libdir}/php/.filemap ${libdir}/php/.lock \
- ${libdir}/php/test "
-
-FILES_${PN} = "${libdir}/php"
-FILES_${PN} += "${bindir}"
-
-RDEPENDS_${PN}-pear = ${PN}
-RDEPENDS_${PN}-cli = ${PN}
-RDEPENDS_${PN}-dev = ${PN}