summaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-10 13:08:58 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-10 20:12:18 +0000
commitfa1e6ccdb109cade94bd87777d1fff372755c7da (patch)
tree394b6c2dd07e72f20cdbb2a8f642180e43b611d6 /recipes/php
parent1994ec5fd25fc237ef42aadefd0fe719af20ef74 (diff)
downloadopenembedded-fa1e6ccdb109cade94bd87777d1fff372755c7da.tar.gz
php_5.2.11.bb : enable the imap extension, which also needed some openssl
I have patched up the autoconf stuff as it was searching in pretty hard coded paths for c-client and openssl.
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php-5.2.11/imap-fix-autofoo.patch41
-rw-r--r--recipes/php/php_5.2.11.bb8
2 files changed, 47 insertions, 2 deletions
diff --git a/recipes/php/php-5.2.11/imap-fix-autofoo.patch b/recipes/php/php-5.2.11/imap-fix-autofoo.patch
new file mode 100644
index 0000000000..3695b7bc42
--- /dev/null
+++ b/recipes/php/php-5.2.11/imap-fix-autofoo.patch
@@ -0,0 +1,41 @@
+Index: php-5.2.11/ext/imap/config.m4
+===================================================================
+--- php-5.2.11.orig/ext/imap/config.m4 2009-12-10 12:27:52.800974533 -0700
++++ php-5.2.11/ext/imap/config.m4 2009-12-10 12:28:33.720976583 -0700
+@@ -103,7 +103,7 @@
+ PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared)
+ AC_DEFINE(HAVE_IMAP,1,[ ])
+
+- for i in $PHP_IMAP /usr/local /usr; do
++ for i in $PHP_IMAP $PHP_IMAP/usr /usr/local /usr; do
+ IMAP_INC_CHK()
+ el[]IMAP_INC_CHK(/include/c-client)
+ el[]IMAP_INC_CHK(/include/imap)
+@@ -192,13 +192,7 @@
+ AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
+ fi
+
+- if test -r "$IMAP_DIR/c-client/c-client.a"; then
+- ln -s "$IMAP_DIR/c-client/c-client.a" "$IMAP_DIR/c-client/libc-client.a" >/dev/null 2>&1
+- elif test -r "$IMAP_DIR/$PHP_LIBDIR/c-client.a"; then
+- ln -s "$IMAP_DIR/$PHP_LIBDIR/c-client.a" "$IMAP_DIR/$PHP_LIBDIR/libc-client.a" >/dev/null 2>&1
+- fi
+-
+- for lib in c-client4 c-client imap; do
++ for lib in /usr/lib c-client4 c-client imap; do
+ IMAP_LIB=$lib
+ IMAP_LIB_CHK($PHP_LIBDIR)
+ IMAP_LIB_CHK(c-client)
+Index: php-5.2.11/acinclude.m4
+===================================================================
+--- php-5.2.11.orig/acinclude.m4 2009-12-10 12:37:13.134722881 -0700
++++ php-5.2.11/acinclude.m4 2009-12-10 12:37:39.342007053 -0700
+@@ -2338,7 +2338,7 @@
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
+ fi
+
+- for i in $PHP_OPENSSL_DIR; do
++ for i in $PHP_OPENSSL_DIR $PHP_OPENSSL_DIR/usr; do
+ if test -r $i/include/openssl/evp.h; then
+ OPENSSL_INCDIR=$i/include
+ fi
diff --git a/recipes/php/php_5.2.11.bb b/recipes/php/php_5.2.11.bb
index d4fd98597a..058f1c2554 100644
--- a/recipes/php/php_5.2.11.bb
+++ b/recipes/php/php_5.2.11.bb
@@ -1,10 +1,12 @@
require php.inc
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql \
+ libc-client openssl"
-PR = "r1"
+PR = "r2"
SRC_URI += "file://pear-makefile.patch;patch=1 \
+ file://imap-fix-autofoo.patch;patch=1 \
"
export THREADS="pthread"
export LIBS=" -lpthread "
@@ -20,6 +22,8 @@ EXTRA_OECONF = " --without-iconv \
--enable-embedded-mysqli \
--enable-magic-quotes \
--enable-fastcgi \
+ --with-imap=${STAGING_DIR_HOST} \
+ --with-imap-ssl=${STAGING_DIR_HOST} \
--with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
--with-libxml-dir=${STAGING_BINDIR_CROSS} \
--with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \