aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pivotinit
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pivotinit
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pivotinit')
-rw-r--r--recipes/pivotinit/pivotinit_1.0.0.bb11
-rw-r--r--recipes/pivotinit/spitz/init25
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/pivotinit/pivotinit_1.0.0.bb b/recipes/pivotinit/pivotinit_1.0.0.bb
new file mode 100644
index 0000000000..912cfeb5b9
--- /dev/null
+++ b/recipes/pivotinit/pivotinit_1.0.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Dedicated /sbin/init for pivot root images"
+SECTION = "base"
+PRIORITY = "required"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "file://init"
+
+do_install () {
+ install -m 0755 -D ${WORKDIR}/init ${D}/sbin/init
+}
diff --git a/recipes/pivotinit/spitz/init b/recipes/pivotinit/spitz/init
new file mode 100644
index 0000000000..41e4aff0db
--- /dev/null
+++ b/recipes/pivotinit/spitz/init
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+mount -t proc proc /proc
+mount -o remount,rw /
+cardmgr -o
+umount /proc
+echo Mounting hda1.
+mount -t ext3 /dev/hda1 /media/hdd
+
+# For some reason the Spitz tar doesn't create the devices.
+if [ ! -b /media/hdd/dev/hda1 ]; then
+ echo Creating non existant device files.
+ /media/hdd/sbin/makedevs -D /media/hdd/etc/device_table -r /media/hdd/
+fi
+
+if [ -e /media/hdd/sbin/init -o -L /media/hdd/sbin/init ]; then
+ echo "Found /sbin/init on HD; pivoting."
+ cd /media/hdd
+ pivot_root . media/realroot
+ cd /
+ exec /sbin/init
+fi
+
+echo Dropping to a shell due to problems.
+exec /bin/sh