aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pmount
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pmount
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pmount')
-rw-r--r--recipes/pmount/files/mmc-fix.patch20
-rw-r--r--recipes/pmount/files/no-hal.patch11
-rw-r--r--recipes/pmount/pmount-0.9.17/gettext.patch133
-rw-r--r--recipes/pmount/pmount-0.9.17/install.patch15
-rw-r--r--recipes/pmount/pmount-0.9.18/gettext.patch133
-rw-r--r--recipes/pmount/pmount-0.9.18/install.patch15
-rw-r--r--recipes/pmount/pmount_0.9.17.bb22
-rw-r--r--recipes/pmount/pmount_0.9.18.bb22
-rw-r--r--recipes/pmount/pmount_0.9.4.bb15
9 files changed, 386 insertions, 0 deletions
diff --git a/recipes/pmount/files/mmc-fix.patch b/recipes/pmount/files/mmc-fix.patch
new file mode 100644
index 0000000000..3376a503c7
--- /dev/null
+++ b/recipes/pmount/files/mmc-fix.patch
@@ -0,0 +1,20 @@
+--- pmount-0.9.4/policy.c.orig 2005-09-22 23:11:29 +0200
++++ pmount-0.9.4/policy.c 2005-09-22 23:12:54 +0200
+@@ -354,7 +354,7 @@
+ device_removable( const char* device )
+ {
+ struct sysfs_device *dev;
+- static char* hotplug_buses[] = { "usb", "ieee1394", NULL };
++ static char* hotplug_buses[] = { "usb", "ieee1394", "mmc", NULL };
+ int removable;
+ char blockdevpath[PATH_MAX];
+
+@@ -370,7 +370,7 @@
+ /* check whether device has "removable" attribute with value '1' */
+ removable = get_blockdev_attr( blockdevpath, "removable" );
+
+- /* if not, fall back to bus scanning (regard USB and FireWire as removable) */
++ /* if not, fall back to bus scanning (regard USB, FireWire and MMC as removable) */
+ if( !removable )
+ removable = find_bus_ancestry( dev, hotplug_buses );
+ sysfs_close_device( dev );
diff --git a/recipes/pmount/files/no-hal.patch b/recipes/pmount/files/no-hal.patch
new file mode 100644
index 0000000000..0deffdee5d
--- /dev/null
+++ b/recipes/pmount/files/no-hal.patch
@@ -0,0 +1,11 @@
+--- pmount-0.9.4/Makefile.orig 2005-09-22 15:43:39 +0200
++++ pmount-0.9.4/Makefile 2005-09-22 15:43:52 +0200
+@@ -9,7 +9,7 @@
+ pumount_OBJ = pumount.o policy.o utils.o luks.o
+ pmount_hal_OBJ = pmount-hal.o policy.o utils.o fs.o
+
+-all: pmount pumount pmount-hal po/pmount.pot
++all: pmount pumount po/pmount.pot
+
+ pmount: $(pmount_OBJ)
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
diff --git a/recipes/pmount/pmount-0.9.17/gettext.patch b/recipes/pmount/pmount-0.9.17/gettext.patch
new file mode 100644
index 0000000000..dbac93f6ba
--- /dev/null
+++ b/recipes/pmount/pmount-0.9.17/gettext.patch
@@ -0,0 +1,133 @@
+Index: pmount-0.9.17/src/pmount-hal.c
+===================================================================
+--- pmount-0.9.17.orig/src/pmount-hal.c 2007-07-01 13:58:49.000000000 +0200
++++ pmount-0.9.17/src/pmount-hal.c 2008-10-08 23:39:20.970178412 +0200
+@@ -16,7 +16,6 @@
+ #include <dirent.h>
+ #include <sys/stat.h>
+ #include <locale.h>
+-#include <libintl.h>
+ #include <libhal-storage.h>
+
+ #include "policy.h"
+@@ -26,7 +25,12 @@
+ #include "realpath.h"
+
+ /* gettext abbreviation */
++#ifdef ENABLE_NLS
++#include <libintl.h>
+ #define _(String) gettext(String)
++#else
++#define _(String) (String)
++#endif
+
+ void help() {
+ puts( _(
+@@ -196,10 +200,12 @@
+ char *dmask = NULL;
+ char *iocharset = NULL;
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ if( argc < 2 ) {
+ help();
+Index: pmount-0.9.17/src/utils.h
+===================================================================
+--- pmount-0.9.17.orig/src/utils.h 2007-07-07 09:05:06.000000000 +0200
++++ pmount-0.9.17/src/utils.h 2008-10-08 23:19:09.515475595 +0200
+@@ -12,7 +12,12 @@
+ #define __utils_h
+
+ /* gettext abbreviation */
++#ifdef ENABLE_NLS
++#include <libintl.h>
+ #define _(String) gettext(String)
++#else
++#define _(String) (String)
++#endif
+
+ /* global flag whether to print debug messages (false by default) */
+ extern int enable_debug;
+Index: pmount-0.9.17/configure.ac
+===================================================================
+--- pmount-0.9.17.orig/configure.ac 2007-12-14 20:27:23.000000000 +0100
++++ pmount-0.9.17/configure.ac 2008-10-08 23:19:09.598820915 +0200
+@@ -77,10 +77,7 @@
+ fi
+ AM_CONDITIONAL(PMOUNT_HAL, test -n "$BUILD_HAL")
+
+-GETTEXT_PACKAGE="pmount"
+-AC_SUBST(GETTEXT_PACKAGE)
+-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext package])
+-AM_GLIB_GNU_GETTEXT
++AM_GNU_GETTEXT([external])
+
+ AC_OUTPUT([
+ Makefile
+Index: pmount-0.9.17/src/pmount.c
+===================================================================
+--- pmount-0.9.17.orig/src/pmount.c 2008-10-08 23:36:44.452037557 +0200
++++ pmount-0.9.17/src/pmount.c 2008-10-08 23:37:38.778816969 +0200
+@@ -21,9 +21,12 @@
+ #include <errno.h>
+ #include <locale.h>
+ #include <langinfo.h>
+-#include <libintl.h>
+ #include <sys/stat.h>
+
++#ifdef ENABLE_NLS
++#include <libintl.h>
++#endif
++
+ #include "fs.h"
+ #include "policy.h"
+ #include "utils.h"
+@@ -619,10 +622,12 @@
+ { NULL, 0, NULL, 0}
+ };
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ /* If pmount is run without a single argument, print out the list
+ of removable devices. Does not require root privileges, just read access
+Index: pmount-0.9.17/src/pumount.c
+===================================================================
+--- pmount-0.9.17.orig/src/pumount.c 2008-10-08 23:38:21.122028300 +0200
++++ pmount-0.9.17/src/pumount.c 2008-10-08 23:38:47.972023678 +0200
+@@ -16,9 +16,12 @@
+ #include <sys/wait.h>
+ #include <limits.h>
+ #include <getopt.h>
+-#include <libintl.h>
+ #include <locale.h>
+
++#ifdef ENABLE_NLS
++#include <libintl.h>
++#endif
++
+ #include "policy.h"
+ #include "utils.h"
+ #include "luks.h"
+@@ -172,10 +175,12 @@
+ { NULL, 0, NULL, 0}
+ };
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ /* are we root? */
+ if( geteuid() ) {
diff --git a/recipes/pmount/pmount-0.9.17/install.patch b/recipes/pmount/pmount-0.9.17/install.patch
new file mode 100644
index 0000000000..b02942a591
--- /dev/null
+++ b/recipes/pmount/pmount-0.9.17/install.patch
@@ -0,0 +1,15 @@
+Index: pmount-0.9.17/src/Makefile.am
+===================================================================
+--- pmount-0.9.17.orig/src/Makefile.am 2008-10-09 01:22:41.668067209 +0200
++++ pmount-0.9.17/src/Makefile.am 2008-10-09 01:23:22.144725902 +0200
+@@ -36,8 +36,8 @@
+
+ install-data-hook:
+ test -z $(INSTALL_DIR) || mkdir -p -- $(INSTALL_DIR)
+- $(INSTALL_DATA) -o root -g root -m 4755 -D $(INSTALL_SRC)/pmount $(INSTALL_DIR)/pmount
+- $(INSTALL_DATA) -o root -g root -m 4755 -D $(INSTALL_SRC)/pumount $(INSTALL_DIR)/pumount
++ $(INSTALL_DATA) -m 4755 -D $(INSTALL_SRC)/pmount $(INSTALL_DIR)/pmount
++ $(INSTALL_DATA) -m 4755 -D $(INSTALL_SRC)/pumount $(INSTALL_DIR)/pumount
+
+ uninstall-hook:
+ rm -f $(INSTALL_DIR)/pmount
diff --git a/recipes/pmount/pmount-0.9.18/gettext.patch b/recipes/pmount/pmount-0.9.18/gettext.patch
new file mode 100644
index 0000000000..dbac93f6ba
--- /dev/null
+++ b/recipes/pmount/pmount-0.9.18/gettext.patch
@@ -0,0 +1,133 @@
+Index: pmount-0.9.17/src/pmount-hal.c
+===================================================================
+--- pmount-0.9.17.orig/src/pmount-hal.c 2007-07-01 13:58:49.000000000 +0200
++++ pmount-0.9.17/src/pmount-hal.c 2008-10-08 23:39:20.970178412 +0200
+@@ -16,7 +16,6 @@
+ #include <dirent.h>
+ #include <sys/stat.h>
+ #include <locale.h>
+-#include <libintl.h>
+ #include <libhal-storage.h>
+
+ #include "policy.h"
+@@ -26,7 +25,12 @@
+ #include "realpath.h"
+
+ /* gettext abbreviation */
++#ifdef ENABLE_NLS
++#include <libintl.h>
+ #define _(String) gettext(String)
++#else
++#define _(String) (String)
++#endif
+
+ void help() {
+ puts( _(
+@@ -196,10 +200,12 @@
+ char *dmask = NULL;
+ char *iocharset = NULL;
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ if( argc < 2 ) {
+ help();
+Index: pmount-0.9.17/src/utils.h
+===================================================================
+--- pmount-0.9.17.orig/src/utils.h 2007-07-07 09:05:06.000000000 +0200
++++ pmount-0.9.17/src/utils.h 2008-10-08 23:19:09.515475595 +0200
+@@ -12,7 +12,12 @@
+ #define __utils_h
+
+ /* gettext abbreviation */
++#ifdef ENABLE_NLS
++#include <libintl.h>
+ #define _(String) gettext(String)
++#else
++#define _(String) (String)
++#endif
+
+ /* global flag whether to print debug messages (false by default) */
+ extern int enable_debug;
+Index: pmount-0.9.17/configure.ac
+===================================================================
+--- pmount-0.9.17.orig/configure.ac 2007-12-14 20:27:23.000000000 +0100
++++ pmount-0.9.17/configure.ac 2008-10-08 23:19:09.598820915 +0200
+@@ -77,10 +77,7 @@
+ fi
+ AM_CONDITIONAL(PMOUNT_HAL, test -n "$BUILD_HAL")
+
+-GETTEXT_PACKAGE="pmount"
+-AC_SUBST(GETTEXT_PACKAGE)
+-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext package])
+-AM_GLIB_GNU_GETTEXT
++AM_GNU_GETTEXT([external])
+
+ AC_OUTPUT([
+ Makefile
+Index: pmount-0.9.17/src/pmount.c
+===================================================================
+--- pmount-0.9.17.orig/src/pmount.c 2008-10-08 23:36:44.452037557 +0200
++++ pmount-0.9.17/src/pmount.c 2008-10-08 23:37:38.778816969 +0200
+@@ -21,9 +21,12 @@
+ #include <errno.h>
+ #include <locale.h>
+ #include <langinfo.h>
+-#include <libintl.h>
+ #include <sys/stat.h>
+
++#ifdef ENABLE_NLS
++#include <libintl.h>
++#endif
++
+ #include "fs.h"
+ #include "policy.h"
+ #include "utils.h"
+@@ -619,10 +622,12 @@
+ { NULL, 0, NULL, 0}
+ };
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ /* If pmount is run without a single argument, print out the list
+ of removable devices. Does not require root privileges, just read access
+Index: pmount-0.9.17/src/pumount.c
+===================================================================
+--- pmount-0.9.17.orig/src/pumount.c 2008-10-08 23:38:21.122028300 +0200
++++ pmount-0.9.17/src/pumount.c 2008-10-08 23:38:47.972023678 +0200
+@@ -16,9 +16,12 @@
+ #include <sys/wait.h>
+ #include <limits.h>
+ #include <getopt.h>
+-#include <libintl.h>
+ #include <locale.h>
+
++#ifdef ENABLE_NLS
++#include <libintl.h>
++#endif
++
+ #include "policy.h"
+ #include "utils.h"
+ #include "luks.h"
+@@ -172,10 +175,12 @@
+ { NULL, 0, NULL, 0}
+ };
+
++#ifdef ENABLE_NLS
+ /* initialize locale */
+ setlocale( LC_ALL, "" );
+ bindtextdomain( "pmount", NULL );
+ textdomain( "pmount" );
++#endif
+
+ /* are we root? */
+ if( geteuid() ) {
diff --git a/recipes/pmount/pmount-0.9.18/install.patch b/recipes/pmount/pmount-0.9.18/install.patch
new file mode 100644
index 0000000000..b02942a591
--- /dev/null
+++ b/recipes/pmount/pmount-0.9.18/install.patch
@@ -0,0 +1,15 @@
+Index: pmount-0.9.17/src/Makefile.am
+===================================================================
+--- pmount-0.9.17.orig/src/Makefile.am 2008-10-09 01:22:41.668067209 +0200
++++ pmount-0.9.17/src/Makefile.am 2008-10-09 01:23:22.144725902 +0200
+@@ -36,8 +36,8 @@
+
+ install-data-hook:
+ test -z $(INSTALL_DIR) || mkdir -p -- $(INSTALL_DIR)
+- $(INSTALL_DATA) -o root -g root -m 4755 -D $(INSTALL_SRC)/pmount $(INSTALL_DIR)/pmount
+- $(INSTALL_DATA) -o root -g root -m 4755 -D $(INSTALL_SRC)/pumount $(INSTALL_DIR)/pumount
++ $(INSTALL_DATA) -m 4755 -D $(INSTALL_SRC)/pmount $(INSTALL_DIR)/pmount
++ $(INSTALL_DATA) -m 4755 -D $(INSTALL_SRC)/pumount $(INSTALL_DIR)/pumount
+
+ uninstall-hook:
+ rm -f $(INSTALL_DIR)/pmount
diff --git a/recipes/pmount/pmount_0.9.17.bb b/recipes/pmount/pmount_0.9.17.bb
new file mode 100644
index 0000000000..f72534b468
--- /dev/null
+++ b/recipes/pmount/pmount_0.9.17.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE = "http://pmount.alioth.debian.org/"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS = "hal e2fsprogs-libs sysfsutils"
+RDEPENDS_${PN}-hal = "${PN}"
+RRECOMMENDS_${PN}-hal = "hal"
+
+SRC_URI = "http://alioth.debian.org/frs/download.php/2247/${P}.tar.gz \
+ file://gettext.patch;patch=1 \
+ file://install.patch;patch=1 \
+ "
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--enable-hal"
+
+PACKAGES =+ "${PN}-hal"
+
+FILES_${PN}-hal = "${bindir}/pmount-hal"
+
diff --git a/recipes/pmount/pmount_0.9.18.bb b/recipes/pmount/pmount_0.9.18.bb
new file mode 100644
index 0000000000..26770b33a9
--- /dev/null
+++ b/recipes/pmount/pmount_0.9.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE = "http://pmount.alioth.debian.org/"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS = "hal e2fsprogs-libs sysfsutils"
+RDEPENDS_${PN}-hal = "${PN}"
+RRECOMMENDS_${PN}-hal = "hal"
+
+SRC_URI = "http://alioth.debian.org/frs/download.php/2624/${P}.tar.gz \
+ file://gettext.patch;patch=1 \
+ file://install.patch;patch=1 \
+ "
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--enable-hal"
+
+PACKAGES =+ "${PN}-hal"
+
+FILES_${PN}-hal = "${bindir}/pmount-hal"
+
diff --git a/recipes/pmount/pmount_0.9.4.bb b/recipes/pmount/pmount_0.9.4.bb
new file mode 100644
index 0000000000..1dcb8733c4
--- /dev/null
+++ b/recipes/pmount/pmount_0.9.4.bb
@@ -0,0 +1,15 @@
+DESCRIPTION="mount removable devices as normal user"
+DEPENDS="sysfsutils"
+PR ="r1"
+
+SRC_URI="http://www.piware.de/projects/pmount-0.9.4.tar.gz \
+ file://mmc-fix.patch;patch=1 \
+ file://no-hal.patch;patch=1"
+
+do_install() {
+ install -m 4755 -D ${S}/pmount ${D}/${bindir}/pmount
+ install -m 4755 -D ${S}/pumount ${D}/${bindir}/pumount
+ install -m 644 -D ${S}/pmount.1 ${D}/${datadir}/man/man1/pmount.1
+ install -m 644 -D ${S}/pumount.1 ${D}/${datadir}/man/man1/pumount.1
+ install -m 644 -D ${S}/pmount.allow ${D}/${sysconfdir}/pmount.allow
+}