summaryrefslogtreecommitdiffstats
path: root/recipes/pmount
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-07-12 17:38:34 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-07-12 17:38:34 +0200
commit1549e54c0be73140dc039640cfc2bc2db0d58628 (patch)
tree87e6debd4c68af15f2a9efa56f5c2d96c635b852 /recipes/pmount
parent5f076af70ba46750e654e63a1703c03c2a33ca63 (diff)
downloadopenembedded-1549e54c0be73140dc039640cfc2bc2db0d58628.tar.gz
pmount: fix gettext suppoprt now for real
* bump PR
Diffstat (limited to 'recipes/pmount')
-rw-r--r--recipes/pmount/pmount-0.9.18/gettext.patch184
-rw-r--r--recipes/pmount/pmount_0.9.18.bb2
2 files changed, 125 insertions, 61 deletions
diff --git a/recipes/pmount/pmount-0.9.18/gettext.patch b/recipes/pmount/pmount-0.9.18/gettext.patch
index dbac93f6ba..a784e32440 100644
--- a/recipes/pmount/pmount-0.9.18/gettext.patch
+++ b/recipes/pmount/pmount-0.9.18/gettext.patch
@@ -1,7 +1,7 @@
-Index: pmount-0.9.17/src/pmount-hal.c
+Index: pmount-0.9.18/src/pmount-hal.c
===================================================================
---- pmount-0.9.17.orig/src/pmount-hal.c 2007-07-01 13:58:49.000000000 +0200
-+++ pmount-0.9.17/src/pmount-hal.c 2008-10-08 23:39:20.970178412 +0200
+--- pmount-0.9.18.orig/src/pmount-hal.c 2008-10-09 23:19:46.000000000 +0200
++++ pmount-0.9.18/src/pmount-hal.c 2009-07-12 17:16:00.719122863 +0200
@@ -16,7 +16,6 @@
#include <dirent.h>
#include <sys/stat.h>
@@ -10,54 +10,77 @@ Index: pmount-0.9.17/src/pmount-hal.c
#include <libhal-storage.h>
#include "policy.h"
-@@ -26,7 +25,12 @@
- #include "realpath.h"
+@@ -25,9 +24,6 @@
- /* gettext abbreviation */
-+#ifdef ENABLE_NLS
-+#include <libintl.h>
- #define _(String) gettext(String)
-+#else
-+#define _(String) (String)
-+#endif
+ #include "realpath.h"
+-/* gettext abbreviation */
+-#define _(String) gettext(String)
+-
void help() {
puts( _(
-@@ -196,10 +200,12 @@
- char *dmask = NULL;
- char *iocharset = NULL;
+ "pmount-hal - execute pmount with additional information from hal\n\n"
+@@ -198,8 +194,8 @@
-+#ifdef ENABLE_NLS
/* initialize locale */
setlocale( LC_ALL, "" );
- bindtextdomain( "pmount", NULL );
- textdomain( "pmount" );
-+#endif
+- bindtextdomain( "pmount", NULL );
+- textdomain( "pmount" );
++ bindtextdomain(PACKAGE, NULL );
++ textdomain(PACKAGE);
if( argc < 2 ) {
help();
-Index: pmount-0.9.17/src/utils.h
+Index: pmount-0.9.18/src/utils.h
===================================================================
---- pmount-0.9.17.orig/src/utils.h 2007-07-07 09:05:06.000000000 +0200
-+++ pmount-0.9.17/src/utils.h 2008-10-08 23:19:09.515475595 +0200
-@@ -12,7 +12,12 @@
+--- pmount-0.9.18.orig/src/utils.h 2008-10-09 23:19:46.000000000 +0200
++++ pmount-0.9.18/src/utils.h 2009-07-12 17:23:01.384780369 +0200
+@@ -12,8 +12,31 @@
#define __utils_h
/* gettext abbreviation */
+#ifdef ENABLE_NLS
++
+#include <libintl.h>
++
#define _(String) gettext(String)
+
++#ifdef gettext_noop
++#define N_(String) gettext_noop(String)
+#else
-+#define _(String) (String)
++#define N_(String) (String)
+#endif
-
++
++#else /* NLS is disabled */
++
++#define _(String) (String)
++#define N_(String) (String)
++#define textdomain(String) (String)
++#define gettext(String) (String)
++#define dgettext(Domain,String) (String)
++#define dcgettext(Domain,String,Type) (String)
++#define bindtextdomain(Domain,Directory) (Domain)
++#define bind_textdomain_codeset(Domain,Codeset) (Codeset)
++
++#endif /* ENABLE_NLS */
++
/* global flag whether to print debug messages (false by default) */
extern int enable_debug;
-Index: pmount-0.9.17/configure.ac
+
+Index: pmount-0.9.18/configure.ac
===================================================================
---- pmount-0.9.17.orig/configure.ac 2007-12-14 20:27:23.000000000 +0100
-+++ pmount-0.9.17/configure.ac 2008-10-08 23:19:09.598820915 +0200
-@@ -77,10 +77,7 @@
+--- pmount-0.9.18.orig/configure.ac 2008-10-18 21:02:18.000000000 +0200
++++ pmount-0.9.18/configure.ac 2009-07-12 17:16:00.719122863 +0200
+@@ -5,8 +5,6 @@
+ AC_CONFIG_SRCDIR(src)
+ AM_INIT_AUTOMAKE(pmount, 0.9.18)
+
+-AC_PROG_INTLTOOL([0.21])
+-
+ AM_MAINTAINER_MODE
+ AC_ISC_POSIX
+ AC_HEADER_STDC
+@@ -77,10 +75,13 @@
fi
AM_CONDITIONAL(PMOUNT_HAL, test -n "$BUILD_HAL")
@@ -65,69 +88,110 @@ Index: pmount-0.9.17/configure.ac
-AC_SUBST(GETTEXT_PACKAGE)
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext package])
-AM_GLIB_GNU_GETTEXT
++
++IT_PROG_INTLTOOL([0.21])
++GETTEXT_PACKAGE=$PACKAGE
++AC_SUBST([GETTEXT_PACKAGE])
++AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[Gettext package])
+AM_GNU_GETTEXT([external])
++AM_GNU_GETTEXT_VERSION([0.17])
AC_OUTPUT([
Makefile
-Index: pmount-0.9.17/src/pmount.c
+Index: pmount-0.9.18/src/pmount.c
===================================================================
---- pmount-0.9.17.orig/src/pmount.c 2008-10-08 23:36:44.452037557 +0200
-+++ pmount-0.9.17/src/pmount.c 2008-10-08 23:37:38.778816969 +0200
-@@ -21,9 +21,12 @@
+--- pmount-0.9.18.orig/src/pmount.c 2008-10-18 20:49:54.000000000 +0200
++++ pmount-0.9.18/src/pmount.c 2009-07-12 17:16:00.722456315 +0200
+@@ -21,7 +21,6 @@
#include <errno.h>
#include <locale.h>
#include <langinfo.h>
-#include <libintl.h>
#include <sys/stat.h>
-+#ifdef ENABLE_NLS
-+#include <libintl.h>
-+#endif
-+
#include "fs.h"
- #include "policy.h"
- #include "utils.h"
-@@ -619,10 +622,12 @@
- { NULL, 0, NULL, 0}
- };
+@@ -652,8 +651,8 @@
-+#ifdef ENABLE_NLS
/* initialize locale */
setlocale( LC_ALL, "" );
- bindtextdomain( "pmount", NULL );
- textdomain( "pmount" );
-+#endif
+- bindtextdomain( "pmount", NULL );
+- textdomain( "pmount" );
++ bindtextdomain(PACKAGE, NULL );
++ textdomain(PACKAGE);
/* If pmount is run without a single argument, print out the list
of removable devices. Does not require root privileges, just read access
-Index: pmount-0.9.17/src/pumount.c
+Index: pmount-0.9.18/src/pumount.c
===================================================================
---- pmount-0.9.17.orig/src/pumount.c 2008-10-08 23:38:21.122028300 +0200
-+++ pmount-0.9.17/src/pumount.c 2008-10-08 23:38:47.972023678 +0200
-@@ -16,9 +16,12 @@
+--- pmount-0.9.18.orig/src/pumount.c 2008-10-09 23:19:46.000000000 +0200
++++ pmount-0.9.18/src/pumount.c 2009-07-12 17:16:00.722456315 +0200
+@@ -16,9 +16,9 @@
#include <sys/wait.h>
#include <limits.h>
#include <getopt.h>
-#include <libintl.h>
#include <locale.h>
-+#ifdef ENABLE_NLS
-+#include <libintl.h>
-+#endif
+
#include "policy.h"
#include "utils.h"
#include "luks.h"
-@@ -172,10 +175,12 @@
- { NULL, 0, NULL, 0}
- };
+@@ -174,8 +174,8 @@
-+#ifdef ENABLE_NLS
/* initialize locale */
setlocale( LC_ALL, "" );
- bindtextdomain( "pmount", NULL );
- textdomain( "pmount" );
-+#endif
+- bindtextdomain( "pmount", NULL );
+- textdomain( "pmount" );
++ bindtextdomain(PACKAGE, NULL );
++ textdomain(PACKAGE);
/* are we root? */
if( geteuid() ) {
+Index: pmount-0.9.18/src/luks.c
+===================================================================
+--- pmount-0.9.18.orig/src/luks.c 2009-07-12 17:17:45.278704656 +0200
++++ pmount-0.9.18/src/luks.c 2009-07-12 17:17:49.627119155 +0200
+@@ -14,7 +14,6 @@
+ #include <stdio.h>
+ #include <limits.h>
+ #include <sys/stat.h>
+-#include <libintl.h>
+
+ enum decrypt_status
+ luks_decrypt( const char* device, char* decrypted, int decrypted_size,
+Index: pmount-0.9.18/src/policy.c
+===================================================================
+--- pmount-0.9.18.orig/src/policy.c 2009-07-12 17:17:55.502449663 +0200
++++ pmount-0.9.18/src/policy.c 2009-07-12 17:18:03.200672861 +0200
+@@ -18,7 +18,6 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <dirent.h>
+-#include <libintl.h>
+ #include <sys/stat.h>
+ #include <sysfs/libsysfs.h>
+ #include <regex.h>
+Index: pmount-0.9.18/src/realpath.c
+===================================================================
+--- pmount-0.9.18.orig/src/realpath.c 2009-07-12 17:18:27.354526224 +0200
++++ pmount-0.9.18/src/realpath.c 2009-07-12 17:18:32.256256916 +0200
+@@ -31,7 +31,6 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include "realpath.h"
+-#include <libintl.h>
+ #include "utils.h"
+
+ #define MAX_READLINKS 32
+Index: pmount-0.9.18/src/utils.c
+===================================================================
+--- pmount-0.9.18.orig/src/utils.c 2009-07-12 17:18:09.718277410 +0200
++++ pmount-0.9.18/src/utils.c 2009-07-12 17:18:13.935179014 +0200
+@@ -21,7 +21,6 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <signal.h>
+-#include <libintl.h>
+
+ /* File name used to tag directories created by pmount */
+ #define CREATED_DIR_STAMP ".created_by_pmount"
diff --git a/recipes/pmount/pmount_0.9.18.bb b/recipes/pmount/pmount_0.9.18.bb
index 26770b33a9..71a823e698 100644
--- a/recipes/pmount/pmount_0.9.18.bb
+++ b/recipes/pmount/pmount_0.9.18.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Policy based mounter that gives the ability to mount removable devices as a user"
HOMEPAGE = "http://pmount.alioth.debian.org/"
LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
DEPENDS = "hal e2fsprogs-libs sysfsutils"
RDEPENDS_${PN}-hal = "${PN}"