summaryrefslogtreecommitdiffstats
path: root/recipes/podget
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/podget
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/podget')
-rw-r--r--recipes/podget/podget-0.5.8/busybox_df.patch11
-rw-r--r--recipes/podget/podget_0.5.8.bb16
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/podget/podget-0.5.8/busybox_df.patch b/recipes/podget/podget-0.5.8/busybox_df.patch
new file mode 100644
index 0000000000..1f84558d92
--- /dev/null
+++ b/recipes/podget/podget-0.5.8/busybox_df.patch
@@ -0,0 +1,11 @@
+--- podget/podget~ 2008-05-08 08:50:23.000000000 +0000
++++ podget/podget 2008-05-08 08:50:37.000000000 +0000
+@@ -535,7 +535,7 @@
+ url_base=$(echo $url | sed -e 's/\(.*\/\)[^\/]\+/\1/')
+
+ # Test for available space on library partition
+- avail_space=$(df -kP ${dir_library} | tail -n 1 | awk '{print $4}')
++ avail_space=$(df -k ${dir_library} | tail -n 1 | awk '{print $4}')
+ if [ ${avail_space} -le ${min_space} ] ; then
+ echo -e "\nAvailable space on Library partition has dropped below allowed.\nStopping Session."
+ exit 1
diff --git a/recipes/podget/podget_0.5.8.bb b/recipes/podget/podget_0.5.8.bb
new file mode 100644
index 0000000000..4af771e153
--- /dev/null
+++ b/recipes/podget/podget_0.5.8.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A simple podcast aggregator."
+HOMEPAGE = "http://podget.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+RDEPENDS = "bash sed wget libiconv"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/podget/podget_${PV}.tar.gz \
+ file://busybox_df.patch;patch=1"
+
+S = "${WORKDIR}/podget"
+
+do_install () {
+ install -d ${D}/usr/bin
+ install -m 0755 ${WORKDIR}/podget/podget ${D}/usr/bin
+}