summaryrefslogtreecommitdiffstats
path: root/recipes/poppler
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/poppler
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/poppler')
-rw-r--r--recipes/poppler/poppler-data_0.1.bb16
-rw-r--r--recipes/poppler/poppler-fpu.inc6
-rw-r--r--recipes/poppler/poppler.inc28
-rw-r--r--recipes/poppler/poppler/fix-splash.patch28
-rw-r--r--recipes/poppler/poppler_0.5.9.bb7
-rw-r--r--recipes/poppler/poppler_0.6.4.bb6
-rw-r--r--recipes/poppler/poppler_0.8.4.bb6
7 files changed, 97 insertions, 0 deletions
diff --git a/recipes/poppler/poppler-data_0.1.bb b/recipes/poppler/poppler-data_0.1.bb
new file mode 100644
index 0000000000..e145cb07ee
--- /dev/null
+++ b/recipes/poppler/poppler-data_0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
+LICENSE = "Adobe"
+PR = "r1"
+
+SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
+
+do_compile() {
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${datadir}"
+PACKAGE_ARCH = "all"
+
diff --git a/recipes/poppler/poppler-fpu.inc b/recipes/poppler/poppler-fpu.inc
new file mode 100644
index 0000000000..a26273020a
--- /dev/null
+++ b/recipes/poppler/poppler-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_poppler_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixedpoint"
+ return ""
+
diff --git a/recipes/poppler/poppler.inc b/recipes/poppler/poppler.inc
new file mode 100644
index 0000000000..0e9b61cd30
--- /dev/null
+++ b/recipes/poppler/poppler.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
+DEPENDS = "fontconfig jpeg zlib gtk+ cairo"
+LICENSE = "GPL"
+
+SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "\
+ --enable-xpdf-headers \
+ --disable-gtk-test \
+ --disable-poppler-qt \
+ --disable-poppler-qt4 \
+ --enable-zlib \
+"
+
+# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require poppler-fpu.inc
+EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libpoppler libpoppler-glib"
+FILES_libpoppler = "${libdir}/libpoppler.so.*"
+FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
+
diff --git a/recipes/poppler/poppler/fix-splash.patch b/recipes/poppler/poppler/fix-splash.patch
new file mode 100644
index 0000000000..001c4ce301
--- /dev/null
+++ b/recipes/poppler/poppler/fix-splash.patch
@@ -0,0 +1,28 @@
+--- poppler/splash/SplashMath.h 2007/04/25 19:59:10 1.3
++++ poppler/splash/SplashMath.h 2007/06/01 18:34:48 1.4
+@@ -8,7 +8,7 @@
+ #define SPLASHMATH_H
+
+ #if USE_FIXEDPOINT
+-#include "FixedPoint.h"
++#include "goo/FixedPoint.h"
+ #else
+ #include <math.h>
+ #endif
+--- poppler/splash/SplashFTFont.cc 2007/04/25 19:59:10 1.8
++++ poppler/splash/SplashFTFont.cc 2007/06/01 18:34:48 1.9
+@@ -127,10 +127,10 @@
+ matrix.yx = (FT_Fixed)((mat[1] / size).getRaw());
+ matrix.xy = (FT_Fixed)((mat[2] / size).getRaw());
+ matrix.yy = (FT_Fixed)((mat[3] / size).getRaw());
+- textMatrix.xx = (FT_Fixed)((textMat[0] / (size * textScale)).getRaw());
+- textMatrix.yx = (FT_Fixed)((textMat[1] / (size * textScale)).getRaw());
+- textMatrix.xy = (FT_Fixed)((textMat[2] / (size * textScale)).getRaw());
+- textMatrix.yy = (FT_Fixed)((textMat[3] / (size * textScale)).getRaw());
++ textMatrix.xx = (FT_Fixed)((textMat[0] / (textScale * size)).getRaw());
++ textMatrix.yx = (FT_Fixed)((textMat[1] / (textScale * size)).getRaw());
++ textMatrix.xy = (FT_Fixed)((textMat[2] / (textScale * size)).getRaw());
++ textMatrix.yy = (FT_Fixed)((textMat[3] / (textScale * size)).getRaw());
+ #else
+ matrix.xx = (FT_Fixed)((mat[0] / size) * 65536);
+ matrix.yx = (FT_Fixed)((mat[1] / size) * 65536);
diff --git a/recipes/poppler/poppler_0.5.9.bb b/recipes/poppler/poppler_0.5.9.bb
new file mode 100644
index 0000000000..2fc2200afc
--- /dev/null
+++ b/recipes/poppler/poppler_0.5.9.bb
@@ -0,0 +1,7 @@
+require poppler.inc
+
+PR = "r1"
+
+SRC_URI += "file://fix-splash.patch;patch=1"
+EXTRA_OECONF_append = " --disable-abiword-output "
+
diff --git a/recipes/poppler/poppler_0.6.4.bb b/recipes/poppler/poppler_0.6.4.bb
new file mode 100644
index 0000000000..3c1ec00183
--- /dev/null
+++ b/recipes/poppler/poppler_0.6.4.bb
@@ -0,0 +1,6 @@
+require poppler.inc
+
+PR = "r0"
+
+EXTRA_OECONF_append = " --disable-abiword-output "
+
diff --git a/recipes/poppler/poppler_0.8.4.bb b/recipes/poppler/poppler_0.8.4.bb
new file mode 100644
index 0000000000..3c1ec00183
--- /dev/null
+++ b/recipes/poppler/poppler_0.8.4.bb
@@ -0,0 +1,6 @@
+require poppler.inc
+
+PR = "r0"
+
+EXTRA_OECONF_append = " --disable-abiword-output "
+