aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/popt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-04 11:31:46 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-05 08:25:50 -0700
commitc55e51d03a08a62061765de4283ed1b1c4f2d12a (patch)
tree6b857b8e8936bfb88e93babdd646ca6c3ae70966 /recipes/popt
parent658594deb58673b587e3f136494d3376d5114e54 (diff)
downloadopenembedded-c55e51d03a08a62061765de4283ed1b1c4f2d12a.tar.gz
popt: Use BBCLASSEXTEND instead of native recipes.
* Use INC_PR Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/popt')
-rw-r--r--recipes/popt/popt-native_1.14.bb5
-rw-r--r--recipes/popt/popt-native_1.7.bb10
-rw-r--r--recipes/popt/popt.inc4
-rw-r--r--recipes/popt/popt_1.14.bb5
-rw-r--r--recipes/popt/popt_1.7.bb8
5 files changed, 7 insertions, 25 deletions
diff --git a/recipes/popt/popt-native_1.14.bb b/recipes/popt/popt-native_1.14.bb
deleted file mode 100644
index dfad9fbf93..0000000000
--- a/recipes/popt/popt-native_1.14.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require popt_${PV}.bb
-DEPENDS = "gettext-native"
-inherit native
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/popt-${PV}"
diff --git a/recipes/popt/popt-native_1.7.bb b/recipes/popt/popt-native_1.7.bb
deleted file mode 100644
index c3c5a63a86..0000000000
--- a/recipes/popt/popt-native_1.7.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require popt_${PV}.bb
-DEPENDS = "gettext-native"
-inherit native
-
-S = "${WORKDIR}/popt-${PV}"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/popt-${PV}"
-
-SRC_URI[md5sum] = "5988e7aeb0ae4dac8d83561265984cc9"
-SRC_URI[sha256sum] = "4e75cb28793f0d44134f71fae53057d5f250805e6268fbd9c9780654b73b0dc1"
diff --git a/recipes/popt/popt.inc b/recipes/popt/popt.inc
index 07671d798f..d95bc4925f 100644
--- a/recipes/popt/popt.inc
+++ b/recipes/popt/popt.inc
@@ -4,6 +4,6 @@ AUTHOR = "Jeff Johnson"
LICENSE = "MIT"
SECTION = "libs"
-S = "${WORKDIR}/popt-${PV}"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/popt-${PV}"
+INC_PR = "r3"
+inherit autotools gettext
diff --git a/recipes/popt/popt_1.14.bb b/recipes/popt/popt_1.14.bb
index 1f6a220611..d5e9a604b9 100644
--- a/recipes/popt/popt_1.14.bb
+++ b/recipes/popt/popt_1.14.bb
@@ -1,11 +1,10 @@
require popt.inc
-PR = "r2"
-
-inherit autotools_stage gettext
+PR = "${INC_PR}.0"
SRC_URI = "\
http://rpm5.org/files/popt/popt-${PV}.tar.gz \
"
+BBCLASSEXTEND = "native"
SRC_URI[md5sum] = "4f90a07316eb825604dd10ae4f9f3f04"
SRC_URI[sha256sum] = "175be17571e9af3ad622531b494a0738ae632c60c8c6329273778b2b6fbbad74"
diff --git a/recipes/popt/popt_1.7.bb b/recipes/popt/popt_1.7.bb
index aab80943a4..c568539ed1 100644
--- a/recipes/popt/popt_1.7.bb
+++ b/recipes/popt/popt_1.7.bb
@@ -1,10 +1,6 @@
require popt.inc
-PR = "r1"
-
-DEPENDS = "gettext virtual/libintl"
-
-inherit autotools autotools_stage
+PR = "${INC_PR}.0"
SRC_URI = "\
http://rpm.org/releases/historical/rpm-4.1.x/popt-${PV}.tar.gz \
@@ -22,5 +18,7 @@ do_configure() {
oe_runconf
}
+BBCLASSEXTEND = "native"
+
SRC_URI[md5sum] = "5988e7aeb0ae4dac8d83561265984cc9"
SRC_URI[sha256sum] = "4e75cb28793f0d44134f71fae53057d5f250805e6268fbd9c9780654b73b0dc1"