aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/poptop/accel-pptp-server
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-04-27 15:38:54 +0200
committerKoen Kooi <koen@openembedded.org>2011-04-28 14:08:42 +0200
commitf4aa7b68e5c714d6c23ee4bc55c49ea0ae52abb3 (patch)
treee26967a3bbacc9599cbf57f6beb82fea3f52b308 /recipes/poptop/accel-pptp-server
parent61e09b313e58d999633029d8d840673dee2c94d9 (diff)
downloadopenembedded-f4aa7b68e5c714d6c23ee4bc55c49ea0ae52abb3.tar.gz
accel-pptp-server: add 0.8.5
accel-pptp-server is a fork of poptop that keeps the pptp stuff in the kernel avoiding needless roundtrips to userspace. pre 2.6.37 you needed an external module, post 2.6.37 it is upstream. Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/poptop/accel-pptp-server')
-rw-r--r--recipes/poptop/accel-pptp-server/0001-configure-remove-pppd-check.patch50
-rw-r--r--recipes/poptop/accel-pptp-server/0002-plugins-fix-DESTDIR-and-install-params.patch35
2 files changed, 85 insertions, 0 deletions
diff --git a/recipes/poptop/accel-pptp-server/0001-configure-remove-pppd-check.patch b/recipes/poptop/accel-pptp-server/0001-configure-remove-pppd-check.patch
new file mode 100644
index 0000000000..e6d9a4dff5
--- /dev/null
+++ b/recipes/poptop/accel-pptp-server/0001-configure-remove-pppd-check.patch
@@ -0,0 +1,50 @@
+From 57d120e1c098b9637e69755e1204c11c3e01872a Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 27 Apr 2011 15:25:08 +0200
+Subject: [PATCH 1/2] configure: remove pppd check
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ configure.in | 21 +++------------------
+ 1 files changed, 3 insertions(+), 18 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 8c4e640..f29aa5f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -202,23 +202,8 @@ AC_MSG_RESULT(found ($KERNELVERSION at ${header/include}))
+ CFLAGS="${CFLAGS} -I. -I${header}"
+ AC_SUBST(kernel_headers,${header})
+
+-AC_MSG_CHECKING(for pppd)
+-pppd=`which pppd 2>&1`
+-if test $? -eq 1; then
+- pppd=""
+- for path in /usr/sbin /usr/local/sbin /usr/bin /usr/local/bin /sbin; do
+- if test -x ${path}/pppd; then
+- pppd=${path}/pppd
+- break;
+- fi
+- done
+-fi
+-
+-if test -z "${pppd}"; then
+- AC_MSG_RESULT(not found)
+- AC_MSG_ERROR(Could not find pppd)
+-fi
+-pppd_ver=`${pppd} --version 2>&1 | grep version | sed 's/pppd version //'`
++pppd="/usr/sbin/pppd"
++pppd_ver="2.4.3"
+ AC_MSG_RESULT($pppd ($pppd_ver))
+ AC_DEFINE_UNQUOTED(PPPD_VERSION,"${pppd_ver}")
+
+@@ -247,4 +232,4 @@ echo ' linux kernel: '$KERNELVERSION at ${header/include}
+
+ AC_CACHE_SAVE
+ AC_OUTPUT(Makefile)
+-
+\ No newline at end of file
++
+--
+1.6.6.1
+
diff --git a/recipes/poptop/accel-pptp-server/0002-plugins-fix-DESTDIR-and-install-params.patch b/recipes/poptop/accel-pptp-server/0002-plugins-fix-DESTDIR-and-install-params.patch
new file mode 100644
index 0000000000..c8e530ab78
--- /dev/null
+++ b/recipes/poptop/accel-pptp-server/0002-plugins-fix-DESTDIR-and-install-params.patch
@@ -0,0 +1,35 @@
+From 75336372c6e197b3a4316d977f4db4f0ef345c3c Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 27 Apr 2011 15:31:02 +0200
+Subject: [PATCH 2/2] plugins: fix DESTDIR and install params
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ plugins/Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/Makefile b/plugins/Makefile
+index 059cba1..7561d06 100644
+--- a/plugins/Makefile
++++ b/plugins/Makefile
+@@ -3,7 +3,7 @@ COPTS = -O2 -g
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+-INSTALL = install -o root
++INSTALL = install
+ prefix = /usr/local
+
+ PLUGINS = pptpd-logwtmp.so
+@@ -18,7 +18,7 @@ all: $(PLUGINS)
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR = $(DESTDIR)$(prefix)/lib/pptpd
+
+ install: $(PLUGINS)
+ $(INSTALL) -d $(LIBDIR)
+--
+1.6.6.1
+