summaryrefslogtreecommitdiffstats
path: root/recipes/poptop/poptop-1.3.4
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/poptop/poptop-1.3.4
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/poptop/poptop-1.3.4')
-rw-r--r--recipes/poptop/poptop-1.3.4/fix-plugins-install.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch b/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch
new file mode 100644
index 0000000000..8a02f7a5de
--- /dev/null
+++ b/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch
@@ -0,0 +1,26 @@
+Don't try and install as root.
+Always set LIBDIR to the include the DESTDIR, otherwise it uses the
+incorrect value set in the toplevel makefile.
+
+Index: pptpd-1.3.4/plugins/Makefile
+===================================================================
+--- pptpd-1.3.4.orig/plugins/Makefile 2006-08-03 12:02:01.000000000 +1000
++++ pptpd-1.3.4/plugins/Makefile 2007-06-09 11:42:57.000000000 +1000
+@@ -3,7 +3,7 @@
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+-INSTALL = install -o root
++INSTALL = install
+ prefix = /usr/local
+
+ PLUGINS = pptpd-logwtmp.so
+@@ -18,7 +18,7 @@
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR = $(DESTDIR)$(prefix)/lib/pptpd
+
+ install: $(PLUGINS)
+ $(INSTALL) -d $(LIBDIR)