summaryrefslogtreecommitdiffstats
path: root/recipes/poptop/poptop_1.3.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/poptop/poptop_1.3.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/poptop/poptop_1.3.4.bb')
-rw-r--r--recipes/poptop/poptop_1.3.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/poptop/poptop_1.3.4.bb b/recipes/poptop/poptop_1.3.4.bb
new file mode 100644
index 0000000000..5c6a71bb2e
--- /dev/null
+++ b/recipes/poptop/poptop_1.3.4.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Poptop is the PPTP server solution for Linux Using Poptop, \
+Linux servers can now function seamlessly in a PPTP VPN environment. This \
+enables administrators to leverage the considerable benefits of both \
+Microsoft and Linux operating systems The current release version supports \
+Windows 95/98/Me/NT/2000/XP PPTP clients and Linux PPTP clients"
+HOMEPAGE = "http://www.poptop.org/"
+SECTION = "network"
+LICENSE = "GPL"
+RDEPENDS_${PN} = "ppp"
+RDEPENDS_${PN}-logwtmp-plugin = "${PN}"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/poptop/pptpd-${PV}.tar.gz \
+ file://fix-plugins-install.patch;patch=1 \
+ file://pptpd.init"
+
+S = "${WORKDIR}/pptpd-${PV}"
+
+inherit autotools update-rc.d
+
+do_install_append() {
+ # Install init script
+ install -m 0755 -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pptpd.init ${D}${sysconfdir}/init.d/pptpd
+ # Install
+ install -d ${D}${sbindir} ${D}/${sysconfdir} ${D}/${sysconfdir}/ppp
+ install -m 0644 samples/options.pptpd ${D}/${sysconfdir}/ppp/
+ install -m 0644 samples/pptpd.conf ${D}/${sysconfdir}/
+ # broken
+ rm -f ${D}${libdir}/pptpd/pptpd-logwtmp.so
+}
+
+PACKAGES = "${PN}-dbg ${PN}-bcrelay ${PN} ${PN}-doc"
+
+FILES_${PN}-bcrelay = "${sbindir}/bcrelay"
+
+CONFFILES_${PN} = "${sysconfdir}/pptpd.conf \
+ ${sysconfdir}/ppp/options.pptpd"
+
+INITSCRIPT_NAME = "pptpd"
+INITSCRIPT_PARAMS = "defaults 92 08"