aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/poptop
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/poptop
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/poptop')
-rwxr-xr-xrecipes/poptop/files/pptpd.init37
-rw-r--r--recipes/poptop/poptop-1.3.4/fix-plugins-install.patch26
-rw-r--r--recipes/poptop/poptop_1.3.0.bb35
-rw-r--r--recipes/poptop/poptop_1.3.4.bb41
4 files changed, 139 insertions, 0 deletions
diff --git a/recipes/poptop/files/pptpd.init b/recipes/poptop/files/pptpd.init
new file mode 100755
index 0000000000..27786cd0c2
--- /dev/null
+++ b/recipes/poptop/files/pptpd.init
@@ -0,0 +1,37 @@
+#! /bin/sh
+
+test -f /usr/sbin/pptpd || exit 0
+test -f /etc/default/pptpd && . /etc/default/pptpd
+
+case $1 in
+ start)
+ echo -n "Starting PPTP server: pptpd"
+ start-stop-daemon --start --quiet --pidfile /var/run/pptpd.pid \
+ --exec /usr/sbin/pptpd
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping PPTP server: pptpd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/pptpd.pid \
+ --exec /usr/sbin/pptpd
+ echo "."
+ ;;
+ status)
+ pid=$(pidof pptpd)
+ if [ -n "$pid" ] ; then
+ echo "Running with pid $pid"
+ else
+ echo "Not running"
+ fi
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/pptpd {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch b/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch
new file mode 100644
index 0000000000..8a02f7a5de
--- /dev/null
+++ b/recipes/poptop/poptop-1.3.4/fix-plugins-install.patch
@@ -0,0 +1,26 @@
+Don't try and install as root.
+Always set LIBDIR to the include the DESTDIR, otherwise it uses the
+incorrect value set in the toplevel makefile.
+
+Index: pptpd-1.3.4/plugins/Makefile
+===================================================================
+--- pptpd-1.3.4.orig/plugins/Makefile 2006-08-03 12:02:01.000000000 +1000
++++ pptpd-1.3.4/plugins/Makefile 2007-06-09 11:42:57.000000000 +1000
+@@ -3,7 +3,7 @@
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+-INSTALL = install -o root
++INSTALL = install
+ prefix = /usr/local
+
+ PLUGINS = pptpd-logwtmp.so
+@@ -18,7 +18,7 @@
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR = $(DESTDIR)$(prefix)/lib/pptpd
+
+ install: $(PLUGINS)
+ $(INSTALL) -d $(LIBDIR)
diff --git a/recipes/poptop/poptop_1.3.0.bb b/recipes/poptop/poptop_1.3.0.bb
new file mode 100644
index 0000000000..da7ebe6a24
--- /dev/null
+++ b/recipes/poptop/poptop_1.3.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Poptop is the PPTP server solution for Linux \
+Using Poptop, Linux servers can now function seamlessly in a PPTP VPN environment. \
+This enables administrators to leverage the considerable benefits of both Microsoft and Linux operating systems \
+The current release version supports Windows 95/98/Me/NT/2000/XP PPTP clients and Linux PPTP clients \
+For more info visit http://www.poptop.org/"
+
+HOMEPAGE = "http://www.poptop.org/"
+LICENSE = "GPL"
+SECTION = "network"
+PRIORITY = "optional"
+DEPENDS = "ppp"
+RDEPENDS = "ppp"
+
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/poptop/pptpd-${PV}.tar.gz"
+S = "${WORKDIR}/pptpd-${PV}"
+
+
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}/${sysconfdir}
+ install -d ${D}/${sysconfdir}/ppp/
+
+ install -m 0755 pptpd ${D}${sbindir}/
+ install -m 0755 pptpctrl ${D}${sbindir}/
+ install -m 0644 samples/options.pptpd ${D}/${sysconfdir}/ppp/
+ install -m 0644 samples/pptpd.conf ${D}/${sysconfdir}/
+
+
+}
+
diff --git a/recipes/poptop/poptop_1.3.4.bb b/recipes/poptop/poptop_1.3.4.bb
new file mode 100644
index 0000000000..5c6a71bb2e
--- /dev/null
+++ b/recipes/poptop/poptop_1.3.4.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Poptop is the PPTP server solution for Linux Using Poptop, \
+Linux servers can now function seamlessly in a PPTP VPN environment. This \
+enables administrators to leverage the considerable benefits of both \
+Microsoft and Linux operating systems The current release version supports \
+Windows 95/98/Me/NT/2000/XP PPTP clients and Linux PPTP clients"
+HOMEPAGE = "http://www.poptop.org/"
+SECTION = "network"
+LICENSE = "GPL"
+RDEPENDS_${PN} = "ppp"
+RDEPENDS_${PN}-logwtmp-plugin = "${PN}"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/poptop/pptpd-${PV}.tar.gz \
+ file://fix-plugins-install.patch;patch=1 \
+ file://pptpd.init"
+
+S = "${WORKDIR}/pptpd-${PV}"
+
+inherit autotools update-rc.d
+
+do_install_append() {
+ # Install init script
+ install -m 0755 -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pptpd.init ${D}${sysconfdir}/init.d/pptpd
+ # Install
+ install -d ${D}${sbindir} ${D}/${sysconfdir} ${D}/${sysconfdir}/ppp
+ install -m 0644 samples/options.pptpd ${D}/${sysconfdir}/ppp/
+ install -m 0644 samples/pptpd.conf ${D}/${sysconfdir}/
+ # broken
+ rm -f ${D}${libdir}/pptpd/pptpd-logwtmp.so
+}
+
+PACKAGES = "${PN}-dbg ${PN}-bcrelay ${PN} ${PN}-doc"
+
+FILES_${PN}-bcrelay = "${sbindir}/bcrelay"
+
+CONFFILES_${PN} = "${sysconfdir}/pptpd.conf \
+ ${sysconfdir}/ppp/options.pptpd"
+
+INITSCRIPT_NAME = "pptpd"
+INITSCRIPT_PARAMS = "defaults 92 08"