aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/postgresql
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-06 13:38:24 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-06 13:38:24 +0000
commit66fe0d8e7fdf7ac665ed8d1facae3143aacf4de4 (patch)
treeb314eac877ab59fd9a3b82154b8dc2c89ca9081a /recipes/postgresql
parentc273263b147da671b5ee105eb85d4302daf33555 (diff)
downloadopenembedded-66fe0d8e7fdf7ac665ed8d1facae3143aacf4de4.tar.gz
postgresql: use LDFLAGS for shared libs (fixes QA error)
Diffstat (limited to 'recipes/postgresql')
-rw-r--r--recipes/postgresql/postgresql.inc3
-rw-r--r--recipes/postgresql/postgresql_8.1.4.bb2
-rw-r--r--recipes/postgresql/postgresql_8.1.8.bb2
-rw-r--r--recipes/postgresql/postgresql_8.2.4.bb2
4 files changed, 6 insertions, 3 deletions
diff --git a/recipes/postgresql/postgresql.inc b/recipes/postgresql/postgresql.inc
index da74516830..4a11e2a420 100644
--- a/recipes/postgresql/postgresql.inc
+++ b/recipes/postgresql/postgresql.inc
@@ -11,6 +11,9 @@ SRC_URI = "ftp://ftp-archives.postgresql.org/pub/source/v${PV}/${P}.tar.bz2"
LEAD_SONAME = "libpq.so"
+# LDFLAGS for shared libraries
+export LDFLAGS_SL = "${LDFLAGS}"
+
inherit autotools pkgconfig
do_compile_append() {
diff --git a/recipes/postgresql/postgresql_8.1.4.bb b/recipes/postgresql/postgresql_8.1.4.bb
index cfb0162bb4..42ba3770ad 100644
--- a/recipes/postgresql/postgresql_8.1.4.bb
+++ b/recipes/postgresql/postgresql_8.1.4.bb
@@ -1,3 +1,3 @@
require postgresql.inc
-PR = "r3"
+PR = "r4"
diff --git a/recipes/postgresql/postgresql_8.1.8.bb b/recipes/postgresql/postgresql_8.1.8.bb
index cfb0162bb4..42ba3770ad 100644
--- a/recipes/postgresql/postgresql_8.1.8.bb
+++ b/recipes/postgresql/postgresql_8.1.8.bb
@@ -1,3 +1,3 @@
require postgresql.inc
-PR = "r3"
+PR = "r4"
diff --git a/recipes/postgresql/postgresql_8.2.4.bb b/recipes/postgresql/postgresql_8.2.4.bb
index 9b60b2b6a7..7e2c370471 100644
--- a/recipes/postgresql/postgresql_8.2.4.bb
+++ b/recipes/postgresql/postgresql_8.2.4.bb
@@ -1,6 +1,6 @@
require postgresql.inc
-PR = "r3"
+PR = "r4"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://ftp.de.postgresql.org/mirror/postgresql/source/v${PV}/${P}.tar.bz2 \