summaryrefslogtreecommitdiffstats
path: root/recipes/povray
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/povray
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/povray')
-rw-r--r--recipes/povray/files/configure-cross-hack.patch94
-rw-r--r--recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch42
-rw-r--r--recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff70
-rw-r--r--recipes/povray/povray_3.6.1+3.7.0-beta25b.bb44
-rw-r--r--recipes/povray/povray_3.6.1.bb42
5 files changed, 292 insertions, 0 deletions
diff --git a/recipes/povray/files/configure-cross-hack.patch b/recipes/povray/files/configure-cross-hack.patch
new file mode 100644
index 0000000000..550eac9323
--- /dev/null
+++ b/recipes/povray/files/configure-cross-hack.patch
@@ -0,0 +1,94 @@
+--- /tmp/configure 2006-09-04 20:44:50.000000000 +0200
++++ povray-3.6.1/configure 2006-09-04 20:44:58.085780000 +0200
+@@ -10287,7 +10287,7 @@
+ # check library version, update LIBS
+ echo "$as_me:$LINENO: checking for libz version >= $required_libz_version" >&5
+ echo $ECHO_N "checking for libz version >= $required_libz_version... $ECHO_C" >&6
+- if test "$cross_compiling" = yes; then
++ if test "$cross_compilingi" = yes; then
+ echo "$as_me:$LINENO: result: cross-compiling, forced" >&5
+ echo "${ECHO_T}cross-compiling, forced" >&6
+
+@@ -10338,7 +10338,7 @@
+ ( exit $ac_status )
+
+ if test "$ac_status" != "1" || ! test -s conftest$ac_exeext ; then
+- pov_check_lib="unknown"
++ pov_check_lib="ok"
+ echo "$as_me:$LINENO: result: $pov_check_lib" >&5
+ echo "${ECHO_T}$pov_check_lib" >&6
+ else
+@@ -10632,7 +10632,7 @@
+ # check library version, update LIBS
+ echo "$as_me:$LINENO: checking for libpng version >= $required_libpng_version" >&5
+ echo $ECHO_N "checking for libpng version >= $required_libpng_version... $ECHO_C" >&6
+- if test "$cross_compiling" = yes; then
++ if test "$cross_compilingi" = yes; then
+ echo "$as_me:$LINENO: result: cross-compiling, forced" >&5
+ echo "${ECHO_T}cross-compiling, forced" >&6
+
+@@ -10683,7 +10683,7 @@
+ ( exit $ac_status )
+
+ if test "$ac_status" != "1" || ! test -s conftest$ac_exeext ; then
+- pov_check_lib="unknown"
++ pov_check_lib="ok"
+ echo "$as_me:$LINENO: result: $pov_check_lib" >&5
+ echo "${ECHO_T}$pov_check_lib" >&6
+ else
+@@ -10989,7 +10989,7 @@
+ # check library version, update LIBS
+ echo "$as_me:$LINENO: checking for libjpeg version >= $required_libjpeg_version" >&5
+ echo $ECHO_N "checking for libjpeg version >= $required_libjpeg_version... $ECHO_C" >&6
+- if test "$cross_compiling" = yes; then
++ if test "$cross_compilings" = yes; then
+ echo "$as_me:$LINENO: result: cross-compiling, forced" >&5
+ echo "${ECHO_T}cross-compiling, forced" >&6
+
+@@ -11041,12 +11041,12 @@
+ ( exit $ac_status )
+
+ if test "$ac_status" != "1" || ! test -s conftest$ac_exeext ; then
+- pov_check_libjpeg="unknown"
++ pov_check_libjpeg="ok"
+ echo "$as_me:$LINENO: result: $pov_check_libjpeg" >&5
+ echo "${ECHO_T}$pov_check_libjpeg" >&6
+ else
+ pov_check_libjpeg_version=`eval $ac_try 2>&1`
+- pov_check_libjpeg="bad"
++ pov_check_libjpeg="ok"
+ echo "$as_me:$LINENO: result: $pov_check_libjpeg_version, $pov_check_libjpeg" >&5
+ echo "${ECHO_T}$pov_check_libjpeg_version, $pov_check_libjpeg" >&6
+ fi
+@@ -11079,7 +11079,7 @@
+
+ subdirs="$subdirs libraries/jpeg"
+
+- if test "$ac_cv_search_jpeg_std_error"; then
++ if test "$ac_cv_search_jpeg_std_errort"; then
+ LIBS=`echo $LIBS | sed s,$ac_cv_search_jpeg_std_error,,g`
+ fi
+ INCJPEG="-I\$(top_srcdir)/libraries/jpeg"
+@@ -11341,7 +11341,7 @@
+ # check library version, update LIBS
+ echo "$as_me:$LINENO: checking for libtiff version >= $required_libtiff_version" >&5
+ echo $ECHO_N "checking for libtiff version >= $required_libtiff_version... $ECHO_C" >&6
+- if test "$cross_compiling" = yes; then
++ if test "$cross_compilingi" = yes; then
+ echo "$as_me:$LINENO: result: cross-compiling, forced" >&5
+ echo "${ECHO_T}cross-compiling, forced" >&6
+
+@@ -11398,11 +11398,11 @@
+ ( exit $ac_status )
+
+ if test "$ac_status" != "1" || ! test -s conftest$ac_exeext ; then
+- pov_check_libtiff="unknown"
++ pov_check_libtiff="ok"
+ echo "$as_me:$LINENO: result: $pov_check_libtiff" >&5
+ echo "${ECHO_T}$pov_check_libtiff" >&6
+ else
+- pov_check_libtiff_version=`eval $ac_try 2>&1`
++ pov_check_libtiff_version="3.6.1"
+ pov_check_libtiff="bad"
+ echo "$as_me:$LINENO: result: $pov_check_libtiff_version, $pov_check_libtiff" >&5
+ echo "${ECHO_T}$pov_check_libtiff_version, $pov_check_libtiff" >&6
diff --git a/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch b/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
new file mode 100644
index 0000000000..e0803bafac
--- /dev/null
+++ b/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
@@ -0,0 +1,42 @@
+--- /tmp/configure.ac 2008-08-14 01:13:37.000000000 +0200
++++ povray-3.7.0.beta.25b/configure.ac 2008-08-14 01:17:56.253198000 +0200
+@@ -357,8 +357,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([z], [$required_libz_version], [z], [zlibVersion], [zlib.h], [zlibVersion()], [$with_zlib])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable ZLIB library])
+- else
+ pov_libz=ok
+ fi
+ fi
+@@ -373,8 +371,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([png], [$required_libpng_version], [png12 png], [png_get_libpng_ver], [png.h], [png_get_libpng_ver(NULL)], [$with_libpng])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable PNG library])
+- else
+ pov_libpng=ok
+ fi
+ fi
+@@ -390,11 +386,9 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBJPEG([$required_libjpeg_version], [$with_libjpeg])
+ if test x"$ax_check_libjpeg" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable JPEG library])
+- else
+ # create jversion.h in builddir
+ test -d "./source" || mkdir ./source
+- echo "#define JVERSION \"${ax_check_libjpeg_version}\"" > ./source/jversion.h
++ echo "#define JVERSION \"62\"" > ./source/jversion.h
+ pov_libjpeg=ok
+ fi
+ fi
+@@ -409,8 +403,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBTIFF([$required_libtiff_version], [$with_libtiff])
+ if test x"$ax_check_libtiff" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable TIFF library])
+- else
+ pov_libtiff=ok
+ fi
+ fi
diff --git a/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff b/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
new file mode 100644
index 0000000000..696dfb471f
--- /dev/null
+++ b/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
@@ -0,0 +1,70 @@
+--- /tmp/processoptions.cpp 2008-08-14 01:47:37.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/processoptions.cpp 2008-08-14 01:48:23.853198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdarg>
+ #include <cctype>
+
+--- /tmp/fileinputoutput.cpp 2008-08-14 01:49:16.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.cpp 2008-08-14 01:49:33.043198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdlib>
+ #include <cstdarg>
+
+--- /tmp/textstreambuffer.cpp 2008-08-14 01:52:07.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/textstreambuffer.cpp 2008-08-14 01:52:21.693198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <algorithm>
+
+ #include "configbase.h"
+--- /tmp/fileinputoutput.h 2008-08-14 01:53:49.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.h 2008-08-14 01:54:07.213198000 +0200
+@@ -96,6 +96,7 @@
+ #include "base/types.h"
+ #include "base/path.h"
+
++#include <cstring>
+ #include <string>
+
+ namespace pov_base
+--- /tmp/configbase.h 2008-08-14 01:57:58.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/configbase.h 2008-08-14 01:58:12.373198000 +0200
+@@ -95,6 +95,7 @@
+ #ifndef CONFIGBASE_H
+ #define CONFIGBASE_H
+
++#include <climits>
+ #include "syspovconfigbase.h"
+
+ #ifndef DBL
+--- /tmp/unixoptions.cpp 2008-08-14 02:02:52.000000000 +0200
++++ povray-3.7.0.beta.25b/vfe/unix/unixoptions.cpp 2008-08-14 10:22:09.073198000 +0200
+@@ -454,13 +454,16 @@
+ char *errormsg =
+ "Cannot determine the current working directory.\n"
+ "Check that the PWD environment variable does exist and is valid.\n";
++ int no_error_call = 1;
+ if(no_error_call)
+ {
+ fprintf(stderr, "%s: %s\n", PACKAGE, errormsg);
+ exit(EXIT_FAILURE);
+ }
++#ifdef USE_ERROR
+ else
+- Error("%s", errormsg);
++ std::Error("%s", errormsg);
++#endif
+ }
+ #endif
+
diff --git a/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb b/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
new file mode 100644
index 0000000000..5ca797cef6
--- /dev/null
+++ b/recipes/povray/povray_3.6.1+3.7.0-beta25b.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
+HOMEPAGE = "http://www.povray.org"
+SECTION = "console/graphics"
+LICENSE = "povray"
+DEPENDS = "virtual/libx11 boost zlib jpeg libpng tiff"
+
+PR = "r1"
+
+#We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
+SRC_URI = "http://www.povray.org/redirect/www.povray.org/beta/source/povray-src-3.7.0.beta.25b.tar.bz2 \
+ file://configure-cross-hack.patch;patch=1 \
+ file://gcc43.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/povray-3.7.0.beta.25b"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --with-boost-thread=boost_thread-mt \
+ --x-includes=${STAGING_INCDIR} \
+ --disable-vsnprintf-check \
+ COMPILED_BY=${MAINTAINER} "
+
+FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -O3 -ftree-vectorize -ffast-math -fno-math-errno "
+
+PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
+
+PACKAGE_ARCH_${PN}-doc = "all"
+
+PACKAGE_ARCH_${PN}-scenes = "all"
+FILES_${PN}-scenes = "${datadir}/povray-3.7/scenes"
+
+PACKAGE_ARCH_${PN}-ini = "all"
+FILES_${PN}-ini = "${datadir}/povray-3.7/ini"
+
+PACKAGE_ARCH_${PN}-icons = "all"
+FILES_${PN}-icons = "${datadir}/povray-3.7/icons"
+
+PACKAGE_ARCH_${PN}-scripts = "all"
+FILES_${PN}-scripts = "${datadir}/povray-3.7/scripts"
+
+PACKAGE_ARCH_${PN}-includes = "all"
+FILES_${PN}-includes = "${datadir}/povray-3.7/include"
+
diff --git a/recipes/povray/povray_3.6.1.bb b/recipes/povray/povray_3.6.1.bb
new file mode 100644
index 0000000000..107c86cfb8
--- /dev/null
+++ b/recipes/povray/povray_3.6.1.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
+HOMEPAGE = "http://www.povray.org"
+SECTION = "console/graphics"
+#Make this a weak assigment to allow branding of the povray binary
+LICENSE = "povray"
+DEPENDS = "virtual/libx11 zlib jpeg libpng tiff"
+RDEPENDS = ""
+
+PR = "r2"
+
+#We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
+SRC_URI = "http://www.povray.org/redirect/www.povray.org/ftp/pub/povray/Official/Unix/${P}.tar.bz2 \
+ file://configure-cross-hack.patch;patch=1"
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+#autoreconf breaks, so we'll skip that. The added advantage is that the patch to ./configure actually has effect
+do_configure() {
+ oe_runconf COMPILED_BY="${MAINTAINER}"
+}
+
+PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
+
+PACKAGE_ARCH_${PN}-doc = "all"
+
+PACKAGE_ARCH_${PN}-scenes = "all"
+FILES_${PN}-scenes = "${datadir}/povray-3.6/scenes"
+
+PACKAGE_ARCH_${PN}-ini = "all"
+FILES_${PN}-ini = "${datadir}/povray-3.6/ini"
+
+PACKAGE_ARCH_${PN}-icons = "all"
+FILES_${PN}-icons = "${datadir}/povray-3.6/icons"
+
+PACKAGE_ARCH_${PN}-scripts = "all"
+FILES_${PN}-scripts = "${datadir}/povray-3.6/scripts"
+
+PACKAGE_ARCH_${PN}-includes = "all"
+FILES_${PN}-includes = "${datadir}/povray-3.6/include"
+