aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop/powertop_1.11.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-11 23:31:12 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-11 23:35:07 -0700
commit53c0673ba015ba400d4e18fef5c5903830a06c09 (patch)
tree2cce6ccdd94a0713614fc5c8b85b665287e47bcf /recipes/powertop/powertop_1.11.bb
parentaa6a11a7168bf804925f78f9003920bce4b3a5e9 (diff)
downloadopenembedded-53c0673ba015ba400d4e18fef5c5903830a06c09.tar.gz
powertop: Make it compile on uclibc.
* Use INC_PR * Move common stuff to powertop.inc * Add -lint for uclibc bases systems * Add a patch to tinker with order of CFLAGS in commandline * Eliminate the sed expression in favor of a patch to substitute nsursesw with ncurses Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/powertop/powertop_1.11.bb')
-rw-r--r--recipes/powertop/powertop_1.11.bb20
1 files changed, 2 insertions, 18 deletions
diff --git a/recipes/powertop/powertop_1.11.bb b/recipes/powertop/powertop_1.11.bb
index 01148cb9fd..6af5290122 100644
--- a/recipes/powertop/powertop_1.11.bb
+++ b/recipes/powertop/powertop_1.11.bb
@@ -1,26 +1,10 @@
-DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
-HOMEPAGE = "http://www.linuxpowertop.org/"
-LICENSE = "GPLv2"
-DEPENDS = "virtual/libintl ncurses"
+require powertop.inc
-PR = "r1"
-
-SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+PR = "${INC_PR}.0"
SRC_URI_append_armv7a = " file://omap.patch;patch=1;pnum=0"
-CFLAGS += "${LDFLAGS}"
CFLAGS_append_beagleboard = " -DOMAP3"
CFLAGS_append_overo = " -DOMAP3"
CFLAGS_append_omap3evm = " -DOMAP3"
CFLAGS_append_omapzoom2 = " -DOMAP3"
-
-
-do_configure() {
- # We do not build ncurses with wide char support
- sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-}