aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-11 23:31:12 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-11 23:35:07 -0700
commit53c0673ba015ba400d4e18fef5c5903830a06c09 (patch)
tree2cce6ccdd94a0713614fc5c8b85b665287e47bcf /recipes/powertop
parentaa6a11a7168bf804925f78f9003920bce4b3a5e9 (diff)
downloadopenembedded-53c0673ba015ba400d4e18fef5c5903830a06c09.tar.gz
powertop: Make it compile on uclibc.
* Use INC_PR * Move common stuff to powertop.inc * Add -lint for uclibc bases systems * Add a patch to tinker with order of CFLAGS in commandline * Eliminate the sed expression in favor of a patch to substitute nsursesw with ncurses Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/powertop')
-rw-r--r--recipes/powertop/files/ldflags.patch13
-rw-r--r--recipes/powertop/powertop.inc27
-rw-r--r--recipes/powertop/powertop_1.10.bb19
-rw-r--r--recipes/powertop/powertop_1.11.bb20
-rw-r--r--recipes/powertop/powertop_1.8.bb18
5 files changed, 46 insertions, 51 deletions
diff --git a/recipes/powertop/files/ldflags.patch b/recipes/powertop/files/ldflags.patch
new file mode 100644
index 0000000000..690d90f8f8
--- /dev/null
+++ b/recipes/powertop/files/ldflags.patch
@@ -0,0 +1,13 @@
+Index: powertop-1.11/Makefile
+===================================================================
+--- powertop-1.11.orig/Makefile 2008-12-30 10:52:54.000000000 -0800
++++ powertop-1.11/Makefile 2009-09-11 19:46:19.550388421 -0700
+@@ -20,7 +20,7 @@
+
+
+ powertop: $(OBJS) Makefile powertop.h
+- $(CC) ${CFLAGS} $(OBJS) -lncursesw -o powertop
++ $(CC) $(OBJS) ${CFLAGS} -lncurses -o powertop
+ @(cd po/ && $(MAKE))
+
+ powertop.1.gz: powertop.1
diff --git a/recipes/powertop/powertop.inc b/recipes/powertop/powertop.inc
new file mode 100644
index 0000000000..931abadc44
--- /dev/null
+++ b/recipes/powertop/powertop.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libintl ncurses"
+
+INC_PR = "r1"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ "
+
+CFLAGS = "${LDFLAGS}"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ # sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+ :
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+
+LDFLAGS_append_linux-uclibc = " -lintl"
+LDFLAGS_append_linux-uclibceabi = " -lintl"
+LDFLAGS_append_linux-uclibcspe = " -lintl"
diff --git a/recipes/powertop/powertop_1.10.bb b/recipes/powertop/powertop_1.10.bb
index 4a429d68ba..49da90e423 100644
--- a/recipes/powertop/powertop_1.10.bb
+++ b/recipes/powertop/powertop_1.10.bb
@@ -1,17 +1,2 @@
-DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
-HOMEPAGE = "http://www.linuxpowertop.org/"
-LICENSE = "GPLv2"
-DEPENDS = "virtual/libintl ncurses"
-
-SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
-
-CFLAGS += "${LDFLAGS}"
-
-do_configure() {
- # We do not build ncurses with wide char support
- sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-}
+require powertop.inc
+PR = "${INC_PR}.0"
diff --git a/recipes/powertop/powertop_1.11.bb b/recipes/powertop/powertop_1.11.bb
index 01148cb9fd..6af5290122 100644
--- a/recipes/powertop/powertop_1.11.bb
+++ b/recipes/powertop/powertop_1.11.bb
@@ -1,26 +1,10 @@
-DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
-HOMEPAGE = "http://www.linuxpowertop.org/"
-LICENSE = "GPLv2"
-DEPENDS = "virtual/libintl ncurses"
+require powertop.inc
-PR = "r1"
-
-SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+PR = "${INC_PR}.0"
SRC_URI_append_armv7a = " file://omap.patch;patch=1;pnum=0"
-CFLAGS += "${LDFLAGS}"
CFLAGS_append_beagleboard = " -DOMAP3"
CFLAGS_append_overo = " -DOMAP3"
CFLAGS_append_omap3evm = " -DOMAP3"
CFLAGS_append_omapzoom2 = " -DOMAP3"
-
-
-do_configure() {
- # We do not build ncurses with wide char support
- sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-}
diff --git a/recipes/powertop/powertop_1.8.bb b/recipes/powertop/powertop_1.8.bb
index ab84161ddc..e74b8a6add 100644
--- a/recipes/powertop/powertop_1.8.bb
+++ b/recipes/powertop/powertop_1.8.bb
@@ -1,17 +1,3 @@
-DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
-HOMEPAGE = "http://www.linuxpowertop.org/"
-LICENSE = "GPLv2"
-DEPENDS = "ncurses"
+require powertop.inc
+PR = "${INC_PR}.0"
-SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
-
-CFLAGS += "${LDFLAGS}"
-
-do_configure() {
- # We do not build ncurses with wide char support
- sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-}