aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-23 13:03:19 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-23 13:03:19 +0200
commit6d446348ff6928c3099e9f7d0a896dbd159687ce (patch)
treeeccb8cfd415b09dffe9c359c9422565f32a5a299 /recipes/powertop
parent4c312174e1b1419e47f3b2d644926a7c985e4312 (diff)
downloadopenembedded-6d446348ff6928c3099e9f7d0a896dbd159687ce.tar.gz
powertop: fix ldflags problem with omap3 machines
Diffstat (limited to 'recipes/powertop')
-rw-r--r--recipes/powertop/powertop_1.11.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes/powertop/powertop_1.11.bb b/recipes/powertop/powertop_1.11.bb
index 2fb8061c59..2f2a3a4255 100644
--- a/recipes/powertop/powertop_1.11.bb
+++ b/recipes/powertop/powertop_1.11.bb
@@ -3,12 +3,17 @@ HOMEPAGE = "http://www.linuxpowertop.org/"
LICENSE = "GPLv2"
DEPENDS = "virtual/libintl ncurses"
+PR = "r1"
+
SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
-SRC_URI_append_beagleboard = " file://omap.patch;patch=1;pnum=0"
+SRC_URI_append_armv7a = " file://omap.patch;patch=1;pnum=0"
CFLAGS += "${LDFLAGS}"
-CFLAGS_beagleboard += "-DOMAP3"
+CFLAGS_append_beagleboard = " -DOMAP3"
+CFLAGS_append_overo = " -DOMAP3"
+CFLAGS_append_omap3evm = " -DOMAP3"
+
do_configure() {
# We do not build ncurses with wide char support