aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-12-05 13:32:20 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-06 13:50:56 +0100
commit36e3ed512646e9b96a8b6a9c969e21a8bc292fb8 (patch)
tree66cecf6f5e7be6837141f7cd13aac5fc5abce18a /recipes/powertop
parentb139be572e76e4c59c2ac098f09b6ead8cb465c7 (diff)
downloadopenembedded-36e3ed512646e9b96a8b6a9c969e21a8bc292fb8.tar.gz
powertop: fix CFLAGS in .inc and add a git version
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/powertop')
-rw-r--r--recipes/powertop/powertop.inc2
-rw-r--r--recipes/powertop/powertop_git.bb19
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes/powertop/powertop.inc b/recipes/powertop/powertop.inc
index 37944b74a4..d6c4fbdb2a 100644
--- a/recipes/powertop/powertop.inc
+++ b/recipes/powertop/powertop.inc
@@ -9,7 +9,7 @@ SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.ta
file://ldflags.patch \
"
-CFLAGS = "${LDFLAGS}"
+CFLAGS += "${LDFLAGS}"
do_configure() {
# We do not build ncurses with wide char support
diff --git a/recipes/powertop/powertop_git.bb b/recipes/powertop/powertop_git.bb
new file mode 100644
index 0000000000..7cfe90fe81
--- /dev/null
+++ b/recipes/powertop/powertop_git.bb
@@ -0,0 +1,19 @@
+# requires kernel 2.6.31+ headers with perf_event_open syscall
+DEFAULT_PREFERENCE = "-1"
+
+require recipes/powertop/powertop.inc
+
+SRCREV = "e9e22ba99bfe0e2f42d52acfd00f434b9d905083"
+PV = "1.13"
+PR = "${INC_PR}.0"
+PR_append = "+gitr${SRCPV}"
+
+SRC_URI = "git://gitorious.org/meego-developer-tools/powertop.git;protocol=git"
+S = "${WORKDIR}/git"
+
+CFLAGS += "-DVERSION=\\"${PV}\\" -Wall -Wshadow -W -Wformat -Wimplicit-function-declaration -Wimplicit-int"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}