aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers/omap3-sgx-modules
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-23 16:04:51 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-24 12:06:59 +0100
commit32799b8fb20c213dd932780bf21148d050d772f4 (patch)
tree905c698018af48ae6aa94094a67badfa5aa674bc /recipes/powervr-drivers/omap3-sgx-modules
parent23681e960148d0edff965eaef30044678eed111e (diff)
downloadopenembedded-32799b8fb20c213dd932780bf21148d050d772f4.tar.gz
libgles-omap3: complete overhaul
* convert to new-style staging * (re)build demos with proper toolchain and flags * build trainingcourses * generate .desktop files on the fly * delete old versions
Diffstat (limited to 'recipes/powervr-drivers/omap3-sgx-modules')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-DSS2.patch96
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/0001-New-build-system-for-SGX.patch247
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-DSS2.patch11
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/build_es3.x_sgx.patch11
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/omap3-sgx-modules-1.3.13.1607.tar.bz2bin178370 -> 0 bytes
-rwxr-xr-xrecipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch22
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/rotation-dss2.patch21
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/spurious-irq-fix.diff11
8 files changed, 0 insertions, 419 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-DSS2.patch b/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-DSS2.patch
deleted file mode 100644
index 7dbf4d9e6e..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/0001-Compile-fixes-for-DSS2.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 8b6a6bb6702ab796ab56dbbd6caa1b271ed4485b Mon Sep 17 00:00:00 2001
-From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
-Date: Fri, 9 Jan 2009 12:40:28 +0200
-Subject: [PATCH] Compile fixes for DSS2
-
----
- .../dc_omap3430_linux/omaplfb_displayclass.c | 6 ++++--
- .../3rdparty/dc_omap3430_linux/omaplfb_linux.c | 14 ++++----------
- 2 files changed, 8 insertions(+), 12 deletions(-)
-
-diff --git a/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c b/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c
-index 7b8ec37..6fde397 100755
---- a/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c
-+++ b/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c
-@@ -57,8 +57,6 @@ PVRSRV_ERROR OMAPLFBPostPower (IMG_HANDLE hDevHandle,
- PVR_POWER_STATE eCurrentPowerState);
- #endif
-
--extern void omap_dispc_set_plane_base(int plane, IMG_UINT32 phys_addr);
--
- static PFN_DC_GET_PVRJTABLE pfnGetPVRJTable = IMG_NULL;
-
- static OMAPLFB_DEVINFO * GetAnchorPtr(IMG_VOID)
-@@ -124,6 +122,9 @@ static void WorkHandler(
- static PVRSRV_ERROR Flip(OMAPLFB_SWAPCHAIN *psSwapChain,
- IMG_UINT32 aPhyAddr)
- {
-+ printk("no flipping\n");
-+ return PVRSRV_OK;
-+#if 0
- if (1 /* omap2_disp_get_output_dev(OMAP2_GRAPHICS) == OMAP2_OUTPUT_LCD */)
- {
- omap_dispc_set_plane_base(0, aPhyAddr);
-@@ -137,6 +138,7 @@ static PVRSRV_ERROR Flip(OMAPLFB_SWAPCHAIN *psSwapChain,
- }
-
- return PVRSRV_ERROR_INVALID_PARAMS;
-+#endif
- }
-
- static IMG_VOID EnableVSyncInterrupt(OMAPLFB_SWAPCHAIN *psSwapChain)
-diff --git a/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c b/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
-index acf1631..12f3e32 100755
---- a/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
-+++ b/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
-@@ -37,6 +37,7 @@
- #include <linux/slab.h>
- #include <linux/errno.h>
- #include <linux/interrupt.h>
-+#include <mach/display.h>
-
- #include <asm/io.h>
-
-@@ -52,10 +53,6 @@ MODULE_LICENSE("GPL");
- MODULE_SUPPORTED_DEVICE(DRVNAME);
-
-
--extern int omap_dispc_request_irq(unsigned long, void (*)(void *), void *);
--extern void omap_dispc_free_irq(unsigned long, void (*)(void *), void *);
--
--
- #define unref__ __attribute__ ((unused))
-
-
-@@ -101,17 +98,14 @@ PVRSRV_ERROR OMAPLFBGetLibFuncAddr (IMG_CHAR *szFunctionName, PFN_DC_GET_PVRJTAB
- }
-
- static void
--OMAPLFBVSyncISR(void *arg)
-+OMAPLFBVSyncISR(void *arg, u32 mask)
- {
- (void) OMAPLFBVSyncIHandler((OMAPLFB_SWAPCHAIN *)arg);
- }
-
--#define DISPC_IRQ_VSYNC 0x0002
--
- PVRSRV_ERROR OMAPLFBInstallVSyncISR(OMAPLFB_SWAPCHAIN *psSwapChain)
- {
--
-- if (omap_dispc_request_irq(DISPC_IRQ_VSYNC, OMAPLFBVSyncISR, psSwapChain) != 0)
-+ if (omap_dispc_register_isr(OMAPLFBVSyncISR, psSwapChain, DISPC_IRQ_VSYNC) != 0)
- return PVRSRV_ERROR_OUT_OF_MEMORY; /* not worth a proper mapping */
-
- return PVRSRV_OK;
-@@ -120,7 +114,7 @@ PVRSRV_ERROR OMAPLFBInstallVSyncISR(OMAPLFB_SWAPCHAIN *psSwapChain)
-
- PVRSRV_ERROR OMAPLFBUninstallVSyncISR (OMAPLFB_SWAPCHAIN *psSwapChain)
- {
-- omap_dispc_free_irq(DISPC_IRQ_VSYNC, OMAPLFBVSyncISR, psSwapChain);
-+ omap_dispc_unregister_isr(OMAPLFBVSyncISR);
-
- return PVRSRV_OK;
- }
---
-1.5.6.3
-
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0001-New-build-system-for-SGX.patch b/recipes/powervr-drivers/omap3-sgx-modules/0001-New-build-system-for-SGX.patch
deleted file mode 100644
index 9751bcd88d..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/0001-New-build-system-for-SGX.patch
+++ /dev/null
@@ -1,247 +0,0 @@
-From 36065340e13e6888e7399a1e5b5b11045e8474c6 Mon Sep 17 00:00:00 2001
-From: Tomba <tomba@bat.org>
-Date: Sun, 1 Feb 2009 15:39:15 +0200
-Subject: [PATCH] New build system for SGX
-
----
- Kbuild | 53 ++++++++++
- Makefile | 151 +++++++++++++++++++++++++++
- services4/3rdparty/dc_omap3430_linux/Kbuild | 8 ++
- 3 files changed, 212 insertions(+), 0 deletions(-)
- create mode 100644 Kbuild
- create mode 100644 Makefile
- create mode 100644 services4/3rdparty/dc_omap3430_linux/Kbuild
-
-diff --git a/Kbuild b/Kbuild
-new file mode 100644
-index 0000000..19f9a24
---- /dev/null
-+++ b/Kbuild
-@@ -0,0 +1,53 @@
-+obj-m := pvrsrvkm.o
-+
-+FILES := \
-+services4/srvkm/common/queue.c \
-+services4/srvkm/common/hash.c \
-+services4/srvkm/common/perproc.c \
-+services4/srvkm/common/mem.c \
-+services4/srvkm/common/power.c \
-+services4/srvkm/common/deviceclass.c \
-+services4/srvkm/common/metrics.c \
-+services4/srvkm/common/resman.c \
-+services4/srvkm/common/buffer_manager.c \
-+services4/srvkm/common/pvrsrv.c \
-+services4/srvkm/common/handle.c \
-+services4/srvkm/common/ra.c \
-+services4/srvkm/common/devicemem.c \
-+services4/srvkm/env/linux/pvr_debug.c \
-+services4/srvkm/env/linux/mm.c \
-+services4/srvkm/env/linux/mutex.c \
-+services4/srvkm/env/linux/mmap.c \
-+services4/srvkm/env/linux/module.c \
-+services4/srvkm/env/linux/proc.c \
-+services4/srvkm/env/linux/event.c \
-+services4/srvkm/env/linux/osfunc.c \
-+services4/srvkm/env/linux/pvr_bridge_k.c \
-+services4/srvkm/env/linux/pdump.c \
-+services4/srvkm/devices/sgx/sgxtransfer.c \
-+services4/srvkm/devices/sgx/sgxinit.c \
-+services4/srvkm/devices/sgx/sgxutils.c \
-+services4/srvkm/devices/sgx/pb.c \
-+services4/srvkm/devices/sgx/sgxkick.c \
-+services4/srvkm/devices/sgx/mmu.c \
-+services4/srvkm/devices/sgx/sgxreset.c \
-+services4/srvkm/bridged/bridged_pvr_bridge.c \
-+services4/system/omap3430/sysutils_linux.c \
-+services4/system/omap3430/sysconfig.c
-+
-+EXTRA_CFLAGS += -I$(src)/include4
-+EXTRA_CFLAGS += -I$(src)/services4/include
-+EXTRA_CFLAGS += -I$(src)/services4/srvkm/include
-+EXTRA_CFLAGS += -I$(src)/services4/srvkm/hwdefs
-+EXTRA_CFLAGS += -I$(src)/services4/srvkm/bridged
-+EXTRA_CFLAGS += -I$(src)/services4/srvkm/devices/sgx
-+EXTRA_CFLAGS += -I$(src)/services4/srvkm/env/linux
-+EXTRA_CFLAGS += -I$(src)/services4/system/include
-+EXTRA_CFLAGS += -I$(src)/services4/system/omap3430
-+
-+EXTRA_CFLAGS += $(ALL_CFLAGS)
-+
-+pvrsrvkm-y := $(FILES:.c=.o)
-+
-+obj-y := services4/3rdparty/dc_omap3430_linux/
-+
-diff --git a/Makefile b/Makefile
-new file mode 100644
-index 0000000..74e9761
---- /dev/null
-+++ b/Makefile
-@@ -0,0 +1,151 @@
-+export DISCIMAGE = /tmp/asdada
-+export KERNELDIR = /home/tomba/work/linux
-+
-+export BUILD = debug
-+
-+export KERNELDIR = /home/tomba/work/linux
-+export KBUILD_EXTRA_SYMBOLS = `pwd`/services4/srvkm/env/linux/kbuild/Module.symvers
-+
-+SGXCORE = 530
-+CORE = -DSGX530 -DSUPPORT_SGX530 -DSGX_CORE_REV=103
-+
-+SUPPORT_SGX = 1
-+SUPPORT_HW_RECOVERY = 1
-+SUPPORT_SGX_HWPERF = 1
-+SYS_USING_INTERRUPTS = 1
-+
-+PVR2D_ALT_2DHW = 1
-+
-+LDM_PLATFORM ?= 1
-+
-+# Only enable active power management if passive power management is
-+# enabled, as indicated by LDM_PLATFORM being set to 1. On OMAP,
-+# the system can suspend in the case where active power management is
-+# enabled in the SGX driver, but passive power management isn't. As
-+# passive power management isn't enabled, the driver won't see the
-+# system suspend/resume events, and so won't take appropriate action.
-+ifeq ($(LDM_PLATFORM),1)
-+SUPPORT_ACTIVE_POWER_MANAGEMENT ?= 1
-+else
-+SUPPORT_ACTIVE_POWER_MANAGEMENT = 0
-+endif
-+
-+export PVR_BUILD_DIR := $(shell pwd)
-+
-+DATE := $(shell date "+%a %B %d %Z %Y" )
-+
-+CBUILD = -DPVR_BUILD_DIR="\"$(PVR_BUILD_DIR)\"" \
-+ -DPVR_BUILD_DATE="\"$(DATE)\"" \
-+ -DPVR_BUILD_TYPE="\"$(BUILD)\""
-+
-+# Don't support HW recovery on debug builds
-+CBUILD.debug = -DDEBUG
-+CBUILD.timing = -DTIMING
-+CBUILD.release = -DRELEASE
-+CFLAGS.debug = -g -O0 -DDLL_METRIC=1
-+CFLAGS.timing = $(OPTIM) -g -DDLL_METRIC=1 -DTIMING
-+CFLAGS.release = $(OPTIM) -g
-+CFLAGS = $(CFLAGS.$(BUILD))
-+
-+
-+ifeq ("$(BUILD)", "debug")
-+DEBUG_LINUX_MEMORY_ALLOCATIONS ?= 1
-+DEBUG_LINUX_MEM_AREAS ?= 1
-+DEBUG_LINUX_MMAP_AREAS ?= 1
-+DEBUG_LINUX_XML_PROC_FILES ?= 0
-+DEBUG_LINUX_SLAB_ALLOCATIONS ?= 0
-+DEBUG_BRIDGE_KM ?= 1
-+DEBUG_TRACE_BRIDGE_KM ?= 0
-+DEBUG_BRIDGE_KM_DISPATCH_TABLE ?= 0
-+endif
-+
-+TRANSFER_QUEUE ?= 1
-+SUPPORT_SGX_EVENT_OBJECT ?= 1
-+SUPPORT_SECURE_HANDLES ?= 1
-+SUPPORT_SRVINIT = 1
-+SUPPORT_PERCONTEXT_PB = 1
-+
-+SYS_CFLAGS += -DSERVICES4 -D_XOPEN_SOURCE=600 -DPVR2D_VALIDATE_INPUT_PARAMS
-+
-+# Thread support
-+USE_PTHREADS ?= 1
-+USE_GCC__thread_KEYWORD ?= 0
-+OPTIMISE_NON_NPTL_SINGLE_THREAD_TLS_LOOKUP ?= 0
-+DISABLE_THREADS ?= 0
-+
-+# Automatically define C compiler macros for features possible (or not) in use.
-+
-+SYS_CFLAGS.$(SUPPORT_SRVINIT) += -DSUPPORT_SRVINIT
-+
-+SYS_CFLAGS.$(SUPPORT_SGX) += -DSUPPORT_SGX
-+SYS_CFLAGS.$(SUPPORT_XWS) += -DSUPPORT_XWS
-+SYS_CFLAGS.$(PDUMP) += -DPDUMP
-+SYS_CFLAGS.$(SUPPORT_POWER_MANAGEMENT) += -DSUPPORT_POWER_MANAGEMENT
-+SYS_CFLAGS.$(SUPPORT_BUFFER_CLASS) += -DSUPPORT_BUFFER_CLASS
-+
-+SYS_CFLAGS.$(SUPPORT_PERCONTEXT_PB) += -DSUPPORT_PERCONTEXT_PB
-+SYS_CFLAGS.$(SUPPORT_DYNAMIC_PBRESIZE) += -DSUPPORT_DYNAMIC_PBRESIZE
-+
-+SYS_CFLAGS.$(USE_FBDEV) += -DUSE_FBDEV
-+SYS_CFLAGS.$(USE_FBDEV) += -DFBDEV_NAME="\"$(FBDEV_NAME)\""
-+SYS_CFLAGS.$(SUPPORT_DYNAMIC_3DCLOCKGATING) += -DSUPPORT_DYNAMIC_3DCLOCKGATING
-+SYS_CFLAGS.$(REENTRANCY_PROTECTION) += -DREENTRANCY_PROTECTION
-+SYS_CFLAGS.$(SCHEDULER_CONTROL_SUPPORT) += -DSCHEDULER_CONTROL_SUPPORT
-+SYS_CFLAGS.$(USE_IMG_POWER_DOMAIN_FUNCTION) += -DUSE_IMG_POWER_DOMAIN_FUNCTION
-+
-+SYS_CFLAGS.$(USE_DMALLOC) += -DDMALLOC
-+
-+SYS_CFLAGS.$(DEBUG_LINUX_MEMORY_ALLOCATIONS) += -DDEBUG_LINUX_MEMORY_ALLOCATIONS
-+SYS_CFLAGS.$(DEBUG_LINUX_MEM_AREAS) += -DDEBUG_LINUX_MEM_AREAS
-+SYS_CFLAGS.$(DEBUG_LINUX_MMAP_AREAS) += -DDEBUG_LINUX_MMAP_AREAS
-+SYS_CFLAGS.$(DEBUG_LINUX_XML_PROC_FILES) += -DDEBUG_LINUX_XML_PROC_FILES
-+SYS_CFLAGS.$(DEBUG_LINUX_SLAB_ALLOCATIONS) += -DDEBUG_LINUX_SLAB_ALLOCATIONS
-+SYS_CFLAGS.$(DEBUG_BRIDGE_KM) += -DDEBUG_BRIDGE_KM
-+SYS_CFLAGS.$(DEBUG_TRACE_BRIDGE_KM) += -DDEBUG_TRACE_BRIDGE_KM
-+SYS_CFLAGS.$(DEBUG_BRIDGE_KM_DISPATCH_TABLE) += -DDEBUG_BRIDGE_KM_DISPATCH_TABLE
-+
-+SYS_CFLAGS.$(SUPPORT_LINUX_X86_WRITECOMBINE) += -DSUPPORT_LINUX_X86_WRITECOMBINE
-+
-+SYS_CFLAGS.$(SGX_PDS_EVENTS_DISABLED) += -DSGX_PDS_EVENTS_DISABLED
-+SYS_CFLAGS.$(USE_SUPPORT_NO_TA3D_OVERLAP) += -DUSE_SUPPORT_NO_TA3D_OVERLAP
-+SYS_CFLAGS.$(SUPPORT_SGX_TILING) += -DSUPPORT_SGX_TILING
-+SYS_CFLAGS.$(TRANSFER_QUEUE) += -DTRANSFER_QUEUE
-+
-+SYS_CFLAGS.$(SUPPORT_SGX_MMU_DUMMY_PAGE) += -DSUPPORT_SGX_MMU_DUMMY_PAGE
-+
-+SYS_CFLAGS.$(PVRSRV_USSE_EDM_STATUS_DEBUG) += -DPVRSRV_USSE_EDM_STATUS_DEBUG
-+
-+SYS_CFLAGS.$(SUPPORT_DRI_DRM) += -DSUPPORT_DRI_DRM
-+
-+SYS_CFLAGS.$(SYS_USING_INTERRUPTS) += -DSYS_USING_INTERRUPTS
-+SYS_CFLAGS.$(SUPPORT_HW_RECOVERY) += -DSUPPORT_HW_RECOVERY
-+SYS_CFLAGS.$(SUPPORT_ACTIVE_POWER_MANAGEMENT) += -DSUPPORT_ACTIVE_POWER_MANAGEMENT
-+
-+SYS_CFLAGS.$(SUPPORT_SECURE_HANDLES) += -DPVR_SECURE_HANDLES
-+
-+SYS_CFLAGS.$(USE_PTHREADS) += -DUSE_PTHREADS
-+SYS_CFLAGS.$(USE_GCC__thread_KEYWORD) += -DUSE_GCC__thread_KEYWORD
-+SYS_CFLAGS.$(OPTIMISE_NON_NPTL_SINGLE_THREAD_TLS_LOOKUP) += -DOPTIMISE_NON_NPTL_SINGLE_THREAD_TLS_LOOKUP
-+SYS_CFLAGS.$(DISABLE_THREADS) += -DDISABLE_THREADS
-+SYS_CFLAGS.$(SUPPORT_SGX_EVENT_OBJECT) += -DSUPPORT_SGX_EVENT_OBJECT
-+SYS_CFLAGS.$(LDM_PLATFORM) += -DLDM_PLATFORM
-+SYS_CFLAGS.$(LDM_PCI) += -DLDM_PCI
-+SYS_CFLAGS.$(PVR_MANUAL_POWER_CONTROL) += -DPVR_MANUAL_POWER_CONTROL
-+
-+SYS_CFLAGS.$(PVR2D_ALT_2DHW) += -DPVR2D_ALT_2DHW
-+
-+SYS_CFLAGS.$(SUPPORT_SGX_HWPERF) += -DSUPPORT_SGX_HWPERF
-+
-+export ALL_CFLAGS = -DLINUX \
-+ $(CBUILD) $(CBUILD.$(BUILD)) \
-+ $(SYS_CFLAGS) $(SYS_CFLAGS.1) \
-+ $(MODULE_CFLAGS) $(MODULE_CFLAGS.$(BUILD)) \
-+ $(CORE) \
-+ $(CFLAGS)
-+
-+all:
-+ $(MAKE) -C $(KERNELDIR) M=`pwd` $*
-+
-+clean:
-+ $(MAKE) -C $(KERNELDIR) M=`pwd` clean
-+
-diff --git a/services4/3rdparty/dc_omap3430_linux/Kbuild b/services4/3rdparty/dc_omap3430_linux/Kbuild
-new file mode 100644
-index 0000000..c08b240
---- /dev/null
-+++ b/services4/3rdparty/dc_omap3430_linux/Kbuild
-@@ -0,0 +1,8 @@
-+EXTRA_CFLAGS = -DLINUX \
-+ -I$(PVR_BUILD_DIR)/include4 \
-+ -I$(PVR_BUILD_DIR)/services4/include \
-+ -I$(PVR_BUILD_DIR)/services4/system/$(PVR_SYSTEM) \
-+ -I$(PVR_BUILD_DIR)/services4/system/include \
-+
-+obj-m := omaplfb.o
-+omaplfb-y := omaplfb_displayclass.o omaplfb_linux.o
---
-1.5.6.3
-
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-DSS2.patch b/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-DSS2.patch
deleted file mode 100644
index c319ac57a9..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-DSS2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
-+++ b/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
-@@ -171,7 +171,7 @@
- #if !defined (CONFIG_OMAP2_DSS)
- omap_dispc_free_irq(DISPC_IRQ_VSYNC, OMAPLFBVSyncISR, psSwapChain);
- #else
-- omap_dispc_unregister_isr(OMAPLFBVSyncISR);
-+ omap_dispc_unregister_isr(OMAPLFBVSyncISR, psSwapChain, DISPC_IRQ_VSYNC);
- #endif
- return PVRSRV_OK;
- }
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/build_es3.x_sgx.patch b/recipes/powervr-drivers/omap3-sgx-modules/build_es3.x_sgx.patch
deleted file mode 100644
index 93df6b3da5..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/build_es3.x_sgx.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/Makefile 2009-05-04 01:14:25.000000000 +0530
-+++ omap3-sgx-modules-1.3.13.1607/Makefile 2009-05-04 01:14:36.000000000 +0530
-@@ -10,7 +10,7 @@ export BUILD = debug
- export KBUILD_EXTRA_SYMBOLS = `pwd`/services4/srvkm/env/linux/kbuild/Module.symvers
-
- SGXCORE = 530
--CORE = -DSGX530 -DSUPPORT_SGX530 -DSGX_CORE_REV=103
-+CORE = -DSGX530 -DSUPPORT_SGX530 -DSGX_CORE_REV=121
-
- SUPPORT_SGX = 1
- SUPPORT_HW_RECOVERY = 1
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/omap3-sgx-modules-1.3.13.1607.tar.bz2 b/recipes/powervr-drivers/omap3-sgx-modules/omap3-sgx-modules-1.3.13.1607.tar.bz2
deleted file mode 100644
index 5c2fd6a0ab..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/omap3-sgx-modules-1.3.13.1607.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch b/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch
deleted file mode 100755
index 185191f4d8..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./services4/srvkm/env/linux/proc.c.orig 2009-10-09 13:46:40.000000000 -0500
-+++ ./services4/srvkm/env/linux/proc.c 2009-10-09 13:48:36.000000000 -0500
-@@ -134,7 +134,9 @@
-
- if (file)
- {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
- file->owner = THIS_MODULE;
-+#endif
- file->read_proc = rhandler;
- file->write_proc = whandler;
- file->data = data;
-@@ -165,7 +167,9 @@
-
- if (file)
- {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
- file->owner = THIS_MODULE;
-+#endif
-
- return 0;
- }
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/rotation-dss2.patch b/recipes/powervr-drivers/omap3-sgx-modules/rotation-dss2.patch
deleted file mode 100644
index ea4a6a10c6..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/rotation-dss2.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c 2009-01-22 17:08:25.000000000 +0530
-+++ b/services4/3rdparty/dc_omap3430_linux/omaplfb_displayclass.c 2009-04-25 16:43:22.000000000 +0530
-@@ -1014,8 +1014,16 @@
- psPVRFBInfo->sSysAddr.uiAddr = psLINFBInfo->fix.smem_start;
- psPVRFBInfo->sCPUVAddr = psLINFBInfo->screen_base;
-
-- psPVRFBInfo->ui32Width = psLINFBInfo->var.xres;
-- psPVRFBInfo->ui32Height = psLINFBInfo->var.yres;
-+ if ((psLINFBInfo->var.rotate == FB_ROTATE_CW)
-+ || (psLINFBInfo->var.rotate == FB_ROTATE_CCW) ) {
-+
-+ psPVRFBInfo->ui32Width = psLINFBInfo->var.yres;
-+ psPVRFBInfo->ui32Height = psLINFBInfo->var.xres;
-+
-+ } else {
-+ psPVRFBInfo->ui32Width = psLINFBInfo->var.xres;
-+ psPVRFBInfo->ui32Height = psLINFBInfo->var.yres;
-+ }
- psPVRFBInfo->ui32ByteStride = psLINFBInfo->fix.line_length;
- psPVRFBInfo->ui32FBSize = FBSize;
- psPVRFBInfo->ui32BufferSize = psPVRFBInfo->ui32Height * psPVRFBInfo->ui32ByteStride;
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/spurious-irq-fix.diff b/recipes/powervr-drivers/omap3-sgx-modules/spurious-irq-fix.diff
deleted file mode 100644
index c857fe713f..0000000000
--- a/recipes/powervr-drivers/omap3-sgx-modules/spurious-irq-fix.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/sgxinit.c 2009-02-20 21:24:01.000000000 +0100
-+++ omap3-sgx-modules-1.3.13.1397/services4/srvkm/devices/sgx/sgxinit.c 2009-02-20 21:25:17.000000000 +0100
-@@ -1139,6 +1139,8 @@
-
-
- OSWriteHWReg(psDevInfo->pvRegsBaseKM, EUR_CR_EVENT_HOST_CLEAR, ui32EventClear);
-+ //Read back to flush posted write to fix spurious IRQ
-+ OSReadHWReg(psDevInfo->pvRegsBaseKM, EUR_CR_EVENT_HOST_CLEAR);
- }
- }
-