aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2010-05-10 15:28:45 -0400
committerDenys Dmytriyenko <denis@denix.org>2010-05-18 15:59:08 -0400
commit36b166cd2d8dc058894496358cbbc7f1c155b339 (patch)
treead35145ebc6c317a5ff9207da2b72abf730f6618 /recipes/powervr-drivers
parent59599c1473da29f2459b745b6559910d9e10ef71 (diff)
downloadopenembedded-36b166cd2d8dc058894496358cbbc7f1c155b339.tar.gz
powervr-drivers: move GFX SDK bin from FILESPATH to DL_DIR
* Don't pollute the recipes/files directories with downloads - avoid git reporting the file as untracked * The same GFX SDK binary is required by libgles-omap3 and omap3-sgx-modules recipes and instructions tell to put them in separate FILESPATH directories, leading to confusion or duplication (it's half a GB file!) * Checksums are not verified for files in FILESPATH, only for DL_DIR Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/libgles-omap3.inc18
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb9
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.01.00.06.bb12
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb5
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb8
5 files changed, 26 insertions, 26 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3.inc b/recipes/powervr-drivers/libgles-omap3.inc
index e1a28bc855..dd832ad0fd 100644
--- a/recipes/powervr-drivers/libgles-omap3.inc
+++ b/recipes/powervr-drivers/libgles-omap3.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "libGLES for the omap3"
LICENSE = "proprietary-binary"
-PR = "r3"
+PR = "r4"
COMPATIBLE_MACHINE = "(dm3730-am3715-evm|am3517-evm|beagleboard|cm-t35|igep0020|omap3-pandora|omap3-touchbook|omap3evm|omapzoom|omapzoom2|overo|palmpre)"
@@ -14,15 +14,17 @@ PROVIDES += "virtual/egl"
#
# 1. if you don't already have a ti account get one here. it's free:
# http://www.ti.com/hdr_my_ti
-# 2. fetch the gl-es bin from here:
-# https://www-a.ti.com/downloads/sds_support/targetcontent/dvsdk/oslinux_dvsdk/v3_00_3530/OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin
-# (replace version in .bin file as appropriate)
-# 3. put the OMAP35x_*.bin file in libgles-omap3/
-# mv OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin ./libgles-omap3/
+# 2. fetch the gl-es bin (full OMAP Graphics SDK) from here:
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# 3. put the OMAP35x_*.bin file in $DL_DIR, i.e. downloads/
+# mv OMAP35x_Graphics_SDK_setuplinux_3_01_00_06.bin ./downloads/
+# 4. make the checksum file in ./downloads/ directory:
+# cd ./downloads/
+# md5sum OMAP35x_Graphics_SDK_setuplinux_3_01_00_06.bin > OMAP35x_Graphics_SDK_setuplinux_3_01_00_06.bin.md5
#
# voila!
-SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
+SRC_URI = "http://install.source.dir.local/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
file://cputype \
file://rc.pvr \
file://sample.desktop \
@@ -225,6 +227,8 @@ FILES_${PN}-frontwsegl = "${libdir}/libpvrPVR2D_FRONTWSEGL.so.* ${libdir}/*/libp
FILES_${PN}-linuxfbwsegl = "${libdir}/libpvrPVR2D_LINUXFBWSEGL.so.* ${libdir}/*/libpvrPVR2D_LINUXFBWSEGL.so.*"
FILES_${PN}-x11wsegl = "${libdir}/libpvrPVR2D_X11WSEGL.so* ${libdir}/*/libpvrPVR2D_X11WSEGL.so*"
+CONFFILES_${PN} = "${sysconfdir}/powervr.ini"
+
FILES_${PN} = "${sysconfdir} ${libdir}/lib*.so.* ${libdir}/ES*/* ${bindir}/pvrsrvinit ${bindir}/cputype ${bindir}/*/*"
FILES_xserver-kdrive-powervrsgx = "${bindir}/Xsgx"
FILES_${PN}-tests = "${bindir}/*"
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
index 129db3f6e2..3b68c18852 100644
--- a/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
+++ b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
@@ -5,14 +5,9 @@ require libgles-omap3.inc
PR = "r7"
# download required binary distribution from:
-# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
SGXPV = "3_01_00_02"
IMGPV = "1.4.14.2514"
BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
-
-
-
-
-
-
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.06.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.06.bb
index 8ed6d7f169..bb7994f70e 100644
--- a/recipes/powervr-drivers/libgles-omap3_3.01.00.06.bb
+++ b/recipes/powervr-drivers/libgles-omap3_3.01.00.06.bb
@@ -1,22 +1,18 @@
-
BINLOCATION = "${S}/gfx_rel_es3.x"
ES2LOCATION = "${S}/gfx_rel_es2.x"
ES3LOCATION = "${S}/gfx_rel_es3.x"
ES5LOCATION = "${S}/gfx_rel_es5.x"
-
require libgles-omap3.inc
# download required binary distribution from:
-# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_06.bin
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
SGXPV = "3_01_00_06"
IMGPV = "1.4.14.2616"
BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
-
-
-
-
-
+SRC_URI[md5sum] = "7aa37ca72f34011d353e72cc67f8aac1"
+SRC_URI[sha256sum] = "02276bc728699c36b0d2411c60f23030aa066ca6b8ed5adb7a40204563a227fb"
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
index c0532c0a9b..37d6c8a729 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
@@ -4,7 +4,8 @@ LICENSE = "GPLv2"
PR_append = "a"
# download required binary distribution from:
-# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
require ../ti/ti-eula-unpack.inc
@@ -13,7 +14,7 @@ SGXPV = "3_01_00_02"
IMGPV = "1.4.14.2514"
BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
-SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
+SRC_URI = "http://install.source.dir.local/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
file://0001-Compile-fixes-for-recent-kernels.patch;patch=1 \
"
S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
index d5eaf97c8c..202c8e6ef8 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
@@ -4,7 +4,8 @@ LICENSE = "GPLv2"
PR_append = "b"
# download required binary distribution from:
-# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_05.bin
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
require ../ti/ti-eula-unpack.inc
@@ -13,7 +14,7 @@ SGXPV = "3_01_00_06"
IMGPV = "1.4.14.2616"
BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
-SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
+SRC_URI = "http://install.source.dir.local/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
"
S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
@@ -32,3 +33,6 @@ do_install() {
${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
}
+
+SRC_URI[md5sum] = "7aa37ca72f34011d353e72cc67f8aac1"
+SRC_URI[sha256sum] = "02276bc728699c36b0d2411c60f23030aa066ca6b8ed5adb7a40204563a227fb"