aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-24 10:53:32 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-24 10:53:32 +0200
commit8c68e043e9cc061a1b7bf3ea28f77918107ace24 (patch)
tree4428e62b41fe5b83cf5f9b226d9f6c12c256f316 /recipes/powervr-drivers
parent7294db5d172bde3ff6ee83456f1254cbbe6e08de (diff)
downloadopenembedded-8c68e043e9cc061a1b7bf3ea28f77918107ace24.tar.gz
libgles-omap3: stage openvg headers as well
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/libgles-omap3.inc6
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb2
2 files changed, 6 insertions, 2 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3.inc b/recipes/powervr-drivers/libgles-omap3.inc
index 789632237b..f681ebb91f 100644
--- a/recipes/powervr-drivers/libgles-omap3.inc
+++ b/recipes/powervr-drivers/libgles-omap3.inc
@@ -98,7 +98,8 @@ do_install () {
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/* ${D}${includedir}/
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/LinuxOMAP3/Include/GLES/* ${D}${includedir}/GLES/
cp -pPr ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Builds/OGLES2/LinuxOMAP3/Include/GLES/* ${D}${includedir}/GLES2/
- cp -PPr ${S}/include/*.h ${D}${includedir} || true
+ cp -pPr ${S}/GFX_Linux_SDK/OVG/SDKPackage/Builds/OVG/Include/v* ${D}${includedir}/
+ cp -pPr ${S}/include/*.h ${D}${includedir} || true
install -d ${D}${sysconfdir}/init.d/
cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init
@@ -127,7 +128,8 @@ do_stage () {
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/* ${STAGING_INCDIR}/
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/LinuxOMAP3/Include/GLES/* ${STAGING_INCDIR}/GLES/
cp -pPr ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Builds/OGLES2/LinuxOMAP3/Include/GLES/* ${STAGING_INCDIR}/GLES2/
- cp -PPr ${S}/include/*.h ${STAGING_INCDIR} || true
+ cp -pPr ${S}/include/*.h ${STAGING_INCDIR} || true
+ cp -pPr ${S}/GFX_Linux_SDK/OVG/SDKPackage/Builds/OVG/Include/v* ${STAGING_INCDIR}/
}
pkg_postinst() {
diff --git a/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
index 6a04e8359b..2918deed25 100644
--- a/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
+++ b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
@@ -2,6 +2,8 @@ require libgles-omap3.inc
DEFAULT_PREFERENCE = "-1"
+PR = "r1"
+
SGXPV = "3_00_00_09"
IMGPV = "1.3.13.1832"
BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"