aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-03-17 16:18:32 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:26 +0200
commitcebcc0abfa75d4e66652b43bda9486d4954985cf (patch)
tree35526ec402818b87add3d39b46e6a0be88a1b25a /recipes/powervr-drivers
parent0eca1a33f9a7e95b00ce5b4b5375fc3b92a1ad6c (diff)
downloadopenembedded-cebcc0abfa75d4e66652b43bda9486d4954985cf.tar.gz
libgles-omap3, omap3-sgx-modules: add 3.01.00.05 release
* DEFAULT_PREFERENCE = "-1" till it becomes widely available * Hardcodes 3430, discussing with upstream to make it universal
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/libgles-omap3.inc18
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb23
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb35
3 files changed, 73 insertions, 3 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3.inc b/recipes/powervr-drivers/libgles-omap3.inc
index 2562ed6234..55a020686f 100644
--- a/recipes/powervr-drivers/libgles-omap3.inc
+++ b/recipes/powervr-drivers/libgles-omap3.inc
@@ -33,6 +33,9 @@ TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
require ../ti/ti-eula-unpack.inc
BINLOCATION ?= "${S}/gfx_rel"
+ES2LOCATION ?= "${S}/gfx_rel_es2.x"
+ES3LOCATION ?= "${S}/gfx_rel_es3.x"
+ES5LOCATION ?= "${S}/gfx_rel_es5.x"
do_configure() {
# Attempt to fix up the worst offenders for file permissions
@@ -155,19 +158,28 @@ do_install () {
echo "[default]" > ${D}${sysconfdir}/powervr.ini
echo "WindowSystem=libpvrPVR2D_FRONTWSEGL.so" >> ${D}${sysconfdir}/powervr.ini
- # The ES2.x and ES3.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
+ # The ES2.x, ES3.x and ES5.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
+ install -d ${D}${libdir}/ES5.0
install -d ${D}${libdir}/ES3.0
install -d ${D}${libdir}/ES2.0
+
+ install -d ${D}${bindir}/ES5.0
install -d ${D}${bindir}/ES3.0
install -d ${D}${bindir}/ES2.0
- cp -pPR ${S}/gfx_rel_es2.x/lib* ${D}${libdir}/ES2.0/
- cp ${S}/gfx_rel_es2.x//p[dv]* ${D}${bindir}/ES2.0/
+
+ cp -pPR ${ES2LOCATION}/lib*${IMGPV} ${D}${libdir}/ES2.0/
+ cp ${ES2LOCATION}/p[dv]* ${D}${bindir}/ES2.0/
cp -pPR ${D}${libdir}/lib*${IMGPV} ${D}${libdir}/ES3.0/
cp ${D}${bindir}/p[dv]* ${D}${bindir}/ES3.0
+ if [ -e ${ES5LOCATION} ] ; then
+ cp -pPR ${ES5LOCATION}/lib*${IMGPV} ${D}${libdir}/ES5.0/
+ cp ${ES3LOCATION}/p[dv]* ${D}${bindir}/ES5.0/
+ fi
+
install -d ${D}${prefix}/share/applications
cp ${WORKDIR}/*.desktop ${D}${prefix}/share/applications
rm ${D}${prefix}/share/applications/sample.desktop
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb
new file mode 100644
index 0000000000..4d98186e2e
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb
@@ -0,0 +1,23 @@
+DEFAULT_PREFERENCE = "-1"
+
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+ES2LOCATION = "${S}/gfx_rel_es2.x"
+ES3LOCATION = "${S}/gfx_rel_es3.x"
+ES5LOCATION = "${S}/gfx_rel_es5.x"
+
+
+require libgles-omap3.inc
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
+
+SGXPV = "3_01_00_05"
+IMGPV = "1.4.14.2616"
+BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+
+
+
+
+
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
new file mode 100644
index 0000000000..8c4c7569b0
--- /dev/null
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
+LICENSE = "GPLv2"
+
+DEFAULT_PREFERENCE = "-1"
+PR_append = "a"
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_05.bin
+
+TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
+require ../ti/ti-eula-unpack.inc
+
+SGXPV = "3_01_00_05"
+IMGPV = "1.4.14.2616"
+BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
+"
+S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
+
+inherit module
+
+PVRBUILD = "release"
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=omap3430"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+ cp ${S}/pvrsrvkm.ko \
+ ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko \
+ ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
+ ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+}