aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ppp-dialin
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ppp-dialin
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ppp-dialin')
-rw-r--r--recipes/ppp-dialin/files/host-peer11
-rw-r--r--recipes/ppp-dialin/files/ppp-dialin3
-rw-r--r--recipes/ppp-dialin/ppp-dialin_0.1.bb35
3 files changed, 49 insertions, 0 deletions
diff --git a/recipes/ppp-dialin/files/host-peer b/recipes/ppp-dialin/files/host-peer
new file mode 100644
index 0000000000..e7e2e11d49
--- /dev/null
+++ b/recipes/ppp-dialin/files/host-peer
@@ -0,0 +1,11 @@
+-detach
+defaultroute
+nocrtscts
+lock
+noauth
+lcp-echo-interval 5
+lcp-echo-failure 3
+usepeerdns
+115200
+local
+asyncmap 0
diff --git a/recipes/ppp-dialin/files/ppp-dialin b/recipes/ppp-dialin/files/ppp-dialin
new file mode 100644
index 0000000000..ea2771311a
--- /dev/null
+++ b/recipes/ppp-dialin/files/ppp-dialin
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/sbin/pppd call host
diff --git a/recipes/ppp-dialin/ppp-dialin_0.1.bb b/recipes/ppp-dialin/ppp-dialin_0.1.bb
new file mode 100644
index 0000000000..51a4a2b32d
--- /dev/null
+++ b/recipes/ppp-dialin/ppp-dialin_0.1.bb
@@ -0,0 +1,35 @@
+SECTION = "console/network"
+DESCRIPTION = "Enables PPP dial-in through a serial connection"
+DEPENDS = "ppp"
+RDEPENDS = "ppp"
+PR = "r6"
+LICENSE = "MIT"
+
+SRC_URI = "file://host-peer \
+ file://ppp-dialin"
+
+do_install() {
+ install -d ${D}${sysconfdir}/ppp/peers
+ install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
+}
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ grep "^ppp:" /etc/passwd > /dev/null || adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
+fi
+}
+
+pkg_postrm() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ deluser ppp || true
+fi
+}