summaryrefslogtreecommitdiffstats
path: root/recipes/ppp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-28 09:08:26 -0700
committerKhem Raj <raj.khem@gmail.com>2010-03-28 09:12:10 -0700
commitb16fd743a61c22d98083a8a33072c73a7bcd8ab6 (patch)
tree70b51ce138c3f85912daaddf0e7d8c62a6d292c4 /recipes/ppp
parent7344f7349900e90fb3a4bb1f489e167b3524e785 (diff)
downloadopenembedded-b16fd743a61c22d98083a8a33072c73a7bcd8ab6.tar.gz
ppp: Prepend ${D} to INCDIR
* Right now it tries to install into /usr/include on build where it should be in the staged areas. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ppp')
-rw-r--r--recipes/ppp/ppp_2.4.3.bb4
-rw-r--r--recipes/ppp/ppp_2.4.4.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/ppp/ppp_2.4.3.bb b/recipes/ppp/ppp_2.4.3.bb
index 6936dd98cc..7c2e872f4c 100644
--- a/recipes/ppp/ppp_2.4.3.bb
+++ b/recipes/ppp/ppp_2.4.3.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
HOMEPAGE = "http://samba.org/ppp/"
DEPENDS = "libpcap"
LICENSE = "BSD GPLv2"
-PR = "r8"
+PR = "r9"
SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
file://ppp-2.4.3-mppe-mppc-1.1.patch;patch=1 \
@@ -31,7 +31,7 @@ EXTRA_OEMAKE = "STRIPPROG=${STRIP} MANDIR=${D}${datadir}/man/man8 INCDIR=${D}/us
EXTRA_OECONF = "--disable-strip"
do_install_append () {
- make INCDIR=${includedir} install-devel
+ make INCDIR=${D}/${includedir} install-devel
make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp
mkdir -p ${D}${bindir}/ ${D}${sysconfdir}/init.d
mkdir -p ${D}${sysconfdir}/ppp/ip-up.d/
diff --git a/recipes/ppp/ppp_2.4.4.bb b/recipes/ppp/ppp_2.4.4.bb
index 81ec3e0737..fc4d79e7ed 100644
--- a/recipes/ppp/ppp_2.4.4.bb
+++ b/recipes/ppp/ppp_2.4.4.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
HOMEPAGE = "http://samba.org/ppp/"
DEPENDS = "libpcap"
LICENSE = "BSD GPLv2"
-
+PR = "r1"
# Not well tested
DEFAULT_PREFERENCE = "-1"
@@ -33,7 +33,7 @@ EXTRA_OEMAKE = "STRIPPROG=${STRIP} MANDIR=${D}${datadir}/man/man8 INCDIR=${D}${i
EXTRA_OECONF = "--disable-strip"
do_install_append () {
- make INCDIR=${includedir} install-devel
+ make INCDIR=${D}/${includedir} install-devel
make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp
mkdir -p ${D}${bindir}/ ${D}${sysconfdir}/init.d
mkdir -p ${D}${sysconfdir}/ppp/ip-up.d/