summaryrefslogtreecommitdiffstats
path: root/recipes/ppp
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-03-27 17:28:08 +0100
committerThomas Zimmermann <ml@vdm-design.de>2010-03-27 17:28:08 +0100
commiteb594c1c5fba3c31bc785bdc537fcb928f014555 (patch)
tree9c9933536f3ddfc4baeaf8eb008bd96487ae4728 /recipes/ppp
parentf28a367b54624446c66d0939ee8d229da4e982ce (diff)
downloadopenembedded-eb594c1c5fba3c31bc785bdc537fcb928f014555.tar.gz
ppp: make if-up/-down scripts compatible to resolvconf (thx to Wonka)
Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
Diffstat (limited to 'recipes/ppp')
-rw-r--r--recipes/ppp/files/08setupdns4
-rw-r--r--recipes/ppp/files/92removedns4
-rw-r--r--recipes/ppp/ppp_2.4.3.bb2
3 files changed, 7 insertions, 3 deletions
diff --git a/recipes/ppp/files/08setupdns b/recipes/ppp/files/08setupdns
index 998219de97..5be2d3831b 100644
--- a/recipes/ppp/files/08setupdns
+++ b/recipes/ppp/files/08setupdns
@@ -1,7 +1,9 @@
#!/bin/sh
ACTUALCONF=/var/run/resolv.conf
PPPCONF=/var/run/ppp/resolv.conf
-if [ -f $PPPCONF ] ; then
+if [ -x /sbin/resolvconf ] ; then
+ cat $PPPCONF | resolvconf -a $PPP_IFACE
+elif [ -f $PPPCONF ] ; then
if [ -f $ACTUALCONF ] ; then
if [ ! -h $ACTUALCONF -o ! "`readlink $ACTUALCONF 2>&1`" = "$PPPCONF" ] ; then
mv $ACTUALCONF $ACTUALCONF.ppporig
diff --git a/recipes/ppp/files/92removedns b/recipes/ppp/files/92removedns
index 2eadec6899..aa3304db76 100644
--- a/recipes/ppp/files/92removedns
+++ b/recipes/ppp/files/92removedns
@@ -1,5 +1,7 @@
#!/bin/sh
ACTUALCONF=/var/run/resolv.conf
-if [ -f $ACTUALCONF.ppporig ] ; then
+if [ -x /sbin/resolvconf ] ; then
+ resolvconf -d $PPP_IFACE
+elif [ -f $ACTUALCONF.ppporig ] ; then
mv $ACTUALCONF.ppporig $ACTUALCONF
fi
diff --git a/recipes/ppp/ppp_2.4.3.bb b/recipes/ppp/ppp_2.4.3.bb
index 3b1f8ad28d..4c7b16876f 100644
--- a/recipes/ppp/ppp_2.4.3.bb
+++ b/recipes/ppp/ppp_2.4.3.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
HOMEPAGE = "http://samba.org/ppp/"
DEPENDS = "libpcap"
LICENSE = "BSD GPLv2"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
file://ppp-2.4.3-mppe-mppc-1.1.patch;patch=1 \