aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pptp-linux/pptp-linux_1.5.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pptp-linux/pptp-linux_1.5.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pptp-linux/pptp-linux_1.5.0.bb')
-rw-r--r--recipes/pptp-linux/pptp-linux_1.5.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/pptp-linux/pptp-linux_1.5.0.bb b/recipes/pptp-linux/pptp-linux_1.5.0.bb
new file mode 100644
index 0000000000..68551443fa
--- /dev/null
+++ b/recipes/pptp-linux/pptp-linux_1.5.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD\
+and OpenBSD client for the proprietary Microsoft Point-to-Point \
+Tunneling Protocol, PPTP. Allows connection to a PPTP based \
+Virtual Private Network (VPN) as used by employers and some \
+cable and ADSL internet service providers."
+LICENSE = "GPL"
+SECTION = "network"
+PRIORITY = "optional"
+DEPENDS = "ppp "
+
+inherit base
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pptpclient/pptp-linux-1.5.0.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://options.pptp"
+
+
+do_configure() {
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}/etc/
+ install -d ${D}/etc/ppp/
+
+ install -m 0755 pptp ${D}${sbindir}/
+ install -m 0644 ${WORKDIR}/options.pptp ${D}/etc/ppp/
+
+}