aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/prelink/prelink_20061027.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2009-07-15 13:23:10 -0700
committerChris Larson <clarson@mvista.com>2009-11-03 13:15:58 -0700
commitfbccdee191234fe422df187261de313eb7c15257 (patch)
tree2a501fa089704d3596996049856842134bb593de /recipes/prelink/prelink_20061027.bb
parenta9bbc07ae8cc1abe0925551845af1d10517e56a3 (diff)
downloadopenembedded-fbccdee191234fe422df187261de313eb7c15257.tar.gz
prelink: pull in /etc/cron.daily/prelink in the postinst.
The cron script obeys /etc/default/prelink, so this ensures that the postinst also obeys it. Also changes postrm to use the same logic as the cron script for the prelink uninstallation. Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/prelink/prelink_20061027.bb')
-rw-r--r--recipes/prelink/prelink_20061027.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes/prelink/prelink_20061027.bb b/recipes/prelink/prelink_20061027.bb
index b650c2c2f1..83f33f382c 100644
--- a/recipes/prelink/prelink_20061027.bb
+++ b/recipes/prelink/prelink_20061027.bb
@@ -4,7 +4,7 @@ DESCRIPTION = " The prelink package contains a utility which modifies ELF shared
and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
file://prelink.conf \
@@ -35,12 +35,15 @@ if [ "x$D" != "x" ]; then
exit 1
fi
-prelink -a
+. ${sysconfdir}/cron.daily/prelink
}
pkg_prerm_prelink() {
#!/bin/sh
-prelink -au
+if [ -f ${sysconfdir}/prelink.cache ]; then
+ prelink -au
+ rm -f ${sysconfdir}/prelink.cache
+fi
}