aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/prismstumbler
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-29 23:14:04 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:15:06 -0700
commite43cc49ace4692287a4e31e72079727cef329b6b (patch)
tree1174daee2d6bdf9fdead5972d6cc521339531d87 /recipes/prismstumbler
parent28c05be128948ab24388177c3f64b55a88a29cd6 (diff)
downloadopenembedded-e43cc49ace4692287a4e31e72079727cef329b6b.tar.gz
prismstumbler_0.7.3+0.7.4pre1.bb: Add patch to replace gps_query call
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/prismstumbler')
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/replace-gps_query.patch17
-rw-r--r--recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb6
2 files changed, 21 insertions, 2 deletions
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/replace-gps_query.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/replace-gps_query.patch
new file mode 100644
index 0000000000..9473971541
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/replace-gps_query.patch
@@ -0,0 +1,17 @@
+As per http://gpsd.berlios.de/protocol-transition.html#_virtue_is_rewarded
+gps_query should be replace with gps_stream
+
+Thanks
+-Khem
+Index: prismstumbler-0.7.4pre1/src/daemon/gpsctl.c
+===================================================================
+--- prismstumbler-0.7.4pre1.orig/src/daemon/gpsctl.c
++++ prismstumbler-0.7.4pre1/src/daemon/gpsctl.c
+@@ -41,6 +41,5 @@ update_gpsdata ()
+ {
+ if(!gps_conn)
+ return;
+-
+- gps_query (gps_conn, "p");
++ gps_stream(gps_conn, WATCH_ENABLE, NULL);
+ }
diff --git a/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
index de51ba0978..75e5bfbc37 100644
--- a/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
+++ b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
@@ -1,5 +1,5 @@
SECTION = "x11/network"
-PR = "r5"
+PR = "r6"
PACKAGES = "${PN}-dbg prismstumbler prismstumbler-frontend prismstumbler-doc"
DESCRIPTION = "Prismstumbler wireless LAN scanner"
@@ -15,7 +15,9 @@ SRC_URI = "http://projects.linuxtogo.org/frs/download.php/14/${PN}-0.7.4pre1.tar
file://gpsapi.patch \
${@['', 'file://wireless.patch'][bb.data.getVar('PREFERRED_VERSION_linux-libc-headers', d, 1) and bb.data.getVar('PREFERRED_VERSION_linux-libc-headers', d, 1).split('.')[2] < '30']} \
file://fix-includes.patch;striplevel=0 \
- file://libgps-check.patch"
+ file://libgps-check.patch \
+ file://replace-gps_query.patch \
+ "
S = "${WORKDIR}/${PN}-0.7.4pre1"