summaryrefslogtreecommitdiffstats
path: root/recipes/procps
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-04 11:23:28 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-05 19:19:54 -0700
commit8c2c7d80a8386b907e95cce3efcc02e59c5924c2 (patch)
treefe6458aa145c012eb4df6207db5a29d8d4e92935 /recipes/procps
parentf4c7ff92f9add8d55315bdb50d7eab6b8adabbe0 (diff)
downloadopenembedded-8c2c7d80a8386b907e95cce3efcc02e59c5924c2.tar.gz
procps_3.2.7.bb: Fix compilation when usr/bin is same as /bin
* On DISTROs like micro where bindir and base_bindir are same, procps does not compile because it wants to install binaries in both places. We have to pass the variable to make file since it does not use autotools. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/procps')
-rw-r--r--recipes/procps/procps_3.2.7.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/procps/procps_3.2.7.bb b/recipes/procps/procps_3.2.7.bb
index 6da975adc7..b31b683708 100644
--- a/recipes/procps/procps_3.2.7.bb
+++ b/recipes/procps/procps_3.2.7.bb
@@ -1,6 +1,6 @@
require procps.inc
-PR = "r8"
+PR = "r9"
inherit update-rc.d
@@ -23,6 +23,9 @@ CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"
EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
CPPFLAGS=-I${STAGING_INCDIR} \
+ usr/bin=${D}${bindir}/ \
+ bin=${D}${base_bindir}/ \
+ usr/proc/bin=${D}${bindir}/ \
LDFLAGS="${LDFLAGS}" \
CURSES=-lncurses \
install='install -D' \