aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/proftpd/files
diff options
context:
space:
mode:
authorfrans <frans@linux-suse.(none)>2009-09-30 15:53:39 +0200
committerfrans <frans@linux-suse.(none)>2009-09-30 15:53:39 +0200
commit2bd89915c3ed05864641ec982fe39bc5c6505cca (patch)
treed20588ab882b58cde528cbbdb07d5b3e6a2d71b4 /recipes/proftpd/files
parent0427b295ab7f42d0df44daecceb1d34660099ceb (diff)
downloadopenembedded-2bd89915c3ed05864641ec982fe39bc5c6505cca.tar.gz
proftpd: fixed makefile issue (replaced CC by BUILD_CC)
Diffstat (limited to 'recipes/proftpd/files')
-rw-r--r--recipes/proftpd/files/make.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/proftpd/files/make.patch b/recipes/proftpd/files/make.patch
index 66ebf2ce89..3e8109f373 100644
--- a/recipes/proftpd/files/make.patch
+++ b/recipes/proftpd/files/make.patch
@@ -49,3 +49,16 @@ Index: proftpd-1.3.2/Make.rules.in
RM=rm -f
SHELL=/bin/sh
+Index: proftpd-1.3.2/lib/libcap/Makefile
+===================================================================
+--- proftpd-1.3.2.orig/lib/libcap/Makefile
++++ proftpd-1.3.2/lib/libcap/Makefile
+@@ -26,7 +26,7 @@ OBJS=$(addsuffix .o, $(FILES))
+ all: $(LIBNAME)
+
+ _makenames: _makenames.c cap_names.sed
+- $(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
++ $(BUILD_CC) $(CFLAGS) $(LDFLAGS) $< -o $@
+
+ cap_names.h: _makenames
+ ./_makenames > cap_names.h