aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/proxy-libintl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-07-24 14:26:02 -0700
committerKhem Raj <raj.khem@gmail.com>2010-07-25 07:48:44 -0700
commit48724742e863d274b9736d2609d9b3976ce5d200 (patch)
tree5844bbdce412c396a929a00e777d30edc4d51cb7 /recipes/proxy-libintl
parent7b5228d350af1af43226ecbccfdffaf968c35e68 (diff)
downloadopenembedded-48724742e863d274b9736d2609d9b3976ce5d200.tar.gz
proxy-libintl: Eliminate the compile rule in makefile
* This rule is not needed because we do not pass correct CFLAGS so on architectures where PIC really matters it does not work. Therefore make is more consistent and let -shared decide what flag to use for PIC'ness Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/proxy-libintl')
-rw-r--r--recipes/proxy-libintl/proxy-libintl-20080418/soname.patch22
-rw-r--r--recipes/proxy-libintl/proxy-libintl_20080418.bb5
2 files changed, 17 insertions, 10 deletions
diff --git a/recipes/proxy-libintl/proxy-libintl-20080418/soname.patch b/recipes/proxy-libintl/proxy-libintl-20080418/soname.patch
index d2e8064372..4e2c1172be 100644
--- a/recipes/proxy-libintl/proxy-libintl-20080418/soname.patch
+++ b/recipes/proxy-libintl/proxy-libintl-20080418/soname.patch
@@ -1,13 +1,23 @@
-Index: proxy-libintl-20080418-r1/src/proxy-libintl/Makefile
+Index: proxy-libintl-20080418-r5/src/proxy-libintl/Makefile
===================================================================
---- proxy-libintl-20080418-r1.orig/src/proxy-libintl/Makefile
-+++ proxy-libintl-20080418-r1/src/proxy-libintl/Makefile
-@@ -7,7 +7,7 @@ CFLAGS = -Wall -I ../../include
+--- proxy-libintl-20080418-r5.orig/src/proxy-libintl/Makefile 2010-07-24 02:54:48.766605000 -0700
++++ proxy-libintl-20080418-r5/src/proxy-libintl/Makefile 2010-07-24 10:14:28.446605000 -0700
+@@ -6,16 +6,13 @@ CFLAGS = -Wall -I ../../include
+
all : ../../lib/libintl.so ../../lib/intl.lib
- ../../lib/libintl.so : libintl.o
+-../../lib/libintl.so : libintl.o
- $(CC) -shared -o $@ libintl.o
-+ $(CC) -shared -Wl,-soname -Wl,libintl.so -o $@ libintl.o
++../../lib/libintl.so : libintl.c
++ $(CC) $(CFLAGS) -shared -Wl,-soname -Wl,libintl.so -o $@
../../lib/intl.lib : ../../lib/libintl.so
cp ../../lib/libintl.so $@
+ $(STRIP) --strip-unneeded $@
+
+-libintl.o : libintl.c
+- $(CC) $(CFLAGS) -c libintl.c
+-
+ clean :
+ rm -f *.o ../../lib/libintl.so ../../$(ZIPFILE)
+
diff --git a/recipes/proxy-libintl/proxy-libintl_20080418.bb b/recipes/proxy-libintl/proxy-libintl_20080418.bb
index 0802365310..68e9fce507 100644
--- a/recipes/proxy-libintl/proxy-libintl_20080418.bb
+++ b/recipes/proxy-libintl/proxy-libintl_20080418.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/binaries/win32/dependencies/"
SECTION = "libs"
LICENSE = "LGPL"
-PR = "r5"
+PR = "r6"
PROVIDES = "virtual/libintl"
SRC_URI = " \
@@ -19,9 +19,6 @@ FILES_${PN} = "${libdir}/libintl.so"
CFLAGS_append = " -Wall -I ../../include ${@['-DSTUB_ONLY', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']}"
TARGET_CC_ARCH += "${LDFLAGS}"
-CFLAGS_append_mips = " -fPIC"
-CFLAGS_append_mipsel = " -fPIC"
-CFLAGS_append_x86_64 = " -fPIC"
do_compile() {
cd ${WORKDIR}/src/proxy-libintl