aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/psplash
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/psplash
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/psplash')
-rw-r--r--recipes/psplash/files/psplash-init2
-rw-r--r--recipes/psplash/files/splashfuncs29
-rw-r--r--recipes/psplash/files/zzapsplash-init4
-rw-r--r--recipes/psplash/psplash-angstrom_svn.bb1
-rw-r--r--recipes/psplash/psplash.inc11
-rw-r--r--recipes/psplash/psplash_svn.bb3
6 files changed, 43 insertions, 7 deletions
diff --git a/recipes/psplash/files/psplash-init b/recipes/psplash/files/psplash-init
index a4fb1dc7d1..0409240232 100644
--- a/recipes/psplash/files/psplash-init
+++ b/recipes/psplash/files/psplash-init
@@ -15,7 +15,7 @@ case `machine_id` in
PARAMS='-a 270' ;;
esac
-export TMPDIR=/mnt/.psplash
+export TMPDIR=/mnt/.splash
mount tmpfs -t tmpfs $TMPDIR -o,size=40k
/usr/bin/psplash $PARAMS &
diff --git a/recipes/psplash/files/splashfuncs b/recipes/psplash/files/splashfuncs
new file mode 100644
index 0000000000..ada2a96dd4
--- /dev/null
+++ b/recipes/psplash/files/splashfuncs
@@ -0,0 +1,29 @@
+status() {
+ if type splash-write >/dev/null 2>&1; then
+ (TMPDIR="/mnt/.splash" EXQUISITE_IPC="$TMPDIR/exquisite" splash-write "$1" || true) &
+ fi
+}
+
+status_position() {
+ status "PROGRESS $1"
+}
+
+status_title() {
+ status "TITLE $1"
+}
+
+status_text() {
+ if test -n "$1"; then
+ status "MSG $1"
+ else
+ status "CLEAR"
+ fi
+}
+
+status_pulse() {
+ status "PULSATE"
+}
+
+status_tick() {
+ status "TICK"
+}
diff --git a/recipes/psplash/files/zzapsplash-init b/recipes/psplash/files/zzapsplash-init
index 5a713e5701..19e18960b6 100644
--- a/recipes/psplash/files/zzapsplash-init
+++ b/recipes/psplash/files/zzapsplash-init
@@ -1,4 +1,4 @@
#!/bin/sh
-TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
+TMPDIR=/mnt/.splash psplash-write "QUIT" || true
sleep 1
-umount /mnt/.psplash >/dev/null 2>/dev/null
+umount /mnt/.splash >/dev/null 2>/dev/null
diff --git a/recipes/psplash/psplash-angstrom_svn.bb b/recipes/psplash/psplash-angstrom_svn.bb
index 401afdfda9..f65fb81429 100644
--- a/recipes/psplash/psplash-angstrom_svn.bb
+++ b/recipes/psplash/psplash-angstrom_svn.bb
@@ -14,6 +14,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-hand-img.h \
file://psplash-bar-img.h \
file://psplash-default \
+ file://splashfuncs \
file://psplash-init"
S = "${WORKDIR}/psplash"
diff --git a/recipes/psplash/psplash.inc b/recipes/psplash/psplash.inc
index 89464694bc..a038f63f1c 100644
--- a/recipes/psplash/psplash.inc
+++ b/recipes/psplash/psplash.inc
@@ -5,9 +5,10 @@ LICENSE = "GPL"
RDEPENDS = "initscripts"
PROVIDES = "virtual/psplash"
RPROVIDES_${PN} = "virtual/psplash"
+RCONFLICTS_${PN} = "exquisite"
PV = "0.0+svnr${SRCREV}"
-PR = "r2"
+PR = "r20"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
@@ -27,11 +28,15 @@ do_configure_append() {
}
do_install_prepend() {
- install -d ${D}/mnt/.psplash/
+ install -d ${D}/mnt/.splash/
install -d ${D}${sysconfdir}/default/
install -m 0644 ${WORKDIR}/psplash-default ${D}${sysconfdir}/default/psplash
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+ install -d ${D}${bindir}
+ ln -s psplash-write ${D}${bindir}/splash-write
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
}
INITSCRIPT_NAME = "psplash"
@@ -40,4 +45,4 @@ INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
PACKAGES =+ "psplash-support"
RDEPENDS_${PN} += "psplash-support"
-FILES_psplash-support += "/mnt/.psplash ${sysconfdir} ${bindir}/psplash-write"
+FILES_psplash-support += "/mnt/.splash ${sysconfdir} ${bindir}/psplash-write ${bindir}/splash-write"
diff --git a/recipes/psplash/psplash_svn.bb b/recipes/psplash/psplash_svn.bb
index cb370b7627..8119ccf1e7 100644
--- a/recipes/psplash/psplash_svn.bb
+++ b/recipes/psplash/psplash_svn.bb
@@ -3,12 +3,13 @@ require psplash-ua.inc
ALTERNATIVE_PRIORITY = "10"
-PR = "r19"
+PR = "r20"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-hand-img.h \
file://psplash-bar-img.h \
file://psplash-default \
+ file://splashfuncs \
file://psplash-init"
S = "${WORKDIR}/psplash"