aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pth
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pth
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pth')
-rw-r--r--recipes/pth/files/m4-warning.patch34
-rw-r--r--recipes/pth/pth_2.0.0.bb27
-rw-r--r--recipes/pth/pth_2.0.2.bb31
3 files changed, 92 insertions, 0 deletions
diff --git a/recipes/pth/files/m4-warning.patch b/recipes/pth/files/m4-warning.patch
new file mode 100644
index 0000000000..6cdc5bbd61
--- /dev/null
+++ b/recipes/pth/files/m4-warning.patch
@@ -0,0 +1,34 @@
+Index: pth-2.0.2/pth.m4
+===================================================================
+--- pth-2.0.2.orig/pth.m4 2004-09-12 13:40:59.000000000 +0200
++++ pth-2.0.2/pth.m4 2008-05-03 16:31:46.000000000 +0200
+@@ -40,7 +40,7 @@
+ dnl ##
+ dnl
+ dnl # auxilliary macros
+-AC_DEFUN(_AC_PTH_ERROR, [dnl
++AC_DEFUN([_AC_PTH_ERROR], [dnl
+ AC_MSG_RESULT([*FAILED*])
+ m4_define(_ac_pth_line,dnl
+ "+------------------------------------------------------------------------+")
+@@ -51,13 +51,13 @@
+ echo " _ac_pth_line" 1>&2
+ exit 1
+ ])
+-AC_DEFUN(_AC_PTH_VERBOSE, [dnl
++AC_DEFUN([_AC_PTH_VERBOSE], [dnl
+ if test ".$verbose" = .yes; then
+ AC_MSG_RESULT([ $1])
+ fi
+ ])
+ dnl # the user macro
+-AC_DEFUN(AC_CHECK_PTH, [dnl
++AC_DEFUN([AC_CHECK_PTH], [dnl
+ dnl
+ dnl # prerequisites
+ AC_REQUIRE([AC_PROG_CC])dnl
+@@ -399,4 +399,3 @@
+ ifelse([$6], , :, [$6])
+ fi
+ ])
+-
diff --git a/recipes/pth/pth_2.0.0.bb b/recipes/pth/pth_2.0.0.bb
new file mode 100644
index 0000000000..8c7f5772a4
--- /dev/null
+++ b/recipes/pth/pth_2.0.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/pth/pth-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/pth/pth_2.0.2.bb b/recipes/pth/pth_2.0.2.bb
new file mode 100644
index 0000000000..81b8a71b63
--- /dev/null
+++ b/recipes/pth/pth_2.0.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
+ file://m4-warning.patch;patch=1 \
+ "
+
+PARALLEL_MAKE=""
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}